aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb')
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb
index c7e65dfe..ad324dce 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb
@@ -22,7 +22,9 @@ SRC_URI = "git://github.com/LunarG/VulkanTools;branch=sdk-${PV} \
file://0001-CMakeLists-add-include-path-so-Xlib.h-is-found-as-ne.patch \
file://0002-obey-CMAKE_INSTALL_LIBDIR.patch \
file://0003-vktrace-do-not-link-to-internal-loader.patch\
- file://0004-json-correct-layer-lib-paths.patch"
+ file://0004-json-correct-layer-lib-paths.patch \
+ file://0005-CMakeLists-add-include-paths-for-xcb-and-Xlib.patch \
+"
EXTRA_OECMAKE = " \
-DBUILD_LOADER=0 \
@@ -51,3 +53,15 @@ do_install_append() {
cp -f ${S}/layersvt/${HOST_OS}/*.json ${D}${sysconfdir}/vulkan/explicit_layer.d
cp -f ${S}/vktrace/src/vktrace_layer/${HOST_OS}/*.json ${D}${sysconfdir}/vulkan/explicit_layer.d
}
+
+# Conditional building of vktraceviewer
+QTBITS ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'cmake_qt5', '',d)}"
+inherit ${QTBITS}
+DEPENDS += "${@base_conditional('QTBITS', '', '', 'libxcb', d)}"
+RDEPENDS_${PN}_append = " ${@base_conditional('QTBITS', '', '', 'qtsvg', d)}"
+do_install_append() {
+ if [ "${QTBITS}" != "" ]
+ then
+ install ${B}/vktrace/vktraceviewer ${D}${bindir}
+ fi
+}