aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/4027-drm-amdgpu-make-pmu-support-optional-again.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/4027-drm-amdgpu-make-pmu-support-optional-again.patch')
-rw-r--r--meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/4027-drm-amdgpu-make-pmu-support-optional-again.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/4027-drm-amdgpu-make-pmu-support-optional-again.patch b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/4027-drm-amdgpu-make-pmu-support-optional-again.patch
new file mode 100644
index 00000000..c2260940
--- /dev/null
+++ b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/4027-drm-amdgpu-make-pmu-support-optional-again.patch
@@ -0,0 +1,43 @@
+From d6b2843bd2523abf10cdb00df252d28044c89b3e Mon Sep 17 00:00:00 2001
+From: Arnd Bergmann <arnd@arndb.de>
+Date: Wed, 2 Oct 2019 14:01:22 +0200
+Subject: [PATCH 4027/4256] drm/amdgpu: make pmu support optional, again
+
+When CONFIG_PERF_EVENTS is disabled, we cannot compile the pmu
+portion of the amdgpu driver:
+
+drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c:48:38: error: no member named 'hw' in 'struct perf_event'
+ struct hw_perf_event *hwc = &event->hw;
+ ~~~~~ ^
+drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c:51:13: error: no member named 'attr' in 'struct perf_event'
+ if (event->attr.type != event->pmu->type)
+ ~~~~~ ^
+...
+
+The same bug was already fixed by commit d155bef0636e ("amdgpu: make pmu
+support optional") but broken again by what looks like an incorrectly
+rebased patch.
+
+Fixes: 64f55e629237 ("drm/amdgpu: Add RAS EEPROM table.")
+Signed-off-by: Arnd Bergmann <arnd@arndb.de>
+Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
+---
+ drivers/gpu/drm/amd/amdgpu/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/gpu/drm/amd/amdgpu/Makefile b/drivers/gpu/drm/amd/amdgpu/Makefile
+index 22c4bcbe7001..fa5703505748 100644
+--- a/drivers/gpu/drm/amd/amdgpu/Makefile
++++ b/drivers/gpu/drm/amd/amdgpu/Makefile
+@@ -54,7 +54,7 @@ amdgpu-y += amdgpu_device.o amdgpu_kms.o \
+ amdgpu_gtt_mgr.o amdgpu_vram_mgr.o amdgpu_virt.o amdgpu_atomfirmware.o \
+ amdgpu_vf_error.o amdgpu_sched.o amdgpu_debugfs.o amdgpu_ids.o \
+ amdgpu_gmc.o amdgpu_mmhub.o amdgpu_xgmi.o amdgpu_csa.o amdgpu_sem.o \
+- amdgpu_ras.o amdgpu_vm_cpu.o amdgpu_vm_sdma.o amdgpu_pmu.o \
++ amdgpu_ras.o amdgpu_vm_cpu.o amdgpu_vm_sdma.o \
+ amdgpu_discovery.o amdgpu_ras_eeprom.o amdgpu_nbio.o amdgpu_umc.o \
+ smu_v11_0_i2c.o
+
+--
+2.17.1
+