aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/2952-drm-amdgpu-powerplay-add-arcturus-ppt-functions-1-2-.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/2952-drm-amdgpu-powerplay-add-arcturus-ppt-functions-1-2-.patch')
-rw-r--r--meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/2952-drm-amdgpu-powerplay-add-arcturus-ppt-functions-1-2-.patch374
1 files changed, 374 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/2952-drm-amdgpu-powerplay-add-arcturus-ppt-functions-1-2-.patch b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/2952-drm-amdgpu-powerplay-add-arcturus-ppt-functions-1-2-.patch
new file mode 100644
index 00000000..c57a012b
--- /dev/null
+++ b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/2952-drm-amdgpu-powerplay-add-arcturus-ppt-functions-1-2-.patch
@@ -0,0 +1,374 @@
+From d979a8c92e195a99f491ad2208f023c03a92ce1c Mon Sep 17 00:00:00 2001
+From: Chengming Gui <Jack.Gui@amd.com>
+Date: Tue, 9 Jul 2019 10:52:20 -0500
+Subject: [PATCH 2952/4256] drm/amdgpu/powerplay: add arcturus ppt functions
+ 1/2 patch
+
+add arcturus_ppsmc.h rcturus_ppt.c and arcturus_ppt.h files.
+
+This is the initial power management support for Arcturus.
+
+Signed-off-by: Chengming Gui <Jack.Gui@amd.com>
+Reviewed-by: Kevin Wang <kevin1.wang@amd.com>
+Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
+---
+ drivers/gpu/drm/amd/powerplay/Makefile | 2 +-
+ drivers/gpu/drm/amd/powerplay/arcturus_ppt.c | 124 ++++++++++++++++++
+ drivers/gpu/drm/amd/powerplay/arcturus_ppt.h | 28 ++++
+ .../gpu/drm/amd/powerplay/inc/amdgpu_smu.h | 10 ++
+ .../drm/amd/powerplay/inc/arcturus_ppsmc.h | 120 +++++++++++++++++
+ drivers/gpu/drm/amd/powerplay/smu_v11_0.c | 4 +
+ 6 files changed, 287 insertions(+), 1 deletion(-)
+ create mode 100644 drivers/gpu/drm/amd/powerplay/arcturus_ppt.c
+ create mode 100644 drivers/gpu/drm/amd/powerplay/arcturus_ppt.h
+ create mode 100644 drivers/gpu/drm/amd/powerplay/inc/arcturus_ppsmc.h
+
+diff --git a/drivers/gpu/drm/amd/powerplay/Makefile b/drivers/gpu/drm/amd/powerplay/Makefile
+index 727c5cff231c..e05a7e3d6d8d 100644
+--- a/drivers/gpu/drm/amd/powerplay/Makefile
++++ b/drivers/gpu/drm/amd/powerplay/Makefile
+@@ -35,7 +35,7 @@ AMD_POWERPLAY = $(addsuffix /Makefile,$(addprefix $(FULL_AMD_PATH)/powerplay/,$(
+
+ include $(AMD_POWERPLAY)
+
+-POWER_MGR = amd_powerplay.o amdgpu_smu.o smu_v11_0.o vega20_ppt.o navi10_ppt.o
++POWER_MGR = amd_powerplay.o amdgpu_smu.o smu_v11_0.o vega20_ppt.o arcturus_ppt.o navi10_ppt.o
+
+ AMD_PP_POWER = $(addprefix $(AMD_PP_PATH)/,$(POWER_MGR))
+
+diff --git a/drivers/gpu/drm/amd/powerplay/arcturus_ppt.c b/drivers/gpu/drm/amd/powerplay/arcturus_ppt.c
+new file mode 100644
+index 000000000000..534e450df4bb
+--- /dev/null
++++ b/drivers/gpu/drm/amd/powerplay/arcturus_ppt.c
+@@ -0,0 +1,124 @@
++/*
++ * Copyright 2019 Advanced Micro Devices, Inc.
++ *
++ * Permission is hereby granted, free of charge, to any person obtaining a
++ * copy of this software and associated documentation files (the "Software"),
++ * to deal in the Software without restriction, including without limitation
++ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
++ * and/or sell copies of the Software, and to permit persons to whom the
++ * Software is furnished to do so, subject to the following conditions:
++ *
++ * The above copyright notice and this permission notice shall be included in
++ * all copies or substantial portions of the Software.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
++ * THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
++ * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
++ * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ * OTHER DEALINGS IN THE SOFTWARE.
++ *
++ */
++
++#include "pp_debug.h"
++#include <linux/firmware.h>
++#include "amdgpu.h"
++#include "amdgpu_smu.h"
++#include "atomfirmware.h"
++#include "amdgpu_atomfirmware.h"
++#include "smu_v11_0.h"
++#include "smu11_driver_if_arcturus.h"
++#include "soc15_common.h"
++#include "atom.h"
++#include "power_state.h"
++#include "arcturus_ppt.h"
++#include "arcturus_ppsmc.h"
++#include "nbio/nbio_7_4_sh_mask.h"
++
++#define MSG_MAP(msg, index) \
++ [SMU_MSG_##msg] = index
++
++static int arcturus_message_map[SMU_MSG_MAX_COUNT] = {
++ MSG_MAP(TestMessage, PPSMC_MSG_TestMessage),
++ MSG_MAP(GetSmuVersion, PPSMC_MSG_GetSmuVersion),
++ MSG_MAP(GetDriverIfVersion, PPSMC_MSG_GetDriverIfVersion),
++ MSG_MAP(SetAllowedFeaturesMaskLow, PPSMC_MSG_SetAllowedFeaturesMaskLow),
++ MSG_MAP(SetAllowedFeaturesMaskHigh, PPSMC_MSG_SetAllowedFeaturesMaskHigh),
++ MSG_MAP(EnableAllSmuFeatures, PPSMC_MSG_EnableAllSmuFeatures),
++ MSG_MAP(DisableAllSmuFeatures, PPSMC_MSG_DisableAllSmuFeatures),
++ MSG_MAP(EnableSmuFeaturesLow, PPSMC_MSG_EnableSmuFeaturesLow),
++ MSG_MAP(EnableSmuFeaturesHigh, PPSMC_MSG_EnableSmuFeaturesHigh),
++ MSG_MAP(DisableSmuFeaturesLow, PPSMC_MSG_DisableSmuFeaturesLow),
++ MSG_MAP(DisableSmuFeaturesHigh, PPSMC_MSG_DisableSmuFeaturesHigh),
++ MSG_MAP(GetEnabledSmuFeaturesLow, PPSMC_MSG_GetEnabledSmuFeaturesLow),
++ MSG_MAP(GetEnabledSmuFeaturesHigh, PPSMC_MSG_GetEnabledSmuFeaturesHigh),
++ MSG_MAP(SetDriverDramAddrHigh, PPSMC_MSG_SetDriverDramAddrHigh),
++ MSG_MAP(SetDriverDramAddrLow, PPSMC_MSG_SetDriverDramAddrLow),
++ MSG_MAP(SetToolsDramAddrHigh, PPSMC_MSG_SetToolsDramAddrHigh),
++ MSG_MAP(SetToolsDramAddrLow, PPSMC_MSG_SetToolsDramAddrLow),
++ MSG_MAP(TransferTableSmu2Dram, PPSMC_MSG_TransferTableSmu2Dram),
++ MSG_MAP(TransferTableDram2Smu, PPSMC_MSG_TransferTableDram2Smu),
++ MSG_MAP(UseDefaultPPTable, PPSMC_MSG_UseDefaultPPTable),
++ MSG_MAP(UseBackupPPTable, PPSMC_MSG_UseBackupPPTable),
++ MSG_MAP(SetSystemVirtualDramAddrHigh, PPSMC_MSG_SetSystemVirtualDramAddrHigh),
++ MSG_MAP(SetSystemVirtualDramAddrLow, PPSMC_MSG_SetSystemVirtualDramAddrLow),
++ MSG_MAP(EnterBaco, PPSMC_MSG_EnterBaco),
++ MSG_MAP(ExitBaco, PPSMC_MSG_ExitBaco),
++ MSG_MAP(ArmD3, PPSMC_MSG_ArmD3),
++ MSG_MAP(SetSoftMinByFreq, PPSMC_MSG_SetSoftMinByFreq),
++ MSG_MAP(SetSoftMaxByFreq, PPSMC_MSG_SetSoftMaxByFreq),
++ MSG_MAP(SetHardMinByFreq, PPSMC_MSG_SetHardMinByFreq),
++ MSG_MAP(SetHardMaxByFreq, PPSMC_MSG_SetHardMaxByFreq),
++ MSG_MAP(GetMinDpmFreq, PPSMC_MSG_GetMinDpmFreq),
++ MSG_MAP(GetMaxDpmFreq, PPSMC_MSG_GetMaxDpmFreq),
++ MSG_MAP(GetDpmFreqByIndex, PPSMC_MSG_GetDpmFreqByIndex),
++ MSG_MAP(SetWorkloadMask, PPSMC_MSG_SetWorkloadMask),
++ MSG_MAP(SetDfSwitchType, PPSMC_MSG_SetDfSwitchType),
++ MSG_MAP(GetVoltageByDpm, PPSMC_MSG_GetVoltageByDpm),
++ MSG_MAP(GetVoltageByDpmOverdrive, PPSMC_MSG_GetVoltageByDpmOverdrive),
++ MSG_MAP(SetPptLimit, PPSMC_MSG_SetPptLimit),
++ MSG_MAP(GetPptLimit, PPSMC_MSG_GetPptLimit),
++ MSG_MAP(PowerUpVcn0, PPSMC_MSG_PowerUpVcn0),
++ MSG_MAP(PowerDownVcn01, PPSMC_MSG_PowerDownVcn01),
++ MSG_MAP(PowerUpVcn1, PPSMC_MSG_PowerUpVcn1),
++ MSG_MAP(PowerDownVcn1, PPSMC_MSG_PowerDownVcn1),
++ MSG_MAP(PrepareMp1ForUnload, PPSMC_MSG_PrepareMp1ForUnload),
++ MSG_MAP(PrepareMp1ForReset, PPSMC_MSG_PrepareMp1ForReset),
++ MSG_MAP(PrepareMp1ForShutdown, PPSMC_MSG_PrepareMp1ForShutdown),
++ MSG_MAP(SoftReset, PPSMC_MSG_SoftReset),
++ MSG_MAP(RunAfllBtc, PPSMC_MSG_RunAfllBtc),
++ MSG_MAP(RunGfxDcBtc, PPSMC_MSG_RunGfxDcBtc),
++ MSG_MAP(RunSocDcBtc, PPSMC_MSG_RunSocDcBtc),
++ MSG_MAP(DramLogSetDramAddrHigh, PPSMC_MSG_DramLogSetDramAddrHigh),
++ MSG_MAP(DramLogSetDramAddrLow, PPSMC_MSG_DramLogSetDramAddrLow),
++ MSG_MAP(DramLogSetDramSize, PPSMC_MSG_DramLogSetDramSize),
++ MSG_MAP(GetDebugData, PPSMC_MSG_GetDebugData),
++ MSG_MAP(WaflTest, PPSMC_MSG_WaflTest),
++ MSG_MAP(SetXgmiMode, PPSMC_MSG_SetXgmiMode),
++ MSG_MAP(SetMemoryChannelEnable, PPSMC_MSG_SetMemoryChannelEnable),
++};
++
++static int arcturus_get_smu_msg_index(struct smu_context *smc, uint32_t index)
++{
++ int val;
++
++ if (index >= SMU_MSG_MAX_COUNT)
++ return -EINVAL;
++
++ val = arcturus_message_map[index];
++ if (val > PPSMC_Message_Count)
++ return -EINVAL;
++
++ return val;
++}
++
++static const struct pptable_funcs arcturus_ppt_funcs = {
++ .get_smu_msg_index = arcturus_get_smu_msg_index,
++};
++
++void arcturus_set_ppt_funcs(struct smu_context *smu)
++{
++ smu->ppt_funcs = &arcturus_ppt_funcs;
++ smu->smc_if_version = SMU11_DRIVER_IF_VERSION;
++}
+diff --git a/drivers/gpu/drm/amd/powerplay/arcturus_ppt.h b/drivers/gpu/drm/amd/powerplay/arcturus_ppt.h
+new file mode 100644
+index 000000000000..7b808d091b31
+--- /dev/null
++++ b/drivers/gpu/drm/amd/powerplay/arcturus_ppt.h
+@@ -0,0 +1,28 @@
++/*
++ * Copyright 2019 Advanced Micro Devices, Inc.
++ *
++ * Permission is hereby granted, free of charge, to any person obtaining a
++ * copy of this software and associated documentation files (the "Software"),
++ * to deal in the Software without restriction, including without limitation
++ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
++ * and/or sell copies of the Software, and to permit persons to whom the
++ * Software is furnished to do so, subject to the following conditions:
++ *
++ * The above copyright notice and this permission notice shall be included in
++ * all copies or substantial portions of the Software.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
++ * THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
++ * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
++ * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ * OTHER DEALINGS IN THE SOFTWARE.
++ *
++ */
++#ifndef __ARCTURUS_PPT_H__
++#define __ARCTURUS_PPT_H__
++
++extern void arcturus_set_ppt_funcs(struct smu_context *smu);
++
++#endif
+diff --git a/drivers/gpu/drm/amd/powerplay/inc/amdgpu_smu.h b/drivers/gpu/drm/amd/powerplay/inc/amdgpu_smu.h
+index 135a3236f7ed..79e34097eb0f 100644
+--- a/drivers/gpu/drm/amd/powerplay/inc/amdgpu_smu.h
++++ b/drivers/gpu/drm/amd/powerplay/inc/amdgpu_smu.h
+@@ -242,6 +242,16 @@ enum smu_message_type
+ SMU_MSG_PowerDownJpeg,
+ SMU_MSG_BacoAudioD3PME,
+ SMU_MSG_ArmD3,
++ SMU_MSG_RunGfxDcBtc,
++ SMU_MSG_RunSocDcBtc,
++ SMU_MSG_SetMemoryChannelEnable,
++ SMU_MSG_SetDfSwitchType,
++ SMU_MSG_GetVoltageByDpm,
++ SMU_MSG_GetVoltageByDpmOverdrive,
++ SMU_MSG_PowerUpVcn0,
++ SMU_MSG_PowerDownVcn01,
++ SMU_MSG_PowerUpVcn1,
++ SMU_MSG_PowerDownVcn1,
+ SMU_MSG_MAX_COUNT,
+ };
+
+diff --git a/drivers/gpu/drm/amd/powerplay/inc/arcturus_ppsmc.h b/drivers/gpu/drm/amd/powerplay/inc/arcturus_ppsmc.h
+new file mode 100644
+index 000000000000..b86bb2bc8a31
+--- /dev/null
++++ b/drivers/gpu/drm/amd/powerplay/inc/arcturus_ppsmc.h
+@@ -0,0 +1,120 @@
++/*
++ * Copyright 2018 Advanced Micro Devices, Inc.
++ *
++ * Permission is hereby granted, free of charge, to any person obtaining a
++ * copy of this software and associated documentation files (the "Software"),
++ * to deal in the Software without restriction, including without limitation
++ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
++ * and/or sell copies of the Software, and to permit persons to whom the
++ * Software is furnished to do so, subject to the following conditions:
++ *
++ * The above copyright notice and this permission notice shall be included in
++ * all copies or substantial portions of the Software.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
++ * THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
++ * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
++ * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ * OTHER DEALINGS IN THE SOFTWARE.
++ *
++ */
++
++#ifndef ARCTURUS_PP_SMC_H
++#define ARCTURUS_PP_SMC_H
++
++#pragma pack(push, 1)
++
++// SMU Response Codes:
++#define PPSMC_Result_OK 0x1
++#define PPSMC_Result_Failed 0xFF
++#define PPSMC_Result_UnknownCmd 0xFE
++#define PPSMC_Result_CmdRejectedPrereq 0xFD
++#define PPSMC_Result_CmdRejectedBusy 0xFC
++
++// Message Definitions:
++// BASIC
++#define PPSMC_MSG_TestMessage 0x1
++#define PPSMC_MSG_GetSmuVersion 0x2
++#define PPSMC_MSG_GetDriverIfVersion 0x3
++#define PPSMC_MSG_SetAllowedFeaturesMaskLow 0x4
++#define PPSMC_MSG_SetAllowedFeaturesMaskHigh 0x5
++#define PPSMC_MSG_EnableAllSmuFeatures 0x6
++#define PPSMC_MSG_DisableAllSmuFeatures 0x7
++#define PPSMC_MSG_EnableSmuFeaturesLow 0x8
++#define PPSMC_MSG_EnableSmuFeaturesHigh 0x9
++#define PPSMC_MSG_DisableSmuFeaturesLow 0xA
++#define PPSMC_MSG_DisableSmuFeaturesHigh 0xB
++#define PPSMC_MSG_GetEnabledSmuFeaturesLow 0xC
++#define PPSMC_MSG_GetEnabledSmuFeaturesHigh 0xD
++#define PPSMC_MSG_SetDriverDramAddrHigh 0xE
++#define PPSMC_MSG_SetDriverDramAddrLow 0xF
++#define PPSMC_MSG_SetToolsDramAddrHigh 0x10
++#define PPSMC_MSG_SetToolsDramAddrLow 0x11
++#define PPSMC_MSG_TransferTableSmu2Dram 0x12
++#define PPSMC_MSG_TransferTableDram2Smu 0x13
++#define PPSMC_MSG_UseDefaultPPTable 0x14
++#define PPSMC_MSG_UseBackupPPTable 0x15
++#define PPSMC_MSG_SetSystemVirtualDramAddrHigh 0x16
++#define PPSMC_MSG_SetSystemVirtualDramAddrLow 0x17
++
++//BACO/BAMACO/BOMACO
++#define PPSMC_MSG_EnterBaco 0x18
++#define PPSMC_MSG_ExitBaco 0x19
++#define PPSMC_MSG_ArmD3 0x1A
++
++//DPM
++#define PPSMC_MSG_SetSoftMinByFreq 0x1B
++#define PPSMC_MSG_SetSoftMaxByFreq 0x1C
++#define PPSMC_MSG_SetHardMinByFreq 0x1D
++#define PPSMC_MSG_SetHardMaxByFreq 0x1E
++#define PPSMC_MSG_GetMinDpmFreq 0x1F
++#define PPSMC_MSG_GetMaxDpmFreq 0x20
++#define PPSMC_MSG_GetDpmFreqByIndex 0x21
++
++#define PPSMC_MSG_SetWorkloadMask 0x22
++#define PPSMC_MSG_SetDfSwitchType 0x23
++#define PPSMC_MSG_GetVoltageByDpm 0x24
++#define PPSMC_MSG_GetVoltageByDpmOverdrive 0x25
++
++#define PPSMC_MSG_SetPptLimit 0x26
++#define PPSMC_MSG_GetPptLimit 0x27
++
++//Power Gating
++#define PPSMC_MSG_PowerUpVcn0 0x28
++#define PPSMC_MSG_PowerDownVcn01 0x29
++#define PPSMC_MSG_PowerUpVcn1 0x2A
++#define PPSMC_MSG_PowerDownVcn1 0x2B
++
++//Resets and reload
++#define PPSMC_MSG_PrepareMp1ForUnload 0x2C
++#define PPSMC_MSG_PrepareMp1ForReset 0x2D
++#define PPSMC_MSG_PrepareMp1ForShutdown 0x2E
++#define PPSMC_MSG_SoftReset 0x2F
++
++//BTC
++#define PPSMC_MSG_RunAfllBtc 0x30
++#define PPSMC_MSG_RunGfxDcBtc 0x31
++#define PPSMC_MSG_RunSocDcBtc 0x32
++
++//Debug
++#define PPSMC_MSG_DramLogSetDramAddrHigh 0x33
++#define PPSMC_MSG_DramLogSetDramAddrLow 0x34
++#define PPSMC_MSG_DramLogSetDramSize 0x35
++#define PPSMC_MSG_GetDebugData 0x36
++
++//WAFL and XGMI
++#define PPSMC_MSG_WaflTest 0x37
++#define PPSMC_MSG_SetXgmiMode 0x38
++
++//Others
++#define PPSMC_MSG_SetMemoryChannelEnable 0x39
++
++#define PPSMC_Message_Count 0x3A
++
++typedef uint32_t PPSMC_Result;
++typedef uint32_t PPSMC_Msg;
++#pragma pack(pop)
++
++#endif
+diff --git a/drivers/gpu/drm/amd/powerplay/smu_v11_0.c b/drivers/gpu/drm/amd/powerplay/smu_v11_0.c
+index c60899de88bb..d0764ba2705c 100644
+--- a/drivers/gpu/drm/amd/powerplay/smu_v11_0.c
++++ b/drivers/gpu/drm/amd/powerplay/smu_v11_0.c
+@@ -30,6 +30,7 @@
+ #include "soc15_common.h"
+ #include "atom.h"
+ #include "vega20_ppt.h"
++#include "arcturus_ppt.h"
+ #include "navi10_ppt.h"
+
+ #include "asic_reg/thm/thm_11_0_2_offset.h"
+@@ -1793,6 +1794,9 @@ void smu_v11_0_set_smu_funcs(struct smu_context *smu)
+ case CHIP_VEGA20:
+ vega20_set_ppt_funcs(smu);
+ break;
++ case CHIP_ARCTURUS:
++ arcturus_set_ppt_funcs(smu);
++ break;
+ case CHIP_NAVI10:
+ case CHIP_NAVI14:
+ navi10_set_ppt_funcs(smu);
+--
+2.17.1
+