aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/1181-drm-amdkfd-make-Makefile-paths-relative.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/1181-drm-amdkfd-make-Makefile-paths-relative.patch')
-rw-r--r--meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/1181-drm-amdkfd-make-Makefile-paths-relative.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/1181-drm-amdkfd-make-Makefile-paths-relative.patch b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/1181-drm-amdkfd-make-Makefile-paths-relative.patch
new file mode 100644
index 00000000..18540891
--- /dev/null
+++ b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/1181-drm-amdkfd-make-Makefile-paths-relative.patch
@@ -0,0 +1,37 @@
+From 93c2e2a419df4667b773bc7df442bc2cd4acf892 Mon Sep 17 00:00:00 2001
+From: Andres Rodriguez <andres.rodriguez@amd.com>
+Date: Wed, 31 Aug 2016 17:39:55 -0400
+Subject: [PATCH 1181/4131] drm/amdkfd: make Makefile paths relative
+
+Use relative paths in Makefile for consistency with amdgpu
+
+BUG: KFD-279
+Change-Id: If5bfe26498ba941941bec65b10896d6d340af0a7
+Signed-off-by: Andres Rodriguez <andres.rodriguez@amd.com>
+
+ Conflicts:
+ drivers/gpu/drm/amd/amdkfd/Makefile
+---
+ drivers/gpu/drm/amd/amdkfd/Makefile | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/drivers/gpu/drm/amd/amdkfd/Makefile b/drivers/gpu/drm/amd/amdkfd/Makefile
+index 59d284e..619b8e6 100644
+--- a/drivers/gpu/drm/amd/amdkfd/Makefile
++++ b/drivers/gpu/drm/amd/amdkfd/Makefile
+@@ -3,8 +3,10 @@
+ # Makefile for Heterogenous System Architecture support for AMD GPU devices
+ #
+
+-ccflags-y := -Idrivers/gpu/drm/amd/include/ \
+- -Idrivers/gpu/drm/amd/include/asic_reg
++FULL_AMD_PATH=$(src)/..
++
++ccflags-y := -I$(FULL_AMD_PATH)/include/ \
++ -I$(FULL_AMD_PATH)/include/asic_reg
+
+ amdkfd-y := kfd_module.o kfd_device.o kfd_chardev.o kfd_topology.o \
+ kfd_pasid.o kfd_doorbell.o kfd_flat_memory.o \
+--
+2.7.4
+