aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/0904-drm-amdgpu-Use-correct-path-to-trace-include.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/0904-drm-amdgpu-Use-correct-path-to-trace-include.patch')
-rw-r--r--meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/0904-drm-amdgpu-Use-correct-path-to-trace-include.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/0904-drm-amdgpu-Use-correct-path-to-trace-include.patch b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/0904-drm-amdgpu-Use-correct-path-to-trace-include.patch
new file mode 100644
index 00000000..c077fb14
--- /dev/null
+++ b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/0904-drm-amdgpu-Use-correct-path-to-trace-include.patch
@@ -0,0 +1,48 @@
+From b57d49bf4b0562249bea60a4bd15c42611b6ec03 Mon Sep 17 00:00:00 2001
+From: Thierry Reding <treding@nvidia.com>
+Date: Fri, 1 Sep 2017 12:32:17 -0400
+Subject: [PATCH 0904/4131] drm/amdgpu: Use correct path to trace include
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The header comment in include/trace/define_trace.h specifies that the
+TRACE_INCLUDE_PATH needs to be relative to the define_trace.h header
+rather than the trace file including it. Most instances get that wrong
+and work around it by adding the $(src) directory to the include path.
+
+While this works, it is preferable to refer to the correct path to the
+trace file in the first place and avoid any workaround.
+
+Reviewed-by: Christian König <christian.koenig@amd.com>
+Signed-off-by: Thierry Reding <treding@nvidia.com>
+Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
+---
+ drivers/gpu/drm/amd/amdgpu/Makefile | 2 --
+ drivers/gpu/drm/amd/amdgpu/amdgpu_trace.h | 2 +-
+ 2 files changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/drivers/gpu/drm/amd/amdgpu/Makefile b/drivers/gpu/drm/amd/amdgpu/Makefile
+index 0713138..57b8d5f 100644
+--- a/drivers/gpu/drm/amd/amdgpu/Makefile
++++ b/drivers/gpu/drm/amd/amdgpu/Makefile
+@@ -149,5 +149,3 @@ amdgpu-y += $(AMD_DISPLAY_FILES)
+ endif
+
+ obj-$(CONFIG_DRM_AMDGPU)+= amdgpu.o
+-
+-CFLAGS_amdgpu_trace_points.o := -I$(src)
+diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_trace.h b/drivers/gpu/drm/amd/amdgpu/amdgpu_trace.h
+index 1dbe405182..f337c316 100644
+--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_trace.h
++++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_trace.h
+@@ -418,5 +418,5 @@ TRACE_EVENT(amdgpu_ttm_bo_move,
+
+ /* This part must be outside protection */
+ #undef TRACE_INCLUDE_PATH
+-#define TRACE_INCLUDE_PATH ../../drivers/gpu/drm/amd/amdgpu/
++#define TRACE_INCLUDE_PATH ../../drivers/gpu/drm/amd/amdgpu
+ #include <trace/define_trace.h>
+--
+2.7.4
+