aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-kernel/amd-spi/amd-spi_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-kernel/amd-spi/amd-spi_1.0.bb')
-rw-r--r--meta-amd-bsp/recipes-kernel/amd-spi/amd-spi_1.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-kernel/amd-spi/amd-spi_1.0.bb b/meta-amd-bsp/recipes-kernel/amd-spi/amd-spi_1.0.bb
new file mode 100644
index 00000000..aacb1039
--- /dev/null
+++ b/meta-amd-bsp/recipes-kernel/amd-spi/amd-spi_1.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "This kernel module provides support for AMD SPI controller driver"
+LICENSE = "BSD | GPLv2"
+LIC_FILES_CHKSUM = "file://spi_amd.c;endline=29;md5=e9fdf6da58412e619d89ec9e135a1be3"
+
+inherit module kernel-openssl
+
+SRC_URI = "file://Makefile \
+ file://spi_amd.c \
+ file://spi_amd.h \
+ file://spirom.c \
+ file://spirom.h \
+ "
+
+S = "${WORKDIR}"
+
+# The inherit of module.bbclass will take care of the rest