aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-graphics')
-rw-r--r--meta-amd-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-amd-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
index 57926ab0..0c0d1067 100644
--- a/meta-amd-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ b/meta-amd-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -41,3 +41,11 @@ set_xorg_opts() {
fi
done
}
+
+do_install_append_r1000 () {
+ sed -i -e 's/^\tBusID "PCI:0:1:0"/\t#BusID "PCI:1:0:0"/' ${D}/${sysconfdir}/X11/xorg.conf
+}
+
+do_install_append_v1000 () {
+ sed -i -e 's/^\tBusID "PCI:0:1:0"/\t#BusID "PCI:1:0:0"/' ${D}/${sysconfdir}/X11/xorg.conf
+}