aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-devtools/codexl/codexl/makefile-mkdir-ordering.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-devtools/codexl/codexl/makefile-mkdir-ordering.patch')
-rw-r--r--meta-amd-bsp/recipes-devtools/codexl/codexl/makefile-mkdir-ordering.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-devtools/codexl/codexl/makefile-mkdir-ordering.patch b/meta-amd-bsp/recipes-devtools/codexl/codexl/makefile-mkdir-ordering.patch
new file mode 100644
index 00000000..6318918c
--- /dev/null
+++ b/meta-amd-bsp/recipes-devtools/codexl/codexl/makefile-mkdir-ordering.patch
@@ -0,0 +1,11 @@
+--- CodeXL/Components/GpuProfiling/Build/CommonTargets.mk.orig 2017-01-19 15:56:10.300696899 -0500
++++ CodeXL/Components/GpuProfiling/Build/CommonTargets.mk 2017-01-19 16:05:12.473012993 -0500
+@@ -39,7 +39,7 @@
+
+ # source file targets
+
+-BUILD_SRC=$(CC) $(CFLAGS) $(INCLUDES) $(DEFINES) -c $< -o $@
++BUILD_SRC=mkdir -p $(@D); $(CC) $(CFLAGS) $(INCLUDES) $(DEFINES) -c $< -o $@
+
+ $(OBJ_DIR)/%.o: %.cpp
+ $(BUILD_SRC)