aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-applications/watchdog-test/watchdog-test_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-applications/watchdog-test/watchdog-test_1.0.bb')
-rw-r--r--meta-amd-bsp/recipes-applications/watchdog-test/watchdog-test_1.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-applications/watchdog-test/watchdog-test_1.0.bb b/meta-amd-bsp/recipes-applications/watchdog-test/watchdog-test_1.0.bb
new file mode 100644
index 00000000..404ffebc
--- /dev/null
+++ b/meta-amd-bsp/recipes-applications/watchdog-test/watchdog-test_1.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Sample application for AMD Watchdog driver"
+SECTION = "applications"
+LICENSE = "BSD"
+DEPENDS = "readline"
+LIC_FILES_CHKSUM = "file://watchdog-test.c;md5=1d81025de7376754875ee74378f07d7a"
+
+SRC_URI = "file://watchdog-test.c"
+
+S = "${WORKDIR}"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_compile() {
+ ${CC} watchdog-test.c -o watchdog-test -lreadline
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 watchdog-test ${D}${bindir}
+}