aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-applications/smbus-test/smbus-test_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-applications/smbus-test/smbus-test_1.0.bb')
-rw-r--r--meta-amd-bsp/recipes-applications/smbus-test/smbus-test_1.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-applications/smbus-test/smbus-test_1.0.bb b/meta-amd-bsp/recipes-applications/smbus-test/smbus-test_1.0.bb
new file mode 100644
index 00000000..24f9b5b8
--- /dev/null
+++ b/meta-amd-bsp/recipes-applications/smbus-test/smbus-test_1.0.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Sample application for AMD SMBUS driver"
+SECTION = "applications"
+LICENSE = "BSD | GPLv2"
+DEPENDS = "readline"
+LIC_FILES_CHKSUM = "file://smbus-test.c;endline=29;md5=8e7a9706367d146e5073510a6e176dc2"
+
+SRC_URI = "file://smbus-test.c \
+ file://i2c-dev.h \
+ "
+
+S = "${WORKDIR}"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_compile() {
+ ${CC} smbus-test.c -o smbus-test -lreadline
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 smbus-test ${D}${bindir}
+}