aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/dpdk/recipes-extended/dpdk/dpdk_18.11.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/dpdk/recipes-extended/dpdk/dpdk_18.11.1.bbappend')
-rw-r--r--meta-amd-bsp/dpdk/recipes-extended/dpdk/dpdk_18.11.1.bbappend17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-amd-bsp/dpdk/recipes-extended/dpdk/dpdk_18.11.1.bbappend b/meta-amd-bsp/dpdk/recipes-extended/dpdk/dpdk_18.11.1.bbappend
new file mode 100644
index 00000000..35bb2b0e
--- /dev/null
+++ b/meta-amd-bsp/dpdk/recipes-extended/dpdk/dpdk_18.11.1.bbappend
@@ -0,0 +1,17 @@
+DEPENDS += "openssl"
+
+# takes n or y
+BUILD_SHARED = "n"
+do_configure_prepend () {
+ # enable the AMD CCP driver
+ sed -e "s#CONFIG_RTE_LIBRTE_PMD_CCP=n#CONFIG_RTE_LIBRTE_PMD_CCP=y#" -i ${S}/config/common_base
+ sed -e "s#CONFIG_RTE_LIBRTE_PMD_CCP_CPU_AUTH=n#CONFIG_RTE_LIBRTE_PMD_CCP_CPU_AUTH=y#" -i ${S}/config/common_base
+
+ # shared libs are a more convenient way for development but then the user
+ # has to load the PMD explicitly with the -d flag so be careful
+ sed -e "s#CONFIG_RTE_BUILD_SHARED_LIB=n#CONFIG_RTE_BUILD_SHARED_LIB=${BUILD_SHARED}#" -i ${S}/config/common_base
+}
+
+COMPATIBLE_MACHINE_e3000 = "e3000"
+DPDK_TARGET_MACHINE_e3000 = "znver1"
+TUNE_FEATURES += "m64"