aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/conf')
-rw-r--r--meta-amd-bsp/conf/layer.conf21
-rw-r--r--meta-amd-bsp/conf/local.conf.append.e30005
-rw-r--r--meta-amd-bsp/conf/local.conf.append.r100012
-rw-r--r--meta-amd-bsp/conf/local.conf.append.v100017
-rw-r--r--meta-amd-bsp/conf/machine/e3000.conf39
-rw-r--r--meta-amd-bsp/conf/machine/include/amd-common-configurations.inc50
-rw-r--r--meta-amd-bsp/conf/machine/include/amd-features.inc78
-rw-r--r--meta-amd-bsp/conf/machine/include/amd-multimedia.inc50
-rw-r--r--meta-amd-bsp/conf/machine/include/tune-e3000.inc15
-rw-r--r--meta-amd-bsp/conf/machine/include/tune-r1000.inc15
-rw-r--r--meta-amd-bsp/conf/machine/include/tune-v1000.inc15
-rw-r--r--meta-amd-bsp/conf/machine/r1000.conf44
-rw-r--r--meta-amd-bsp/conf/machine/v1000.conf43
13 files changed, 404 insertions, 0 deletions
diff --git a/meta-amd-bsp/conf/layer.conf b/meta-amd-bsp/conf/layer.conf
new file mode 100644
index 00000000..d4ab36f7
--- /dev/null
+++ b/meta-amd-bsp/conf/layer.conf
@@ -0,0 +1,21 @@
+BBPATH .= ":${LAYERDIR}"
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
+ ${LAYERDIR}/recipes*/*/*.bbappend"
+
+# Let us add layer-specific bbs & bbappends which are only applied
+# when that layer is included in our configuration
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())} \
+ ${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+
+BBFILE_COLLECTIONS += "amd-bsp"
+BBFILE_PRIORITY_amd-bsp = "13"
+BBFILE_PATTERN_amd-bsp = "^${LAYERDIR}/"
+LAYERSERIES_COMPAT_amd-bsp = "warrior"
+
+LICENSE_PATH += "${LAYERDIR}/licenses"
+
+LAYERDEPENDS_r1000 = "openembedded-layer meta-python"
+LAYERDEPENDS_v1000 = "openembedded-layer meta-python"
+LAYERDEPENDS_e3000 = "openembedded-layer meta-python meta-networking"
diff --git a/meta-amd-bsp/conf/local.conf.append.e3000 b/meta-amd-bsp/conf/local.conf.append.e3000
new file mode 100644
index 00000000..919307ad
--- /dev/null
+++ b/meta-amd-bsp/conf/local.conf.append.e3000
@@ -0,0 +1,5 @@
+
+# Set to "yes" to start using the RT Kernel, please
+# run 'bitbake -c clean virtual/kernel' before doing so.
+RT_KERNEL_AMD ?= "no"
+
diff --git a/meta-amd-bsp/conf/local.conf.append.r1000 b/meta-amd-bsp/conf/local.conf.append.r1000
new file mode 100644
index 00000000..d7533e3a
--- /dev/null
+++ b/meta-amd-bsp/conf/local.conf.append.r1000
@@ -0,0 +1,12 @@
+# AMD supports various components that can be enabled by setting the corresponding
+# INCLUDE_<component> to "yes".
+# Following is a list of <components> that can be enabled if you want them to be
+# installed/available on your image.
+# Please change the required INCLUDE_<component> to "yes" before building an image, or
+# generating an ADE that can be used to develop apps for these components (if applicable):
+#
+# - OPENCL - The Open Computing Language.
+# Framework for writing programs that execute across heterogeneous platforms consisting
+# of CPUs, GPUs, DSPs, FPGAs and other processors or hardware accelerators.
+#
+INCLUDE_OPENCL ??= "no"
diff --git a/meta-amd-bsp/conf/local.conf.append.v1000 b/meta-amd-bsp/conf/local.conf.append.v1000
new file mode 100644
index 00000000..e36e8252
--- /dev/null
+++ b/meta-amd-bsp/conf/local.conf.append.v1000
@@ -0,0 +1,17 @@
+# AMD supports various components that can be enabled by setting the corresponding
+# INCLUDE_<component> to "yes".
+# Following is a list of <components> that can be enabled if you want them to be
+# installed/available on your image.
+# Please change the required INCLUDE_<component> to "yes" before building an image, or
+# generating an ADE that can be used to develop apps for these components (if applicable):
+#
+# - VULKAN - Vulkan driver and Loader Layer.
+# It is required to run Vulkan based applications. Vulkan is a new generation graphics
+# and compute API that provides high-efficiency, cross-platform access to modern GPUs.
+#
+# - OPENCL - The Open Computing Language.
+# Framework for writing programs that execute across heterogeneous platforms consisting
+# of CPUs, GPUs, DSPs, FPGAs and other processors or hardware accelerators.
+#
+INCLUDE_VULKAN ??= "no"
+INCLUDE_OPENCL ??= "no"
diff --git a/meta-amd-bsp/conf/machine/e3000.conf b/meta-amd-bsp/conf/machine/e3000.conf
new file mode 100644
index 00000000..7ef6462b
--- /dev/null
+++ b/meta-amd-bsp/conf/machine/e3000.conf
@@ -0,0 +1,39 @@
+#@TYPE: Machine
+#@NAME: e3000
+
+#@DESCRIPTION: Machine configuration for e3000 systems
+
+PREFERRED_PROVIDER_virtual/kernel ?= "${@bb.utils.contains('RT_KERNEL_AMD', 'yes', "linux-yocto-rt", "linux-yocto", d)}"
+PREFERRED_VERSION_linux-yocto ?= "4.14%"
+PREFERRED_VERSION_linux-yocto-rt ?= "4.14%"
+
+require conf/machine/include/tune-e3000.inc
+
+# Add machine specific AMD features and feature pkgs here
+EXTRA_IMAGE_FEATURES += "amd-feature-networking"
+DPDK_PKGS_e3000 = "${@bb.utils.contains("BBFILE_COLLECTIONS", "dpdk", "dpdk dpdk-examples dpdk-test", "", d)}"
+
+include conf/machine/include/amd-common-configurations.inc
+include conf/machine/include/amd-customer-configurations.inc
+
+MACHINE_FEATURES_remove = "alsa"
+MACHINE_EXTRA_RRECOMMENDS_remove = " rtc-test alsa-utils"
+
+# Setup a getty on all serial ports
+SERIAL_CONSOLES = "115200;ttyS4 115200;ttyS5"
+
+# Enable the kernel console on ttyS4/COM0
+KERNEL_SERIAL_CONSOLE ?= "console=ttyS4,115200n8"
+
+# Disable the graphical console, no graphics support for now
+# this allows the serial console to be used for installation
+APPEND_remove="console=tty0"
+
+# Drop features we do not need
+DISTRO_FEATURES_remove="opengl x11 alsa pulseaudio"
+
+MACHINEOVERRIDES =. "amd:amdx86:"
+
+# Mask out recipes for packages we do not support for
+# e3000 but require under common.
+BBMASK = ".*/meta-amd/common/recipes-multimedia/mpv|.*/meta-amd/common/recipes-multimedia/v4l2apps|.*/meta-amd/common/recipes-support/libtinyxml|.*/meta-amd/common/recipes-support/numactl"
diff --git a/meta-amd-bsp/conf/machine/include/amd-common-configurations.inc b/meta-amd-bsp/conf/machine/include/amd-common-configurations.inc
new file mode 100644
index 00000000..7704acfd
--- /dev/null
+++ b/meta-amd-bsp/conf/machine/include/amd-common-configurations.inc
@@ -0,0 +1,50 @@
+require conf/machine/include/amd-features.inc
+require conf/machine/include/amd-multimedia.inc
+
+POKY_DEFAULT_DISTRO_FEATURES_remove = "wayland"
+
+PREFERRED_PROVIDER_jpeg ?= "jpeg"
+PREFERRED_PROVIDER_jpeg-native ?= "jpeg-native"
+PREFERRED_VERSION_linux-yocto ?= "4.14%"
+PREFERRED_VERSION_libav ?= "9.18"
+PREFERRED_PROVIDER_llvm ?= "llvm9.0.0"
+
+# Components that depend on LLVM should set versions here
+# so we know what needs to be changed/validated as LLVM moves
+MESA_LLVM_RELEASE_amd = "9.0.0"
+CLAMAV_LLVM_RELEASE_amd = "9.0.0"
+
+MULTILIBS ?= ""
+require conf/multilib.conf
+
+MACHINE_FEATURES += "wifi efi alsa"
+
+# QEMU does not support some of the enhanced instructions available
+# on the AMD chips which causes some build time failures.
+MACHINE_FEATURES_remove = "qemu-usermode"
+
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules alsa-utils"
+MACHINE_EXTRA_RRECOMMENDS += "grub parted util-linux-blkid"
+MACHINE_EXTRA_RRECOMMENDS += "rtc-test watchdog-test spi-test smbus-test gpio-test"
+MACHINE_EXTRA_RRECOMMENDS += "amd-wdt amd-spi"
+
+# Add serial consoles to kernel commandline, these should occur before the tty0
+KERNEL_SERIAL_CONSOLE ??= ""
+APPEND += "${KERNEL_SERIAL_CONSOLE}"
+
+# Make sure the kernel messages go to the VGA console
+APPEND += "console=tty0"
+
+# Set a generic video mode, use gfxpayload=wxh for grub2
+GRUB_OPTS_append = ";set gfxpayload=1024x768"
+
+# We use ext4 rootfs normally so give it priority rather than trying other FS first
+APPEND += "rootfstype=ext4,ext3,ext2"
+
+APPEND_ADDITIONAL ??= ""
+APPEND += "${APPEND_ADDITIONAL}"
+
+EXTRA_OECONF_append_pn-matchbox-panel-2 = " --with-battery=acpi"
+
+# Add common feartures to be supported for all machines here
+EXTRA_IMAGE_FEATURES += "amd-misc-pkgs"
diff --git a/meta-amd-bsp/conf/machine/include/amd-features.inc b/meta-amd-bsp/conf/machine/include/amd-features.inc
new file mode 100644
index 00000000..0ac536b2
--- /dev/null
+++ b/meta-amd-bsp/conf/machine/include/amd-features.inc
@@ -0,0 +1,78 @@
+# This file defines AMD Features that can be added as EXTRA_IMAGE_FEATURES to
+# different machines based on what is supported on a machine (MACHINE_FEATURES)
+# and which additional features a user is requesting through EXTRA_IMAGE_FEATURES.
+# This gives a broad flexibility and control over packages being installed on a
+# machine for any image without needing to create bbappends for all the images
+# that are to be supported.
+#
+# > Each feature can contain packages and packagegroups as its components.
+# > Feature components can be dependent on DISTRO, EXTRA_IMAGE_FEATURES, or any
+# variable in general other than a particular image's related variable so most
+# things should be based on global configs rather than image configs.
+# e.g.: Components of "amd-feature-graphics" may be dependent on "x11-base" as
+# an IMAGE_FEATURE. Some packages may only be included for a specific
+# DISTRO. Some packages may only be installed if user allows them in local.conf etc.
+# > Each machine must add the requested features to EXTRA_IMAGE_FEATURES in its
+# own machine config file regardless of the image being built, if that particular
+# feature is not handled in the common fragments.
+# > Each machine can also override feature components in its own machine config
+# when adding the feature to EXTRA_IMAGE_FEATURES. e.g.: A feature may be added
+# to a specific machine with minimal (or extended) packages based on requirement.
+#
+# Features are classified as:
+#
+# * amd-misc-pkgs : Intended for Platform Specific Packages, Common Packages to be added to all machines, etc.
+# * amd-feature-multimedia : Multimedia packages (it does not depend on graphics because a machine may not have a GUI but could play videos and sounds from console)
+# * amd-feature-graphics : Graphics packages
+# * amd-feature-networking : Networking packages
+# * amd-feature-debug-profile : Debugging and Profiling tools
+# * <add more features here> : <feature summary>
+
+GSTREAMER_PKGS ?= " \
+ ${@bb.utils.contains("IMAGE_FEATURES", "x11-base", "gstreamer1.0-meta-x11-base", "", d)} \
+ ${@bb.utils.contains("COMBINED_FEATURES", "alsa", "gstreamer1.0-meta-audio", "", d)} \
+ gstreamer1.0-meta-debug \
+ gstreamer1.0-meta-video \
+ ${@bb.utils.contains("IMAGE_FEATURES", "x11-base", "gstreamer1.0-omx", "", d)} \
+ ${@bb.utils.contains("IMAGE_FEATURES", "x11-base", "gstreamer1.0-vaapi", "", d)} \
+"
+VULKAN_PKGS ?= ""
+CODEXL_PKGS ?= ""
+DPDK_PKGS ?= ""
+
+# Additional packages can be added to the following feature specific
+# variables from each machine's config file
+AMD_PLATFORM_SPECIFIC_PKGS ?= ""
+AMD_FEATURE_MULTIMEDIA_PKGS ?= ""
+AMD_FEATURE_GRAPHICS_PKGS ?= ""
+AMD_FEATURE_NETWORKING_PKGS ?= ""
+AMD_FEATURE_DEBUG_PROFILE_PKGS ?= ""
+
+FEATURE_PACKAGES_amd-misc-pkgs = "\
+ bc \
+ ${AMD_PLATFORM_SPECIFIC_PKGS} \
+"
+
+FEATURE_PACKAGES_amd-feature-multimedia = "\
+ ${GSTREAMER_PKGS} \
+ ${@bb.utils.contains("IMAGE_FEATURES", "x11-base", "vdpauinfo", "", d)} \
+ ${AMD_FEATURE_MULTIMEDIA_PKGS} \
+"
+
+FEATURE_PACKAGES_amd-feature-graphics = "\
+ ${@bb.utils.contains("INCLUDE_VULKAN", "yes", "${VULKAN_PKGS}", "", d)} \
+ ${AMD_FEATURE_GRAPHICS_PKGS} \
+"
+FEATURE_PACKAGES_amd-feature-graphics_append_amdgpu = " ${@bb.utils.contains("IMAGE_FEATURES", "x11-base", "mesa-demos", "", d)}"
+FEATURE_PACKAGES_amd-feature-graphics_append_radeon = " ${@bb.utils.contains("IMAGE_FEATURES", "x11-base", "mesa-demos", "", d)}"
+
+FEATURE_PACKAGES_amd-feature-networking = "\
+ ${DPDK_PKGS} \
+ strongswan \
+ ${AMD_FEATURE_NETWORKING_PKGS} \
+"
+
+FEATURE_PACKAGES_amd-feature-debug-profile = "\
+ ${@bb.utils.contains("INCLUDE_CODEXL", "yes", "${CODEXL_PKGS}", "", d)} \
+ ${AMD_FEATURE_DEBUG_PROFILE_PKGS} \
+"
diff --git a/meta-amd-bsp/conf/machine/include/amd-multimedia.inc b/meta-amd-bsp/conf/machine/include/amd-multimedia.inc
new file mode 100644
index 00000000..3e2c2f57
--- /dev/null
+++ b/meta-amd-bsp/conf/machine/include/amd-multimedia.inc
@@ -0,0 +1,50 @@
+# AMD provides the functionality to build packages with license-restricted
+# algorithms or software. Their configuration variables can be set to
+# "yes" or "no" in the local.conf file to enable or disable the
+# functionality to include them in the build. The option to build these
+# packages is NOT enabled in the default configuration. After enabling the
+# option to build, when you build your target image, the BitBake utility
+# fetches package sources from the canonical upstream location. If you do
+# not have an active network connection, your build with these packages
+# will fail.
+#
+# Building packages with license-restricted algorithms or software may add
+# proprietary IP or functionality with other restrictions to your output.
+# AMD has no connection with or responsibility for such
+# license-restricted algorithms or software, and failure to abide by the
+# relevant license terms may have legal consequences.
+#
+# AMD does not distribute or endorse sources for license-restricted
+# algorithms or software, and disclaims any liability for their use.
+
+# Using mpv requires the use of license-restricted algorithms
+# or software.
+INCLUDE_MPV ??= "no"
+
+COMMERCIAL_LIC_FLAGS_MPV = "commercial_mpv commercial_ffmpeg commercial_x264"
+LICENSE_FLAGS_WHITELIST_append = "${@' ${COMMERCIAL_LIC_FLAGS_MPV}' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
+CORE_IMAGE_EXTRA_INSTALL_append = "${@' mpv' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
+
+# Certain multimedia formats also require license restricted codecs and
+# software components which are not included in build by default.
+INCLUDE_COMMERCIAL_MULTIMEDIA ??= "no"
+
+COMMERCIAL_LIC_FLAGS_MULTIMEDIA = "\
+ commercial_gstreamer1.0-plugins-ugly \
+ commercial_gstreamer1.0-libav \
+ commercial_mpeg2dec \
+ commercial_ffmpeg \
+ commercial_x264 \
+ commercial_faad2 \
+"
+
+LICENSE_FLAGS_WHITELIST_append = "${@' ${COMMERCIAL_LIC_FLAGS_MULTIMEDIA}' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
+CORE_IMAGE_EXTRA_INSTALL_append = "${@' packagegroup-multimedia-risky' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
+
+# To fix the following error:
+# Missing or unbuildable dependency chain was: ['core-image-sato', 'gstreamer1.0-vaapi', 'gstreamer1.0-plugins-bad', 'faad2']
+GSTREAMER_PKGS_remove = "${@' gstreamer1.0-vaapi' if not bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
+
+# To fix the following error:
+# Missing or unbuildable dependency chain was: ['core-image-sato', 'packagegroup-core-x11-sato', 'gst-examples', 'gstreamer1.0-plugins-bad', 'faad2']
+GSTEXAMPLES_remove = "${@' gst-examples' if not bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
diff --git a/meta-amd-bsp/conf/machine/include/tune-e3000.inc b/meta-amd-bsp/conf/machine/include/tune-e3000.inc
new file mode 100644
index 00000000..ed6c2889
--- /dev/null
+++ b/meta-amd-bsp/conf/machine/include/tune-e3000.inc
@@ -0,0 +1,15 @@
+DEFAULTTUNE ?= "dbfp5"
+
+require conf/machine/include/x86/arch-x86.inc
+require conf/machine/include/x86-base.inc
+# AMD DB-FP5 64bit (e3000)
+TUNEVALID[dbfp5] = "Enable AMD DB-FP5 (64 bit) specific processor optimizations"
+TUNECONFLICTS[dbfp5] = "m32 mx32"
+TUNE_CCARGS .= "${@bb.utils.contains("TUNE_FEATURES", "dbfp5", " -march=znver1", "", d)}"
+
+# Extra tune selections
+AVAILTUNES += "dbfp5"
+TUNE_FEATURES_tune-dbfp5 = "m64 dbfp5"
+BASE_LIB_tune-dbfp5 = "lib64"
+TUNE_PKGARCH_tune-dbfp5 = "dbfp5"
+PACKAGE_EXTRA_ARCHS_tune-dbfp5 = "${TUNE_PKGARCH_tune-dbfp5}"
diff --git a/meta-amd-bsp/conf/machine/include/tune-r1000.inc b/meta-amd-bsp/conf/machine/include/tune-r1000.inc
new file mode 100644
index 00000000..1ac8e610
--- /dev/null
+++ b/meta-amd-bsp/conf/machine/include/tune-r1000.inc
@@ -0,0 +1,15 @@
+DEFAULTTUNE ?= "dbfp5"
+
+require conf/machine/include/x86/arch-x86.inc
+require conf/machine/include/x86-base.inc
+# AMD DB-FP5 64bit (r1000)
+TUNEVALID[dbfp5] = "Enable AMD DB-FP5 (64 bit) specific processor optimizations"
+TUNECONFLICTS[dbfp5] = "m32 mx32"
+TUNE_CCARGS .= "${@bb.utils.contains("TUNE_FEATURES", "dbfp5", " -march=znver1", "", d)}"
+
+# Extra tune selections
+AVAILTUNES += "dbfp5"
+TUNE_FEATURES_tune-dbfp5 = "m64 dbfp5"
+BASE_LIB_tune-dbfp5 = "lib64"
+TUNE_PKGARCH_tune-dbfp5 = "dbfp5"
+PACKAGE_EXTRA_ARCHS_tune-dbfp5 = "${TUNE_PKGARCH_tune-dbfp5}"
diff --git a/meta-amd-bsp/conf/machine/include/tune-v1000.inc b/meta-amd-bsp/conf/machine/include/tune-v1000.inc
new file mode 100644
index 00000000..1c481cd3
--- /dev/null
+++ b/meta-amd-bsp/conf/machine/include/tune-v1000.inc
@@ -0,0 +1,15 @@
+DEFAULTTUNE ?= "dbfp5"
+
+require conf/machine/include/x86/arch-x86.inc
+require conf/machine/include/x86-base.inc
+# AMD DB-FP5 64bit (v1000)
+TUNEVALID[dbfp5] = "Enable AMD DB-FP5 (64 bit) specific processor optimizations"
+TUNECONFLICTS[dbfp5] = "m32 mx32"
+TUNE_CCARGS .= "${@bb.utils.contains("TUNE_FEATURES", "dbfp5", " -march=znver1", "", d)}"
+
+# Extra tune selections
+AVAILTUNES += "dbfp5"
+TUNE_FEATURES_tune-dbfp5 = "m64 dbfp5"
+BASE_LIB_tune-dbfp5 = "lib64"
+TUNE_PKGARCH_tune-dbfp5 = "dbfp5"
+PACKAGE_EXTRA_ARCHS_tune-dbfp5 = "${TUNE_PKGARCH_tune-dbfp5}"
diff --git a/meta-amd-bsp/conf/machine/r1000.conf b/meta-amd-bsp/conf/machine/r1000.conf
new file mode 100644
index 00000000..c06ef728
--- /dev/null
+++ b/meta-amd-bsp/conf/machine/r1000.conf
@@ -0,0 +1,44 @@
+#@TYPE: Machine
+#@NAME: r1000
+
+#@DESCRIPTION: Machine configuration for r1000 systems
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+PREFERRED_VERSION_linux-yocto ?= "4.19%"
+PREFERRED_VERSION_rgp ?= "1.5.1"
+
+require conf/machine/include/tune-r1000.inc
+
+# Add machine specific AMD features and feature pkgs here
+EXTRA_IMAGE_FEATURES += "amd-feature-graphics amd-feature-multimedia amd-feature-debug-profile"
+VULKAN_PKGS_r1000 = "amdvlk vulkan vulkan-tools"
+AMD_FEATURE_DEBUG_PROFILE_PKGS_r1000 += " \
+ ${@bb.utils.contains('INCLUDE_VULKAN', 'yes', 'rgp', '', d)} \
+ "
+
+include conf/machine/include/amd-common-configurations.inc
+include conf/machine/include/amd-customer-configurations.inc
+
+# GPU
+XSERVER_X86_GPU = "xf86-video-amd \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-radeonsi', '', d)} \
+ "
+
+XSERVER ?= "${XSERVER_X86_BASE} \
+ ${XSERVER_X86_EXT} \
+ ${XSERVER_X86_FBDEV} \
+ ${XSERVER_X86_MODESETTING} \
+ ${XSERVER_X86_GPU} \
+ "
+
+KERNEL_MODULE_AUTOLOAD += "snd-soc-acp-pcm snd-soc-acp-rt286-mach amdgpu"
+MACHINE_EXTRA_RRECOMMENDS += "amdgpu-firmware grub-efi"
+MACHINE_EXTRA_RRECOMMENDS_remove = "rtc-test smbus-test grub"
+
+# Setup a getty on all serial ports
+SERIAL_CONSOLES = "115200;ttyS4 115200;ttyS5"
+
+# Enable the kernel console on ttyS4/USB0 as well
+KERNEL_SERIAL_CONSOLE ?= "console=ttyS4,115200n8"
+
+MACHINEOVERRIDES =. "amd:amdx86:amdgpu:"
diff --git a/meta-amd-bsp/conf/machine/v1000.conf b/meta-amd-bsp/conf/machine/v1000.conf
new file mode 100644
index 00000000..8b323063
--- /dev/null
+++ b/meta-amd-bsp/conf/machine/v1000.conf
@@ -0,0 +1,43 @@
+#@TYPE: Machine
+#@NAME: v1000
+
+#@DESCRIPTION: Machine configuration for v1000 systems
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+PREFERRED_VERSION_linux-yocto ?= "4.14%"
+PREFERRED_VERSION_rgp ?= "1.3.1"
+
+require conf/machine/include/tune-v1000.inc
+
+# Add machine specific AMD features and feature pkgs here
+VULKAN_PKGS_v1000 = "amdvlk vulkan vulkan-tools rgp"
+AMD_PLATFORM_SPECIFIC_PKGS_v1000 += " \
+ ${@bb.utils.contains('INCLUDE_OPENCL', 'yes', 'opencl', '', d)} \
+ "
+
+include conf/machine/include/amd-common-configurations.inc
+include conf/machine/include/amd-customer-configurations.inc
+
+# GPU
+XSERVER_X86_GPU = "xf86-video-amd \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-radeonsi', '', d)} \
+ "
+
+XSERVER ?= "${XSERVER_X86_BASE} \
+ ${XSERVER_X86_EXT} \
+ ${XSERVER_X86_FBDEV} \
+ ${XSERVER_X86_MODESETTING} \
+ ${XSERVER_X86_GPU} \
+ "
+
+KERNEL_MODULE_AUTOLOAD += "snd-soc-acp-pcm snd-soc-acp-rt286-mach amdgpu"
+MACHINE_EXTRA_RRECOMMENDS += "amdgpu-firmware grub-efi"
+MACHINE_EXTRA_RRECOMMENDS_remove = "rtc-test smbus-test grub"
+
+# Setup a getty on all serial ports
+SERIAL_CONSOLES = "115200;ttyS4 115200;ttyS5"
+
+# Enable the kernel console on ttyS4/USB0 as well
+KERNEL_SERIAL_CONSOLE ?= "console=ttyS4,115200n8"
+
+MACHINEOVERRIDES =. "amd:amdx86:amdgpu:"