aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/conf/layer.conf')
-rw-r--r--meta-amd-bsp/conf/layer.conf17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-amd-bsp/conf/layer.conf b/meta-amd-bsp/conf/layer.conf
new file mode 100644
index 00000000..877c3550
--- /dev/null
+++ b/meta-amd-bsp/conf/layer.conf
@@ -0,0 +1,17 @@
+BBPATH .= ":${LAYERDIR}"
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
+ ${LAYERDIR}/recipes*/*/*.bbappend"
+
+# Let us add layer-specific bbs & bbappends which are only applied
+# when that layer is included in our configuration
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())} \
+ ${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+
+BBFILE_COLLECTIONS += "amd-bsp"
+BBFILE_PRIORITY_amd-bsp = "13"
+BBFILE_PATTERN_amd-bsp = "^${LAYERDIR}/"
+LAYERSERIES_COMPAT_amd-bsp = "kirkstone"
+
+LAYERDEPENDS_amd-bsp = "core openembedded-layer meta-python networking-layer"