aboutsummaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
Diffstat (limited to 'common')
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch36
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-configure.ac-obey-llvm_prefix-if-available.patch30
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch72
-rw-r--r--common/recipes-graphics/mesa/mesa_19.0.1.bbappend (renamed from common/recipes-graphics/mesa/mesa_git.bb)25
4 files changed, 0 insertions, 163 deletions
diff --git a/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch b/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
deleted file mode 100644
index 7338cf50..00000000
--- a/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 5f05454b30da807a02233e99373a37b7c863d5c3 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Thu, 26 Jul 2018 17:13:32 +0500
-Subject: [PATCH] configure.ac: adjust usage of LLVM flags
-
-The llvm-config is provided through a native build
-so using flags from there creates conflicts between
-mesa and llvm on the target.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
-
----
- configure.ac | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index f59b29f2d68..893d41f7094 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1101,6 +1101,7 @@ strip_unwanted_llvm_flags() {
- -e 's/[[[:space:]]]+-pedantic[[[:space:]]]/ /g' \
- -e 's/[[[:space:]]]+-W[[^[:space:]]]*//g' \
- -e 's/[[[:space:]]]+-O[[^[:space:]]]*//g' \
-+ -e 's/[[[:space:]]]+-D_GLIBCXX_USE_CXX11_ABI[[^[:space:]]]*//g' \
- -e 's/[[[:space:]]]+-g[[^[:space:]]]*//g' \
- -e 's/-fno-rtti[[[:space:]]]/-Fno-rtti /g' \
- -e 's/[[[:space:]]]+-f[[^[:space:]]]*//g' \
-@@ -2900,7 +2901,7 @@ dnl
- if test "x$enable_llvm" = xyes; then
- DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DMESA_LLVM_VERSION_PATCH=$LLVM_VERSION_PATCH"
-
-- LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
-+ LLVM_LDFLAGS=
- LLVM_CFLAGS=$LLVM_CPPFLAGS # CPPFLAGS seem to be sufficient
- LLVM_CXXFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cxxflags"`
- LLVM_CXXFLAGS="$CXX11_CXXFLAGS $LLVM_CXXFLAGS"
diff --git a/common/recipes-graphics/mesa/mesa/0001-configure.ac-obey-llvm_prefix-if-available.patch b/common/recipes-graphics/mesa/mesa/0001-configure.ac-obey-llvm_prefix-if-available.patch
deleted file mode 100644
index 76e152e7..00000000
--- a/common/recipes-graphics/mesa/mesa/0001-configure.ac-obey-llvm_prefix-if-available.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 8dc29db401030725ca0201ba03feb6238ec258f7 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Fri, 20 Jul 2018 17:58:45 +0500
-Subject: [PATCH] configure.ac: obey llvm_prefix if available
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- configure.ac | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index d1c8bb82da..92a83fec4a 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -2821,7 +2821,11 @@ if test "x$enable_llvm" = xyes; then
-
- if test $LLVM_VERSION_MAJOR -ge 4 -o $LLVM_VERSION_MAJOR -eq 3 -a $LLVM_VERSION_MINOR -ge 9; then
- if test "x$enable_llvm_shared_libs" = xyes; then
-- LLVM_LIBS="`$LLVM_CONFIG --link-shared --libs ${LLVM_COMPONENTS}`"
-+ if test "x${llvm_prefix}" == "x"; then
-+ LLVM_LIBS="`$LLVM_CONFIG --link-shared --libs ${LLVM_COMPONENTS}`"
-+ else
-+ LLVM_LIBS="`$LLVM_CONFIG --link-shared --libs ${LLVM_COMPONENTS} --tgtlibdir ${llvm_prefix}`"
-+ fi
- else
- dnl Invoking llvm-config with both -libs and --system-libs produces the
- dnl two separate lines - each for the set of libraries.
---
-2.11.1
-
diff --git a/common/recipes-graphics/mesa/mesa/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch b/common/recipes-graphics/mesa/mesa/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch
deleted file mode 100644
index e487d420..00000000
--- a/common/recipes-graphics/mesa/mesa/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From fa10114debafb2058789047704dbe2b21ce8df7e Mon Sep 17 00:00:00 2001
-From: Leo Liu <leo.liu@amd.com>
-Date: Tue, 19 Mar 2019 13:37:39 -0400
-Subject: [PATCH] vl/dri3: remove the wait before getting back buffer
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-The wait here is unnecessary since we got a pool of back buffers,
-and the wait for swap buffer will happen before the present pixmap,
-at the same time the previous back buffer will be put back to pool
-for reuse after the check for PresentIdleNotify event
-
-Signed-off-by: Leo Liu <leo.liu@amd.com>
-Reviewed-by: Michel Dänzer <michel.daenzer@amd.com>
----
- src/gallium/auxiliary/vl/vl_winsys_dri3.c | 18 +++---------------
- 1 file changed, 3 insertions(+), 15 deletions(-)
-
-diff --git a/src/gallium/auxiliary/vl/vl_winsys_dri3.c b/src/gallium/auxiliary/vl/vl_winsys_dri3.c
-index 152d28e59fc..1558d832555 100644
---- a/src/gallium/auxiliary/vl/vl_winsys_dri3.c
-+++ b/src/gallium/auxiliary/vl/vl_winsys_dri3.c
-@@ -88,7 +88,6 @@ struct vl_dri3_screen
- uint64_t send_sbc, recv_sbc;
- int64_t last_ust, ns_frame, last_msc, next_msc;
-
-- bool flushed;
- bool is_different_gpu;
- };
-
-@@ -570,11 +569,9 @@ vl_dri3_flush_frontbuffer(struct pipe_screen *screen,
- if (!back)
- return;
-
-- if (scrn->flushed) {
-- while (scrn->special_event && scrn->recv_sbc < scrn->send_sbc)
-- if (!dri3_wait_present_events(scrn))
-- return;
-- }
-+ while (scrn->special_event && scrn->recv_sbc < scrn->send_sbc)
-+ if (!dri3_wait_present_events(scrn))
-+ return;
-
- rectangle.x = 0;
- rectangle.y = 0;
-@@ -610,8 +607,6 @@ vl_dri3_flush_frontbuffer(struct pipe_screen *screen,
-
- xcb_flush(scrn->conn);
-
-- scrn->flushed = true;
--
- return;
- }
-
-@@ -626,13 +621,6 @@ vl_dri3_screen_texture_from_drawable(struct vl_screen *vscreen, void *drawable)
- if (!dri3_set_drawable(scrn, (Drawable)drawable))
- return NULL;
-
-- if (scrn->flushed) {
-- while (scrn->special_event && scrn->recv_sbc < scrn->send_sbc)
-- if (!dri3_wait_present_events(scrn))
-- return NULL;
-- }
-- scrn->flushed = false;
--
- buffer = (scrn->is_pixmap) ?
- dri3_get_front_buffer(scrn) :
- dri3_get_back_buffer(scrn);
---
-2.17.1
-
diff --git a/common/recipes-graphics/mesa/mesa_git.bb b/common/recipes-graphics/mesa/mesa_19.0.1.bbappend
index de2e8481..07695036 100644
--- a/common/recipes-graphics/mesa/mesa_git.bb
+++ b/common/recipes-graphics/mesa/mesa_19.0.1.bbappend
@@ -1,14 +1,3 @@
-require recipes-graphics/mesa/${BPN}.inc
-
-S = "${WORKDIR}/git"
-
-DEPENDS_append = " python-mako-native"
-inherit pythonnative
-
-SRCREV_amd = "d2c170eb355a912586cb982858faac2fc85c4783"
-LIC_FILES_CHKSUM_amd = "file://docs/license.html;md5=725f991a1cc322aa7a0cd3a2016621c4"
-PV_amd = "19.0.0+git${SRCPV}"
-
DEPENDS_append_amd = " libvdpau libomxil"
PACKAGECONFIG[va] = "--enable-va,--disable-va,libva"
@@ -24,11 +13,6 @@ LIBVA_PLATFORMS .= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' libva-x11',
LIBVA_PLATFORMS .= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', ' libva-wayland', '', d)}"
RDEPENDS_mesa-megadriver += "${@bb.utils.contains('PACKAGECONFIG', 'va', '${LIBVA_PLATFORMS}', '', d)}"
-SRC_URI_amd = "git://anongit.freedesktop.org/mesa/mesa;branch=master \
- file://0001-configure.ac-obey-llvm_prefix-if-available.patch \
- file://0001-configure.ac-adjust-usage-of-LLVM-flags.patch \
- file://0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch"
-
EXTRA_OECONF_append_amd = " \
--enable-vdpau \
--enable-osmesa \
@@ -67,12 +51,3 @@ python () {
d.setVar("DRIDRIVERS", "swrast,radeon")
d.setVar("GALLIUMDRIVERS", "swrast,r300,r600,radeonsi")
}
-
-#because we cannot rely on the fact that all apps will use pkgconfig,
-#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
-do_install_append() {
- if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
- sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
- fi
-}
-