aboutsummaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
Diffstat (limited to 'common')
-rw-r--r--common/conf/machine/include/amd-common-configurations.inc6
-rw-r--r--common/recipes-core/llvm/files/0001-llvm-config-allow-overriding-libdir-through-cmdline.patch101
-rw-r--r--common/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch35
-rw-r--r--common/recipes-core/llvm/llvm_git.bbappend16
4 files changed, 3 insertions, 155 deletions
diff --git a/common/conf/machine/include/amd-common-configurations.inc b/common/conf/machine/include/amd-common-configurations.inc
index 0b41f3f9..32db2544 100644
--- a/common/conf/machine/include/amd-common-configurations.inc
+++ b/common/conf/machine/include/amd-common-configurations.inc
@@ -6,12 +6,12 @@ PREFERRED_PROVIDER_jpeg ?= "jpeg"
PREFERRED_PROVIDER_jpeg-native ?= "jpeg-native"
PREFERRED_VERSION_linux-yocto ?= "4.4%"
PREFERRED_VERSION_libav ?= "9.18"
-PREFERRED_PROVIDER_llvm ?= "llvm7"
+PREFERRED_PROVIDER_llvm ?= "llvm8.0.0"
# Components that depend on LLVM should set versions here
# so we know what needs to be changed/validated as LLVM moves
-MESA_LLVM_RELEASE_amd = "7"
-CLAMAV_LLVM_RELEASE_amd = "7"
+MESA_LLVM_RELEASE_amd = "8.0.0"
+CLAMAV_LLVM_RELEASE_amd = "8.0.0"
MULTILIBS ?= ""
require conf/multilib.conf
diff --git a/common/recipes-core/llvm/files/0001-llvm-config-allow-overriding-libdir-through-cmdline.patch b/common/recipes-core/llvm/files/0001-llvm-config-allow-overriding-libdir-through-cmdline.patch
deleted file mode 100644
index 26bf42e5..00000000
--- a/common/recipes-core/llvm/files/0001-llvm-config-allow-overriding-libdir-through-cmdline.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-From 87b01c9e5cecd30f9cde1f717e1ae7094e1f62c1 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Wed, 13 Dec 2017 14:15:24 +0500
-Subject: [PATCH] llvm-config: allow overriding libdir through cmdline
-
-This is handy in cases such as the OE environment
-where llvm-config is used through the llvm-native
-package so the libdir it reports can be different
-what is required for the target sysroot and so if
-the baselib is different for target and host the
-llvm-config --libs command will fail complaining
-about not finding required libraries. This scenario
-can be reproduced through an LLVM enabled mesa build
-where host and target have different baselib. So
-after the patch the mesa build should pass the whole
-target libdir to the llvm-config command to use.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- tools/llvm-config/llvm-config.cpp | 32 ++++++++++++++++++++++++++++----
- 1 file changed, 28 insertions(+), 4 deletions(-)
-
-diff --git a/tools/llvm-config/llvm-config.cpp b/tools/llvm-config/llvm-config.cpp
-index 08b096afb05..8233d16dda0 100644
---- a/tools/llvm-config/llvm-config.cpp
-+++ b/tools/llvm-config/llvm-config.cpp
-@@ -301,6 +301,18 @@ int main(int argc, char **argv) {
- DevelopmentTreeLayout = CMakeStyle; // Initialized to avoid warnings.
- }
-
-+ // Check if we were given a special libdir to use
-+ // if so disregard all other libdir settings
-+ std::string TargetLibDir;
-+ for (int i = 1; i != argc; ++i) {
-+ if (strcmp(argv[i],"--tgtlibdir") == 0) {
-+ if (argc > i+1) {
-+ TargetLibDir.assign(argv[i+1]);
-+ break;
-+ }
-+ }
-+ }
-+
- // Compute various directory locations based on the derived location
- // information.
- std::string ActivePrefix, ActiveBinDir, ActiveIncludeDir, ActiveLibDir,
-@@ -315,13 +327,19 @@ int main(int argc, char **argv) {
- switch (DevelopmentTreeLayout) {
- case CMakeStyle:
- ActiveBinDir = ActiveObjRoot + "/bin";
-- ActiveLibDir = ActiveObjRoot + "/lib" + LLVM_LIBDIR_SUFFIX;
-+ if (!TargetLibDir.empty())
-+ ActiveLibDir = TargetLibDir;
-+ else
-+ ActiveLibDir = ActiveObjRoot + "/lib" + LLVM_LIBDIR_SUFFIX;
- ActiveCMakeDir = ActiveLibDir + "/cmake/llvm";
- break;
- case CMakeBuildModeStyle:
- ActivePrefix = ActiveObjRoot;
- ActiveBinDir = ActiveObjRoot + "/bin/" + build_mode;
-- ActiveLibDir =
-+ if (!TargetLibDir.empty())
-+ ActiveLibDir = TargetLibDir;
-+ else
-+ ActiveLibDir =
- ActiveObjRoot + "/lib" + LLVM_LIBDIR_SUFFIX + "/" + build_mode;
- ActiveCMakeDir = ActiveLibDir + "/cmake/llvm";
- break;
-@@ -336,7 +354,10 @@ int main(int argc, char **argv) {
- SmallString<256> path(StringRef(LLVM_TOOLS_INSTALL_DIR));
- sys::fs::make_absolute(ActivePrefix, path);
- ActiveBinDir = path.str();
-- ActiveLibDir = ActivePrefix + "/lib" + LLVM_LIBDIR_SUFFIX;
-+ if (!TargetLibDir.empty())
-+ ActiveLibDir = TargetLibDir;
-+ else
-+ ActiveLibDir = ActivePrefix + "/lib" + LLVM_LIBDIR_SUFFIX;
- ActiveCMakeDir = ActiveLibDir + "/cmake/llvm";
- ActiveIncludeOption = "-I" + ActiveIncludeDir;
- }
-@@ -468,7 +489,7 @@ int main(int argc, char **argv) {
- };
-
- raw_ostream &OS = outs();
-- for (int i = 1; i != argc; ++i) {
-+ for (int i = 1; i < argc; ++i) {
- StringRef Arg = argv[i];
-
- if (Arg.startswith("-")) {
-@@ -567,6 +588,9 @@ int main(int argc, char **argv) {
- LinkMode = LinkModeShared;
- } else if (Arg == "--link-static") {
- LinkMode = LinkModeStatic;
-+ } else if (Arg == "--tgtlibdir") {
-+ ++i;
-+ continue;
- } else {
- usage();
- }
---
-2.11.1
-
diff --git a/common/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch b/common/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch
deleted file mode 100644
index 7b490a81..00000000
--- a/common/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From ac39269933a9011567722e69c02734beaa1191b3 Mon Sep 17 00:00:00 2001
-From: Martin Kelly <mkelly@xevo.com>
-Date: Fri, 19 May 2017 00:22:57 -0700
-Subject: [PATCH] llvm: allow env override of exe path
-
-When using a native llvm-config from inside a sysroot, we need llvm-config to
-return the libraries, include directories, etc. from inside the sysroot rather
-than from the native sysroot. Thus provide an env override for calling
-llvm-config from a target sysroot.
-
-Signed-off-by: Martin Kelly <mkelly@xevo.com>
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
----
- tools/llvm-config/llvm-config.cpp | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/tools/llvm-config/llvm-config.cpp b/tools/llvm-config/llvm-config.cpp
-index 892adc3b9dd..73b6989fa9e 100644
---- a/tools/llvm-config/llvm-config.cpp
-+++ b/tools/llvm-config/llvm-config.cpp
-@@ -226,6 +226,13 @@ Typical components:\n\
-
- /// Compute the path to the main executable.
- std::string GetExecutablePath(const char *Argv0) {
-+ // Hack for Yocto: we need to override the root path when we are using
-+ // llvm-config from within a target sysroot.
-+ const char *Sysroot = std::getenv("YOCTO_ALTERNATE_EXE_PATH");
-+ if (Sysroot != nullptr) {
-+ return Sysroot;
-+ }
-+
- // This just needs to be some symbol in the binary; C++ doesn't
- // allow taking the address of ::main however.
- void *P = (void *)(intptr_t)GetExecutablePath;
diff --git a/common/recipes-core/llvm/llvm_git.bbappend b/common/recipes-core/llvm/llvm_git.bbappend
deleted file mode 100644
index bd77ed77..00000000
--- a/common/recipes-core/llvm/llvm_git.bbappend
+++ /dev/null
@@ -1,16 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=c520ed40e11887bb1d24d86f7f5b1f05"
-
-SRCREV = "4a059213dd6f034147e9083c21133dc1b57b3a8a"
-PV = "7"
-BRANCH = "release_70"
-PATCH_VERSION = "0"
-
-SRC_URI += "file://0001-llvm-config-allow-overriding-libdir-through-cmdline.patch"
-SRC_URI_remove = "file://0001-Disable-generating-a-native-llvm-config.patch"
-
-INSANE_SKIP_${MLPREFIX}libllvm${LLVM_RELEASE}-llvm-${LLVM_RELEASE}.${PATCH_VERSION}.0 += "dev-so"
-
-PACKAGES =+ "${PN}-testplugin"
-FILES_${PN}-testplugin = "${libdir}/${LLVM_DIR}/TestPlugin.so"
-FILES_${PN}-dbg += "${libdir}/${LLVM_DIR}/.debug/TestPlugin.so"