aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-sato
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-sato')
-rw-r--r--common/recipes-sato/packagegroups/packagegroup-core-x11-sato.bbappend12
1 files changed, 7 insertions, 5 deletions
diff --git a/common/recipes-sato/packagegroups/packagegroup-core-x11-sato.bbappend b/common/recipes-sato/packagegroups/packagegroup-core-x11-sato.bbappend
index c40f51d3..3602803c 100644
--- a/common/recipes-sato/packagegroups/packagegroup-core-x11-sato.bbappend
+++ b/common/recipes-sato/packagegroups/packagegroup-core-x11-sato.bbappend
@@ -1,7 +1,9 @@
-# Remove gaku from the apps as it depends
-# on gstreamer which is currently unsupported
python __anonymous () {
- rdepvar = "RDEPENDS_%s-apps" % (d.getVar("PN", True))
- rdep = d.getVar(rdepvar, True)
- d.setVar(rdepvar, rdep.replace("gaku", ""))
+ if d.getVar("DISTRO", True) == "mel-lite":
+ # Remove gaku from the apps as it depends
+ # on gstreamer which is currently unsupported
+ # in MEL Lite.
+ rdepvar = "RDEPENDS_%s-apps" % (d.getVar("PN", True))
+ rdep = d.getVar(rdepvar, True)
+ d.setVar(rdepvar, rdep.replace("gaku", ""))
}