aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-sato/images/core-image-sato.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-sato/images/core-image-sato.bbappend')
-rw-r--r--common/recipes-sato/images/core-image-sato.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/common/recipes-sato/images/core-image-sato.bbappend b/common/recipes-sato/images/core-image-sato.bbappend
index 31818edc..0f626879 100644
--- a/common/recipes-sato/images/core-image-sato.bbappend
+++ b/common/recipes-sato/images/core-image-sato.bbappend
@@ -2,3 +2,10 @@ require conf/machine/include/amd-common.inc
IMAGE_INSTALL_append_amdgpu = " mesa-demos"
IMAGE_INSTALL_append_radeon = " mesa-demos"
+
+VULKAN_COMPONENTS_amdfalconx86 = "glslang spirv-tools vulkan-loader-layers vulkan-tools vulkan-samples"
+CODEXL_COMPONENTS = "codexl codexl-examples"
+
+IMAGE_INSTALL_append = "${@' ${VULKAN_COMPONENTS}' if bb.utils.to_boolean('${INCLUDE_VULKAN}') else ''} \
+ ${@' ${CODEXL_COMPONENTS}' if bb.utils.to_boolean('${INCLUDE_CODEXL}') else ''} \
+ "