aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/libomxil/libomxil
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-multimedia/libomxil/libomxil')
-rw-r--r--common/recipes-multimedia/libomxil/libomxil/0001-Added-NULL-pointer-check-for-failure-scenario.patch34
-rw-r--r--common/recipes-multimedia/libomxil/libomxil/0001-test-components-fix-linking-issue.patch44
2 files changed, 0 insertions, 78 deletions
diff --git a/common/recipes-multimedia/libomxil/libomxil/0001-Added-NULL-pointer-check-for-failure-scenario.patch b/common/recipes-multimedia/libomxil/libomxil/0001-Added-NULL-pointer-check-for-failure-scenario.patch
deleted file mode 100644
index e86f2d4b..00000000
--- a/common/recipes-multimedia/libomxil/libomxil/0001-Added-NULL-pointer-check-for-failure-scenario.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 3eb67fb18c26f6cdf4daf7dc3f987b217315e984 Mon Sep 17 00:00:00 2001
-From: Indrajit Das <indrajit-kumar.das@amd.com>
-Date: Tue, 29 Mar 2016 22:51:13 +0530
-Subject: [PATCH] Added NULL pointer check for failure scenario
-
----
- src/base/omx_base_component.c | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/src/base/omx_base_component.c b/src/base/omx_base_component.c
-index 4156c37..86c6795 100644
---- a/src/base/omx_base_component.c
-+++ b/src/base/omx_base_component.c
-@@ -1631,12 +1631,17 @@ OSCL_EXPORT_REF OMX_ERRORTYPE omx_base_component_MessageHandler(OMX_COMPONENTTYP
- }
- }
- else {
-+ if(NULL != omx_base_component_Private->ports)
-+ {
- pPort=omx_base_component_Private->ports[message->messageParam];
- if(omx_base_component_Private->state!=OMX_StateLoaded) {
- err = pPort->FlushProcessingBuffers(pPort);
- DEBUG(DEB_LEV_FULL_SEQ, "In %s: Port Flush completed for Comp %s\n",__func__,omx_base_component_Private->name);
- }
- err = pPort->Port_DisablePort(pPort);
-+ }
-+ else
-+ printf("Skipping NULL pointer access\n");
- }
- /** This condition is added to pass the tests, it is not significant for the environment */
- if (err != OMX_ErrorNone) {
---
-2.1.4
-
diff --git a/common/recipes-multimedia/libomxil/libomxil/0001-test-components-fix-linking-issue.patch b/common/recipes-multimedia/libomxil/libomxil/0001-test-components-fix-linking-issue.patch
deleted file mode 100644
index 4704c30a..00000000
--- a/common/recipes-multimedia/libomxil/libomxil/0001-test-components-fix-linking-issue.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From a923a068ec8c44a88cfcac545d6d0cee074cbffa Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Fri, 20 May 2016 16:09:39 +0500
-Subject: [PATCH] test/components: fix linking issue
-
-The test binaries pick up incorrect rpaths due to the wrong
-usage of linking of the libomxil-bellagio lib which
-is produced by the same package.
-We now use the libtool description file in the link
-command to correctly identify and pick up the libs
-without hardcoding.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
-Upstream-status: Pending
----
- test/components/audio_effects/Makefile.am | 4 ++--
- test/components/resource_manager/Makefile.am | 4 ++--
-
-diff --git a/test/components/audio_effects/Makefile.am b/test/components/audio_effects/Makefile.am
-index b28b992..ee9cffa 100644
---- a/test/components/audio_effects/Makefile.am
-+++ b/test/components/audio_effects/Makefile.am
-@@ -1,6 +1,6 @@
- check_PROGRAMS = omxvolcontroltest omxaudiomixertest
-
--bellagio_LDADD = -lomxil-bellagio
-+bellagio_LDADD = $(top_builddir)/src/libomxil-bellagio.la
- common_CFLAGS = -I$(top_srcdir)/test/components/common -I$(includedir)
-
- omxvolcontroltest_SOURCES = omxvolcontroltest.c omxvolcontroltest.h
-diff --git a/test/components/resource_manager/Makefile.am b/test/components/resource_manager/Makefile.am
-index fcc1d99..c24d32c 100644
---- a/test/components/resource_manager/Makefile.am
-+++ b/test/components/resource_manager/Makefile.am
-@@ -1,6 +1,6 @@
- check_PROGRAMS = omxrmtest omxprioritytest
-
--bellagio_LDADD = -lomxil-bellagio
-+bellagio_LDADD = $(top_builddir)/src/libomxil-bellagio.la
- common_CFLAGS = -I$(top_srcdir)/test/components/common -I$(includedir)
-
- omxrmtest_SOURCES = omxrmtest.c omxrmtest.h
---
-1.9.1