aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/gpio-load/amd-gpio-load_1.0.bb17
-rw-r--r--common/recipes-kernel/gpio-load/files/modprobe.d/gpio-amd.conf0
-rw-r--r--common/recipes-kernel/linux/files/0001-amdgpu-fix-various-compilation-issues.patch40
-rw-r--r--common/recipes-kernel/linux/files/0001-mmc-sdhci-add-AMD-CZ-device-handling.patch8
-rw-r--r--common/recipes-kernel/linux/files/1570-4-1-0-kernel-s-drivers-I2C-directory.patch27
-rw-r--r--common/recipes-kernel/linux/files/linux-yocto-amd-patches.scc1
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend6
-rw-r--r--common/recipes-kernel/lttng/lttng-modules/trace_clock_disable_preemption.patch45
-rw-r--r--common/recipes-kernel/lttng/lttng-modules_git.bbappend2
-rw-r--r--common/recipes-kernel/wdt-load/amd-wdt-load_1.0.bb18
-rw-r--r--common/recipes-kernel/wdt-load/files/modprobe.d/amd-wdt.conf0
11 files changed, 48 insertions, 116 deletions
diff --git a/common/recipes-kernel/gpio-load/amd-gpio-load_1.0.bb b/common/recipes-kernel/gpio-load/amd-gpio-load_1.0.bb
deleted file mode 100644
index eba925e4..00000000
--- a/common/recipes-kernel/gpio-load/amd-gpio-load_1.0.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-DESCRIPTION = "Configuration file to pass module load parameters to AMD GPIO driver"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
-SRC_URI = "file://modprobe.d/gpio-amd.conf"
-
-PR = "r0"
-PV = "1.0"
-
-S = "${WORKDIR}"
-
-do_install() {
- install -d ${D}/${sysconfdir}/modprobe.d/
- install -m 0644 modprobe.d/gpio-amd.conf ${D}${sysconfdir}/modprobe.d/
-}
-
-FILES_${PN} = "${sysconfdir}/modprobe.d"
diff --git a/common/recipes-kernel/gpio-load/files/modprobe.d/gpio-amd.conf b/common/recipes-kernel/gpio-load/files/modprobe.d/gpio-amd.conf
deleted file mode 100644
index e69de29b..00000000
--- a/common/recipes-kernel/gpio-load/files/modprobe.d/gpio-amd.conf
+++ /dev/null
diff --git a/common/recipes-kernel/linux/files/0001-amdgpu-fix-various-compilation-issues.patch b/common/recipes-kernel/linux/files/0001-amdgpu-fix-various-compilation-issues.patch
new file mode 100644
index 00000000..91aa2bb5
--- /dev/null
+++ b/common/recipes-kernel/linux/files/0001-amdgpu-fix-various-compilation-issues.patch
@@ -0,0 +1,40 @@
+From 480e54e78f3df2bbc21f7977d3f55dc5aef5317e Mon Sep 17 00:00:00 2001
+From: Awais Belal <awais_belal@mentor.com>
+Date: Wed, 13 Jul 2016 15:18:23 -0700
+Subject: [PATCH] amdgpu: fix various compilation issues
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+Signed-off-by: Drew Moseley <drew_moseley@mentor.com>
+---
+ drivers/gpu/drm/amd/dal/dc/calcs/bandwidth_calcs.c | 2 +-
+ drivers/gpu/drm/amd/dal/dc/core/dc_link_ddc.c | 1 -
+ 2 files changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/drivers/gpu/drm/amd/dal/dc/calcs/bandwidth_calcs.c b/drivers/gpu/drm/amd/dal/dc/calcs/bandwidth_calcs.c
+index f39499a..e995f9b 100644
+--- a/drivers/gpu/drm/amd/dal/dc/calcs/bandwidth_calcs.c
++++ b/drivers/gpu/drm/amd/dal/dc/calcs/bandwidth_calcs.c
+@@ -3181,7 +3181,7 @@ static void calculate_bandwidth(
+ bw_int_to_fixed(
+ 2),
+ vbios->mcifwrmc_urgent_latency),
+- results->dmif_burst_time[i][j]),
++ results->dmif_burst_time[results->y_clk_level][results->sclk_level]),
+ results->mcifwr_burst_time[results->y_clk_level][results->sclk_level])),
+ results->dispclk),
+ bw_int_to_fixed(
+diff --git a/drivers/gpu/drm/amd/dal/dc/core/dc_link_ddc.c b/drivers/gpu/drm/amd/dal/dc/core/dc_link_ddc.c
+index 698a34e..13a1449 100644
+--- a/drivers/gpu/drm/amd/dal/dc/core/dc_link_ddc.c
++++ b/drivers/gpu/drm/amd/dal/dc/core/dc_link_ddc.c
+@@ -41,7 +41,6 @@
+ #define CV_SMART_DONGLE_ADDRESS 0x20
+ /* DVI-HDMI dongle slave address for retrieving dongle signature*/
+ #define DVI_HDMI_DONGLE_ADDRESS 0x68
+-static const int8_t dvi_hdmi_dongle_signature_str[] = "6140063500G";
+ struct dvi_hdmi_dongle_signature_data {
+ int8_t vendor[3];/* "AMD" */
+ uint8_t version[2];
+--
+2.9.1
+
diff --git a/common/recipes-kernel/linux/files/0001-mmc-sdhci-add-AMD-CZ-device-handling.patch b/common/recipes-kernel/linux/files/0001-mmc-sdhci-add-AMD-CZ-device-handling.patch
index fe6783a9..056c8ee2 100644
--- a/common/recipes-kernel/linux/files/0001-mmc-sdhci-add-AMD-CZ-device-handling.patch
+++ b/common/recipes-kernel/linux/files/0001-mmc-sdhci-add-AMD-CZ-device-handling.patch
@@ -13,14 +13,14 @@ Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org>
Signed-off-by: Arindam Nath <arindam.nath@amd.com>
Signed-off-by: Awais Belal <awais_belal@mentor.com>
---
- drivers/mmc/host/sdhci-pci.c | 26 +++++++++++++++++++++++++-
+ drivers/mmc/host/sdhci-pci-core.c | 26 +++++++++++++++++++++++++-
include/linux/pci_ids.h | 1 +
2 files changed, 26 insertions(+), 1 deletion(-)
-diff --git a/drivers/mmc/host/sdhci-pci.c b/drivers/mmc/host/sdhci-pci.c
+diff --git a/drivers/mmc/host/sdhci-pci-core.c b/drivers/mmc/host/sdhci-pci-core.c
index 53cfc7c..6ee5f2b 100644
---- a/drivers/mmc/host/sdhci-pci.c
-+++ b/drivers/mmc/host/sdhci-pci.c
+--- a/drivers/mmc/host/sdhci-pci-core.c
++++ b/drivers/mmc/host/sdhci-pci-core.c
@@ -656,14 +656,38 @@ static const struct sdhci_pci_fixes sdhci_rtsx = {
.probe_slot = rtsx_probe_slot,
};
diff --git a/common/recipes-kernel/linux/files/1570-4-1-0-kernel-s-drivers-I2C-directory.patch b/common/recipes-kernel/linux/files/1570-4-1-0-kernel-s-drivers-I2C-directory.patch
index cf83439f..12b131ee 100644
--- a/common/recipes-kernel/linux/files/1570-4-1-0-kernel-s-drivers-I2C-directory.patch
+++ b/common/recipes-kernel/linux/files/1570-4-1-0-kernel-s-drivers-I2C-directory.patch
@@ -197,33 +197,6 @@ index 3f7d487..0a80e4a 100644
if (ACPI_FAILURE(acpi_evaluate_object(handle, method, NULL, &buf)))
return;
-@@ -273,6 +253,12 @@ static int dw_i2c_probe(struct platform_device *pdev)
- adap->dev.parent = &pdev->dev;
- adap->dev.of_node = pdev->dev.of_node;
-
-+ r = i2c_add_numbered_adapter(adap);
-+ if (r) {
-+ dev_err(&pdev->dev, "failure adding adapter\n");
-+ return r;
-+ }
-+
- if (dev->pm_runtime_disabled) {
- pm_runtime_forbid(&pdev->dev);
- } else {
-@@ -282,13 +268,6 @@ static int dw_i2c_probe(struct platform_device *pdev)
- pm_runtime_enable(&pdev->dev);
- }
-
-- r = i2c_add_numbered_adapter(adap);
-- if (r) {
-- dev_err(&pdev->dev, "failure adding adapter\n");
-- pm_runtime_disable(&pdev->dev);
-- return r;
-- }
--
- return 0;
- }
-
diff --git a/drivers/i2c/busses/i2c-mv64xxx.c b/drivers/i2c/busses/i2c-mv64xxx.c
index 5801227..30059c1 100644
--- a/drivers/i2c/busses/i2c-mv64xxx.c
diff --git a/common/recipes-kernel/linux/files/linux-yocto-amd-patches.scc b/common/recipes-kernel/linux/files/linux-yocto-amd-patches.scc
index ffbcf476..db38401d 100644
--- a/common/recipes-kernel/linux/files/linux-yocto-amd-patches.scc
+++ b/common/recipes-kernel/linux/files/linux-yocto-amd-patches.scc
@@ -1465,4 +1465,5 @@ patch 1573-Add-power-gating-initialization-support-for-GFX8.0.patch
patch 1574-add-support-of-SW-clock-gating-for-UVD6.patch
patch 0300-amd-powerplay-handle-power-management-state-based-on.patch
patch 0001-ALSA-hda-add-AMD-Stoney-PCI-ID-with-proper-driver-ca.patch
+patch 0001-amdgpu-fix-various-compilation-issues.patch
patch 0001-fs-prioritize-ext4-rootfs-type.patch
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
index ad262906..faadb27d 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -4,9 +4,9 @@ PR := "${INC_PR}.1"
KBRANCH_amdx86 ?= "standard/base"
KMACHINE_amdx86 ?= "common-pc-64"
-SRCREV_machine_amdx86 ?= "dd6492b44151164242718855d6c9eebbf0018eac"
-SRCREV_meta_amdx86 ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
-LINUX_VERSION_amdx86 ?= "4.1.18"
+SRCREV_machine_amdx86 ?= "ecc983477682203619da0e456fa4a8689ac41097"
+SRCREV_meta_amdx86 ?= "d6e1f4bfc254c677a8dfef92f0ad8c78bdeeea75"
+LINUX_VERSION_amdx86 ?= "4.1.24"
SRC_URI_append_amdx86 += " \
file://linux-yocto-amd-patches.scc \
diff --git a/common/recipes-kernel/lttng/lttng-modules/trace_clock_disable_preemption.patch b/common/recipes-kernel/lttng/lttng-modules/trace_clock_disable_preemption.patch
deleted file mode 100644
index 7b266793..00000000
--- a/common/recipes-kernel/lttng/lttng-modules/trace_clock_disable_preemption.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From d3a177c909622313ef3a314e0ce812b0aca9d5ad Mon Sep 17 00:00:00 2001
-From: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
-Date: Fri, 9 Oct 2015 12:24:23 -0400
-Subject: [PATCH] Fix: lttng trace-clock needs to disable preemption
-
-We use a per-cpu data structure, and some contexts (e.g. buffer create)
-call this function with preemption enabled. This is the case also for
-buffer flush operation.
-
-Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
----
- wrapper/trace-clock.h | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/wrapper/trace-clock.h b/wrapper/trace-clock.h
-index d7d1842..561094b 100644
---- a/wrapper/trace-clock.h
-+++ b/wrapper/trace-clock.h
-@@ -90,7 +90,7 @@ static inline u64 trace_clock_fixup(u64 src_now, u64 last)
- #endif /* #else #if (BITS_PER_LONG == 32) */
-
- /*
-- * Always called with preemption disabled. Can be interrupted.
-+ * Sometimes called with preemption enabled. Can be interrupted.
- */
- static inline u64 trace_clock_monotonic_wrapper(void)
- {
-@@ -99,6 +99,7 @@ static inline u64 trace_clock_monotonic_wrapper(void)
- local_t *last_tsc;
-
- /* Use fast nmi-safe monotonic clock provided by the Linux kernel. */
-+ preempt_disable();
- last_tsc = lttng_this_cpu_ptr(&lttng_last_tsc);
- last = local_read(last_tsc);
- /*
-@@ -112,6 +113,7 @@ static inline u64 trace_clock_monotonic_wrapper(void)
- if (((long) now - (long) last) < 0)
- now = trace_clock_fixup(now, last);
- result = local_cmpxchg(last_tsc, last, (unsigned long) now);
-+ preempt_enable();
- if (result == last) {
- /* Update done. */
- return now;
---
-1.9.1
diff --git a/common/recipes-kernel/lttng/lttng-modules_git.bbappend b/common/recipes-kernel/lttng/lttng-modules_git.bbappend
deleted file mode 100644
index 9896bfff..00000000
--- a/common/recipes-kernel/lttng/lttng-modules_git.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://trace_clock_disable_preemption.patch"
diff --git a/common/recipes-kernel/wdt-load/amd-wdt-load_1.0.bb b/common/recipes-kernel/wdt-load/amd-wdt-load_1.0.bb
deleted file mode 100644
index b124e12c..00000000
--- a/common/recipes-kernel/wdt-load/amd-wdt-load_1.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "Configuration file to pass module load parameters to AMD Watchdog driver"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
-SRC_URI = "file://modprobe.d/amd-wdt.conf"
-
-PR = "r0"
-PV = "1.0"
-
-S = "${WORKDIR}"
-
-do_install() {
- install -d ${D}/${sysconfdir}/modprobe.d/
- install -m 0644 modprobe.d/amd-wdt.conf ${D}${sysconfdir}/modprobe.d/
-}
-
-FILES_${PN} = "${sysconfdir}/modprobe.d"
-
diff --git a/common/recipes-kernel/wdt-load/files/modprobe.d/amd-wdt.conf b/common/recipes-kernel/wdt-load/files/modprobe.d/amd-wdt.conf
deleted file mode 100644
index e69de29b..00000000
--- a/common/recipes-kernel/wdt-load/files/modprobe.d/amd-wdt.conf
+++ /dev/null