aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-yocto-4.14.71/1229-drm-amd-dkms-add-amdkfd-module.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/linux/linux-yocto-4.14.71/1229-drm-amd-dkms-add-amdkfd-module.patch')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-4.14.71/1229-drm-amd-dkms-add-amdkfd-module.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-4.14.71/1229-drm-amd-dkms-add-amdkfd-module.patch b/common/recipes-kernel/linux/linux-yocto-4.14.71/1229-drm-amd-dkms-add-amdkfd-module.patch
new file mode 100644
index 00000000..3e342033
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto-4.14.71/1229-drm-amd-dkms-add-amdkfd-module.patch
@@ -0,0 +1,58 @@
+From a5b57049ea452eb0d6490872e770d6a876c836f0 Mon Sep 17 00:00:00 2001
+From: Qiang Yu <Qiang.Yu@amd.com>
+Date: Mon, 12 Dec 2016 14:48:56 +0800
+Subject: [PATCH 1229/4131] drm/amd/dkms: add amdkfd module
+
+Change-Id: I49bfb2aa76766f9ede31062a226015a5993deb02
+Signed-off-by: Qiang Yu <Qiang.Yu@amd.com>
+Reviewed-by: Junwei Zhang <Jerry.Zhang@amd.com>
+Reviewed-by: Ken Wang <Qingqing.Wang@amd.com>
+
+Conflicts:
+ drivers/gpu/drm/amd/dkms/dkms.conf
+---
+ drivers/gpu/drm/amd/amdkfd/Makefile | 3 +++
+ drivers/gpu/drm/amd/amdkfd/backport/Makefile | 6 ++++++
+ drivers/gpu/drm/amd/amdkfd/backport/backport.h | 6 ++++++
+ 3 files changed, 15 insertions(+)
+ create mode 100644 drivers/gpu/drm/amd/amdkfd/backport/Makefile
+ create mode 100644 drivers/gpu/drm/amd/amdkfd/backport/backport.h
+
+diff --git a/drivers/gpu/drm/amd/amdkfd/Makefile b/drivers/gpu/drm/amd/amdkfd/Makefile
+index 3be1acd..923e3ae 100644
+--- a/drivers/gpu/drm/amd/amdkfd/Makefile
++++ b/drivers/gpu/drm/amd/amdkfd/Makefile
+@@ -23,3 +23,6 @@ amdkfd-y := kfd_module.o kfd_device.o kfd_chardev.o kfd_topology.o \
+ amdkfd-$(CONFIG_DEBUG_FS) += kfd_debugfs.o
+
+ obj-$(CONFIG_HSA_AMD) += amdkfd.o
++
++AMDKFD_FULL_PATH = $(src)
++include $(AMDKFD_FULL_PATH)/backport/Makefile
+diff --git a/drivers/gpu/drm/amd/amdkfd/backport/Makefile b/drivers/gpu/drm/amd/amdkfd/backport/Makefile
+new file mode 100644
+index 0000000..3fc650a
+--- /dev/null
++++ b/drivers/gpu/drm/amd/amdkfd/backport/Makefile
+@@ -0,0 +1,6 @@
++
++
++LINUXINCLUDE := $(DKMS_INCLUDE_PREFIX) $(LINUXINCLUDE)
++
++ccflags-y += \
++ -include $(AMDKFD_FULL_PATH)/backport/backport.h
+diff --git a/drivers/gpu/drm/amd/amdkfd/backport/backport.h b/drivers/gpu/drm/amd/amdkfd/backport/backport.h
+new file mode 100644
+index 0000000..e1f8c1d
+--- /dev/null
++++ b/drivers/gpu/drm/amd/amdkfd/backport/backport.h
+@@ -0,0 +1,6 @@
++#ifndef AMDKFD_BACKPORT_H
++#define AMDKFD_BACKPORT_H
++
++#include <linux/version.h>
++
++#endif
+--
+2.7.4
+