aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-yocto-4.14.71/0001-drm-ttm-Add-DMA-map-unmap-tracepoint-v3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/linux/linux-yocto-4.14.71/0001-drm-ttm-Add-DMA-map-unmap-tracepoint-v3.patch')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-4.14.71/0001-drm-ttm-Add-DMA-map-unmap-tracepoint-v3.patch274
1 files changed, 0 insertions, 274 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-4.14.71/0001-drm-ttm-Add-DMA-map-unmap-tracepoint-v3.patch b/common/recipes-kernel/linux/linux-yocto-4.14.71/0001-drm-ttm-Add-DMA-map-unmap-tracepoint-v3.patch
deleted file mode 100644
index 589587f3..00000000
--- a/common/recipes-kernel/linux/linux-yocto-4.14.71/0001-drm-ttm-Add-DMA-map-unmap-tracepoint-v3.patch
+++ /dev/null
@@ -1,274 +0,0 @@
-From c53eb9d17b07332eb5d0325aaf6854e547bfad18 Mon Sep 17 00:00:00 2001
-From: Tom St Denis <tom.stdenis@amd.com>
-Date: Wed, 23 Aug 2017 15:17:47 -0400
-Subject: [PATCH 0001/4131] drm/ttm: Add DMA map/unmap tracepoint (v3)
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Also exports two functions that vendor drivers can call
-to trace DMA mappings. This is meant to help translate
-IOMMU mappings of bus addresses back to physical pages.
-
-Used by the umr amdgpu debugger for instance.
-
-Signed-off-by: Tom St Denis <tom.stdenis@amd.com>
-Reviewed-by: Christian König <christian.koenig@amd.com>
-Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
-
-(v2): Use dev_name() to get PCI path instead.
-(v3): Use correct types for dma/phys addresses
----
- drivers/gpu/drm/ttm/Makefile | 3 +-
- drivers/gpu/drm/ttm/ttm_debug.c | 74 +++++++++++++++++++++++++++++
- drivers/gpu/drm/ttm/ttm_trace.h | 87 +++++++++++++++++++++++++++++++++++
- drivers/gpu/drm/ttm/ttm_tracepoints.c | 45 ++++++++++++++++++
- 4 files changed, 208 insertions(+), 1 deletion(-)
- create mode 100644 drivers/gpu/drm/ttm/ttm_debug.c
- create mode 100644 drivers/gpu/drm/ttm/ttm_trace.h
- create mode 100644 drivers/gpu/drm/ttm/ttm_tracepoints.c
-
-diff --git a/drivers/gpu/drm/ttm/Makefile b/drivers/gpu/drm/ttm/Makefile
-index a60e560..7c57dac 100644
---- a/drivers/gpu/drm/ttm/Makefile
-+++ b/drivers/gpu/drm/ttm/Makefile
-@@ -2,10 +2,11 @@
- #
- # Makefile for the drm device driver. This driver provides support for the
-
-+ccflags-y := -I$(src)/.
- ttm-y := ttm_memory.o ttm_tt.o ttm_bo.o \
- ttm_bo_util.o ttm_bo_vm.o ttm_module.o \
- ttm_object.o ttm_lock.o ttm_execbuf_util.o ttm_page_alloc.o \
-- ttm_bo_manager.o ttm_page_alloc_dma.o
-+ ttm_bo_manager.o ttm_page_alloc_dma.o ttm_debug.o ttm_tracepoints.o
- ttm-$(CONFIG_AGP) += ttm_agp_backend.o
-
- obj-$(CONFIG_DRM_TTM) += ttm.o
-diff --git a/drivers/gpu/drm/ttm/ttm_debug.c b/drivers/gpu/drm/ttm/ttm_debug.c
-new file mode 100644
-index 0000000..ef5f0d0
---- /dev/null
-+++ b/drivers/gpu/drm/ttm/ttm_debug.c
-@@ -0,0 +1,74 @@
-+/**************************************************************************
-+ *
-+ * Copyright (c) 2017 Advanced Micro Devices, Inc.
-+ * All Rights Reserved.
-+ *
-+ * Permission is hereby granted, free of charge, to any person obtaining a
-+ * copy of this software and associated documentation files (the
-+ * "Software"), to deal in the Software without restriction, including
-+ * without limitation the rights to use, copy, modify, merge, publish,
-+ * distribute, sub license, and/or sell copies of the Software, and to
-+ * permit persons to whom the Software is furnished to do so, subject to
-+ * the following conditions:
-+ *
-+ * The above copyright notice and this permission notice (including the
-+ * next paragraph) shall be included in all copies or substantial portions
-+ * of the Software.
-+ *
-+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+ * FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
-+ * THE COPYRIGHT HOLDERS, AUTHORS AND/OR ITS SUPPLIERS BE LIABLE FOR ANY CLAIM,
-+ * DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
-+ * OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE
-+ * USE OR OTHER DEALINGS IN THE SOFTWARE.
-+ *
-+ **************************************************************************/
-+/*
-+ * Authors: Tom St Denis <tom.stdenis@amd.com>
-+ */
-+#include <linux/sched.h>
-+#include <linux/highmem.h>
-+#include <linux/pagemap.h>
-+#include <linux/shmem_fs.h>
-+#include <linux/file.h>
-+#include <linux/swap.h>
-+#include <linux/slab.h>
-+#include <linux/export.h>
-+#include <drm/drm_cache.h>
-+#include <drm/ttm/ttm_module.h>
-+#include <drm/ttm/ttm_bo_driver.h>
-+#include <drm/ttm/ttm_placement.h>
-+#include <drm/ttm/ttm_page_alloc.h>
-+#include "ttm_trace.h"
-+
-+void ttm_trace_dma_map(struct device *dev, struct ttm_dma_tt *tt)
-+{
-+ unsigned i;
-+
-+ if (unlikely(trace_ttm_dma_map_enabled())) {
-+ for (i = 0; i < tt->ttm.num_pages; i++) {
-+ trace_ttm_dma_map(
-+ dev,
-+ tt->ttm.pages[i],
-+ tt->dma_address[i]);
-+ }
-+ }
-+}
-+EXPORT_SYMBOL(ttm_trace_dma_map);
-+
-+void ttm_trace_dma_unmap(struct device *dev, struct ttm_dma_tt *tt)
-+{
-+ unsigned i;
-+
-+ if (unlikely(trace_ttm_dma_unmap_enabled())) {
-+ for (i = 0; i < tt->ttm.num_pages; i++) {
-+ trace_ttm_dma_unmap(
-+ dev,
-+ tt->ttm.pages[i],
-+ tt->dma_address[i]);
-+ }
-+ }
-+}
-+EXPORT_SYMBOL(ttm_trace_dma_unmap);
-+
-diff --git a/drivers/gpu/drm/ttm/ttm_trace.h b/drivers/gpu/drm/ttm/ttm_trace.h
-new file mode 100644
-index 0000000..23279b9
---- /dev/null
-+++ b/drivers/gpu/drm/ttm/ttm_trace.h
-@@ -0,0 +1,87 @@
-+/**************************************************************************
-+ *
-+ * Copyright (c) 2017 Advanced Micro Devices, Inc.
-+ * All Rights Reserved.
-+ *
-+ * Permission is hereby granted, free of charge, to any person obtaining a
-+ * copy of this software and associated documentation files (the
-+ * "Software"), to deal in the Software without restriction, including
-+ * without limitation the rights to use, copy, modify, merge, publish,
-+ * distribute, sub license, and/or sell copies of the Software, and to
-+ * permit persons to whom the Software is furnished to do so, subject to
-+ * the following conditions:
-+ *
-+ * The above copyright notice and this permission notice (including the
-+ * next paragraph) shall be included in all copies or substantial portions
-+ * of the Software.
-+ *
-+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+ * FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
-+ * THE COPYRIGHT HOLDERS, AUTHORS AND/OR ITS SUPPLIERS BE LIABLE FOR ANY CLAIM,
-+ * DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
-+ * OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE
-+ * USE OR OTHER DEALINGS IN THE SOFTWARE.
-+ *
-+ **************************************************************************/
-+/*
-+ * Authors: Tom St Denis <tom.stdenis@amd.com>
-+ */
-+#if !defined(_TTM_TRACE_H) || defined(TRACE_HEADER_MULTI_READ)
-+#define _TTM_TRACE_H_
-+
-+#include <linux/stringify.h>
-+#include <linux/types.h>
-+#include <linux/tracepoint.h>
-+
-+#include <drm/drmP.h>
-+
-+#undef TRACE_SYSTEM
-+#define TRACE_SYSTEM ttm
-+#define TRACE_INCLUDE_FILE ttm_trace
-+
-+TRACE_EVENT(ttm_dma_map,
-+ TP_PROTO(struct device *dev, struct page *page, dma_addr_t dma_address),
-+ TP_ARGS(dev, page, dma_address),
-+ TP_STRUCT__entry(
-+ __string(device, dev_name(dev))
-+ __field(dma_addr_t, dma)
-+ __field(phys_addr_t, phys)
-+ ),
-+ TP_fast_assign(
-+ __assign_str(device, dev_name(dev));
-+ __entry->dma = dma_address;
-+ __entry->phys = page_to_phys(page);
-+ ),
-+ TP_printk("%s: %pad => %pa",
-+ __get_str(device),
-+ &__entry->dma,
-+ &__entry->phys)
-+);
-+
-+TRACE_EVENT(ttm_dma_unmap,
-+ TP_PROTO(struct device *dev, struct page *page, dma_addr_t dma_address),
-+ TP_ARGS(dev, page, dma_address),
-+ TP_STRUCT__entry(
-+ __string(device, dev_name(dev))
-+ __field(dma_addr_t, dma)
-+ __field(phys_addr_t, phys)
-+ ),
-+ TP_fast_assign(
-+ __assign_str(device, dev_name(dev));
-+ __entry->dma = dma_address;
-+ __entry->phys = page_to_phys(page);
-+ ),
-+ TP_printk("%s: %pad => %pa",
-+ __get_str(device),
-+ &__entry->dma,
-+ &__entry->phys)
-+);
-+
-+#endif
-+
-+/* This part must be outside protection */
-+#undef TRACE_INCLUDE_PATH
-+#define TRACE_INCLUDE_PATH .
-+#include <trace/define_trace.h>
-+
-diff --git a/drivers/gpu/drm/ttm/ttm_tracepoints.c b/drivers/gpu/drm/ttm/ttm_tracepoints.c
-new file mode 100644
-index 0000000..861a626
---- /dev/null
-+++ b/drivers/gpu/drm/ttm/ttm_tracepoints.c
-@@ -0,0 +1,45 @@
-+/**************************************************************************
-+ *
-+ * Copyright (c) 2017 Advanced Micro Devices, Inc.
-+ * All Rights Reserved.
-+ *
-+ * Permission is hereby granted, free of charge, to any person obtaining a
-+ * copy of this software and associated documentation files (the
-+ * "Software"), to deal in the Software without restriction, including
-+ * without limitation the rights to use, copy, modify, merge, publish,
-+ * distribute, sub license, and/or sell copies of the Software, and to
-+ * permit persons to whom the Software is furnished to do so, subject to
-+ * the following conditions:
-+ *
-+ * The above copyright notice and this permission notice (including the
-+ * next paragraph) shall be included in all copies or substantial portions
-+ * of the Software.
-+ *
-+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+ * FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
-+ * THE COPYRIGHT HOLDERS, AUTHORS AND/OR ITS SUPPLIERS BE LIABLE FOR ANY CLAIM,
-+ * DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
-+ * OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE
-+ * USE OR OTHER DEALINGS IN THE SOFTWARE.
-+ *
-+ **************************************************************************/
-+/*
-+ * Authors: Tom St Denis <tom.stdenis@amd.com>
-+ */
-+#include <linux/sched.h>
-+#include <linux/highmem.h>
-+#include <linux/pagemap.h>
-+#include <linux/shmem_fs.h>
-+#include <linux/file.h>
-+#include <linux/swap.h>
-+#include <linux/slab.h>
-+#include <linux/export.h>
-+#include <drm/drm_cache.h>
-+#include <drm/ttm/ttm_module.h>
-+#include <drm/ttm/ttm_bo_driver.h>
-+#include <drm/ttm/ttm_placement.h>
-+#include <drm/ttm/ttm_page_alloc.h>
-+
-+#define CREATE_TRACE_POINTS
-+#include "ttm_trace.h"
---
-2.7.4
-