aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/files/0731-drm-amd-dal-Add-DCE10-HW-Sequencer.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/linux/files/0731-drm-amd-dal-Add-DCE10-HW-Sequencer.patch')
-rw-r--r--common/recipes-kernel/linux/files/0731-drm-amd-dal-Add-DCE10-HW-Sequencer.patch143
1 files changed, 143 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/files/0731-drm-amd-dal-Add-DCE10-HW-Sequencer.patch b/common/recipes-kernel/linux/files/0731-drm-amd-dal-Add-DCE10-HW-Sequencer.patch
new file mode 100644
index 00000000..d2f15351
--- /dev/null
+++ b/common/recipes-kernel/linux/files/0731-drm-amd-dal-Add-DCE10-HW-Sequencer.patch
@@ -0,0 +1,143 @@
+From 53b0f6f238dbacdf3e08344009d1d7622c5b5fb0 Mon Sep 17 00:00:00 2001
+From: Andrey Grodzovsky <Andrey.Grodzovsky@amd.com>
+Date: Mon, 25 Jan 2016 14:03:52 -0500
+Subject: [PATCH 0731/1110] drm/amd/dal: Add DCE10 HW Sequencer.
+
+Signed-off-by: Andrey Grodzovsky <Andrey.Grodzovsky@amd.com>
+Acked-by: Harry Wentland <harry.wentland@amd.com>
+---
+ drivers/gpu/drm/amd/dal/dc/core/dc_hw_sequencer.c | 5 ++-
+ drivers/gpu/drm/amd/dal/dc/dce100/Makefile | 2 +-
+ .../drm/amd/dal/dc/dce100/dce100_hw_sequencer.c | 40 ++++++++++++++++++++++
+ .../drm/amd/dal/dc/dce100/dce100_hw_sequencer.h | 36 +++++++++++++++++++
+ 4 files changed, 81 insertions(+), 2 deletions(-)
+ create mode 100644 drivers/gpu/drm/amd/dal/dc/dce100/dce100_hw_sequencer.c
+ create mode 100644 drivers/gpu/drm/amd/dal/dc/dce100/dce100_hw_sequencer.h
+
+diff --git a/drivers/gpu/drm/amd/dal/dc/core/dc_hw_sequencer.c b/drivers/gpu/drm/amd/dal/dc/core/dc_hw_sequencer.c
+index 2cac267..df7e89f 100644
+--- a/drivers/gpu/drm/amd/dal/dc/core/dc_hw_sequencer.c
++++ b/drivers/gpu/drm/amd/dal/dc/core/dc_hw_sequencer.c
+@@ -25,6 +25,9 @@
+ #include "dc_services.h"
+ #include "core_types.h"
+
++#if defined(CONFIG_DRM_AMD_DAL_DCE10_0)
++#include "dce100/dce100_hw_sequencer.h"
++#endif
+ #if defined(CONFIG_DRM_AMD_DAL_DCE11_0)
+ #include "dce110/dce110_hw_sequencer.h"
+ #endif
+@@ -39,7 +42,7 @@ bool dc_construct_hw_sequencer(
+ {
+ #if defined(CONFIG_DRM_AMD_DAL_DCE10_0)
+ case DCE_VERSION_10_0:
+- return dce110_hw_sequencer_construct(dc);
++ return dce100_hw_sequencer_construct(dc);
+ #endif
+ #if defined(CONFIG_DRM_AMD_DAL_DCE11_0)
+ case DCE_VERSION_11_0:
+diff --git a/drivers/gpu/drm/amd/dal/dc/dce100/Makefile b/drivers/gpu/drm/amd/dal/dc/dce100/Makefile
+index 4c0b4d5..656c38e 100644
+--- a/drivers/gpu/drm/amd/dal/dc/dce100/Makefile
++++ b/drivers/gpu/drm/amd/dal/dc/dce100/Makefile
+@@ -2,7 +2,7 @@
+ # Makefile for the 'controller' sub-component of DAL.
+ # It provides the control and status of HW CRTC block.
+
+-DCE100 = dce100_resource.o
++DCE100 = dce100_resource.o dce100_hw_sequencer.o
+
+ AMD_DAL_DCE100 = $(addprefix $(AMDDALPATH)/dc/dce100/,$(DCE100))
+
+diff --git a/drivers/gpu/drm/amd/dal/dc/dce100/dce100_hw_sequencer.c b/drivers/gpu/drm/amd/dal/dc/dce100/dce100_hw_sequencer.c
+new file mode 100644
+index 0000000..a235bb0
+--- /dev/null
++++ b/drivers/gpu/drm/amd/dal/dc/dce100/dce100_hw_sequencer.c
+@@ -0,0 +1,40 @@
++/*
++ * Copyright 2015 Advanced Micro Devices, Inc.
++ *
++ * Permission is hereby granted, free of charge, to any person obtaining a
++ * copy of this software and associated documentation files (the "Software"),
++ * to deal in the Software without restriction, including without limitation
++ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
++ * and/or sell copies of the Software, and to permit persons to whom the
++ * Software is furnished to do so, subject to the following conditions:
++ *
++ * The above copyright notice and this permission notice shall be included in
++ * all copies or substantial portions of the Software.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
++ * THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
++ * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
++ * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ * OTHER DEALINGS IN THE SOFTWARE.
++ *
++ * Authors: AMD
++ *
++ */
++
++#include "dce110/dce110_hw_sequencer.h"
++
++#include "resource.h"
++#include "hw_sequencer.h"
++#include "dce100_resource.h"
++
++bool dce100_hw_sequencer_construct(struct dc *dc)
++{
++ dce110_hw_sequencer_construct(dc);
++ dc->hwss.construct_resource_pool = dce100_construct_resource_pool;
++ dc->hwss.destruct_resource_pool = dce100_destruct_resource_pool;
++
++ return true;
++}
++
+diff --git a/drivers/gpu/drm/amd/dal/dc/dce100/dce100_hw_sequencer.h b/drivers/gpu/drm/amd/dal/dc/dce100/dce100_hw_sequencer.h
+new file mode 100644
+index 0000000..d52bfda
+--- /dev/null
++++ b/drivers/gpu/drm/amd/dal/dc/dce100/dce100_hw_sequencer.h
+@@ -0,0 +1,36 @@
++/*
++* Copyright 2012-15 Advanced Micro Devices, Inc.
++ *
++ * Permission is hereby granted, free of charge, to any person obtaining a
++ * copy of this software and associated documentation files (the "Software"),
++ * to deal in the Software without restriction, including without limitation
++ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
++ * and/or sell copies of the Software, and to permit persons to whom the
++ * Software is furnished to do so, subject to the following conditions:
++ *
++ * The above copyright notice and this permission notice shall be included in
++ * all copies or substantial portions of the Software.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
++ * THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
++ * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
++ * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ * OTHER DEALINGS IN THE SOFTWARE.
++ *
++ * Authors: AMD
++ *
++ */
++
++#ifndef __DC_HWSS_DCE100_H__
++#define __DC_HWSS_DCE100_H__
++
++#include "core_types.h"
++
++struct dc;
++
++bool dce100_hw_sequencer_construct(struct dc *dc);
++
++#endif /* __DC_HWSS_DCE110_H__ */
++
+--
+2.7.4
+