aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/files/0554-drm-amd-dal-Treat-warnings-as-errors.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/linux/files/0554-drm-amd-dal-Treat-warnings-as-errors.patch')
-rw-r--r--common/recipes-kernel/linux/files/0554-drm-amd-dal-Treat-warnings-as-errors.patch58
1 files changed, 0 insertions, 58 deletions
diff --git a/common/recipes-kernel/linux/files/0554-drm-amd-dal-Treat-warnings-as-errors.patch b/common/recipes-kernel/linux/files/0554-drm-amd-dal-Treat-warnings-as-errors.patch
deleted file mode 100644
index af776d2b..00000000
--- a/common/recipes-kernel/linux/files/0554-drm-amd-dal-Treat-warnings-as-errors.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From cb5336555b89e440bad0c786ef666d9006e6dd97 Mon Sep 17 00:00:00 2001
-From: Jordan Lazare <Jordan.Lazare@amd.com>
-Date: Tue, 1 Dec 2015 14:08:19 -0500
-Subject: [PATCH 0554/1110] drm/amd/dal: Treat warnings as errors
-
-Also fix any existing warnings
-
-Signed-off-by: Jordan Lazare <Jordan.Lazare@amd.com>
-Signed-off-by: Harry Wentland <harry.wentland@amd.com>
-Acked-by: Harry Wentland <harry.wentland@amd.com>
----
- drivers/gpu/drm/amd/dal/Makefile | 2 ++
- drivers/gpu/drm/amd/dal/amdgpu_dm/amdgpu_dc_helpers.c | 2 +-
- drivers/gpu/drm/amd/dal/amdgpu_dm/amdgpu_dm_irq.c | 2 +-
- 3 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/drivers/gpu/drm/amd/dal/Makefile b/drivers/gpu/drm/amd/dal/Makefile
-index bdf5d18..d5db32e 100644
---- a/drivers/gpu/drm/amd/dal/Makefile
-+++ b/drivers/gpu/drm/amd/dal/Makefile
-@@ -5,6 +5,8 @@
-
- AMDDALPATH = $(RELATIVE_AMD_DAL_PATH)
-
-+subdir-ccflags-y += -Werror
-+
- subdir-ccflags-y += -I$(AMDDALPATH)/ -I$(AMDDALPATH)/include -DDAL_CZ_BRINGUP
-
- subdir-ccflags-y += -I$(FULL_AMD_DAL_PATH)/dc/inc/
-diff --git a/drivers/gpu/drm/amd/dal/amdgpu_dm/amdgpu_dc_helpers.c b/drivers/gpu/drm/amd/dal/amdgpu_dm/amdgpu_dc_helpers.c
-index 5b780e1..6b70a41 100644
---- a/drivers/gpu/drm/amd/dal/amdgpu_dm/amdgpu_dc_helpers.c
-+++ b/drivers/gpu/drm/amd/dal/amdgpu_dm/amdgpu_dc_helpers.c
-@@ -183,7 +183,7 @@ bool dc_helpers_dp_mst_write_payload_allocation_table(
- int bpp;
- int pbn = 0;
- uint8_t i;
-- uint8_t vcid;
-+ uint8_t vcid = 0;
- bool find_stream_for_sink;
-
- aconnector = get_connector_for_sink(dev, sink);
-diff --git a/drivers/gpu/drm/amd/dal/amdgpu_dm/amdgpu_dm_irq.c b/drivers/gpu/drm/amd/dal/amdgpu_dm/amdgpu_dm_irq.c
-index 9491fd0..05a0053 100644
---- a/drivers/gpu/drm/amd/dal/amdgpu_dm/amdgpu_dm_irq.c
-+++ b/drivers/gpu/drm/amd/dal/amdgpu_dm/amdgpu_dm_irq.c
-@@ -466,7 +466,7 @@ void amdgpu_dm_irq_register_timer(
- queue_delayed_work(adev->dm.timer_workqueue, &handler_data->d_work,
- jf_delay);
-
-- DRM_DEBUG_KMS("DM_IRQ: added handler:%p with micro_sec_interval=%llu\n",
-+ DRM_DEBUG_KMS("DM_IRQ: added handler:%p with micro_sec_interval=%u\n",
- handler_data, int_params->micro_sec_interval);
- return;
- }
---
-2.7.4
-