aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/files/0368-drm-amdgpu-handle-conditional-support-for-CIK-proper.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/linux/files/0368-drm-amdgpu-handle-conditional-support-for-CIK-proper.patch')
-rw-r--r--common/recipes-kernel/linux/files/0368-drm-amdgpu-handle-conditional-support-for-CIK-proper.patch56
1 files changed, 0 insertions, 56 deletions
diff --git a/common/recipes-kernel/linux/files/0368-drm-amdgpu-handle-conditional-support-for-CIK-proper.patch b/common/recipes-kernel/linux/files/0368-drm-amdgpu-handle-conditional-support-for-CIK-proper.patch
deleted file mode 100644
index 9045263b..00000000
--- a/common/recipes-kernel/linux/files/0368-drm-amdgpu-handle-conditional-support-for-CIK-proper.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 41548ef78bbf26994546ea5225ad4b4c1bf96d1f Mon Sep 17 00:00:00 2001
-From: Alex Deucher <alexander.deucher@amd.com>
-Date: Fri, 31 Jul 2015 17:20:14 -0400
-Subject: [PATCH 0368/1050] drm/amdgpu: handle conditional support for CIK
- properly
-
-gfx7 support is not necessary or available if CIK support
-is not enabled.
-
-Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
----
- drivers/gpu/drm/amd/amdgpu/Makefile | 4 ++--
- drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.c | 2 ++
- 2 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/drivers/gpu/drm/amd/amdgpu/Makefile b/drivers/gpu/drm/amd/amdgpu/Makefile
-index 733f775..4e1c07d 100644
---- a/drivers/gpu/drm/amd/amdgpu/Makefile
-+++ b/drivers/gpu/drm/amd/amdgpu/Makefile
-@@ -22,7 +22,8 @@ amdgpu-y += amdgpu_device.o amdgpu_kms.o \
-
- # add asic specific block
- amdgpu-$(CONFIG_DRM_AMDGPU_CIK)+= cik.o gmc_v7_0.o cik_ih.o kv_smc.o kv_dpm.o \
-- ci_smc.o ci_dpm.o dce_v8_0.o gfx_v7_0.o cik_sdma.o uvd_v4_2.o vce_v2_0.o
-+ ci_smc.o ci_dpm.o dce_v8_0.o gfx_v7_0.o cik_sdma.o uvd_v4_2.o vce_v2_0.o \
-+ amdgpu_amdkfd_gfx_v7.o
-
- amdgpu-y += \
- vi.o
-@@ -75,7 +76,6 @@ amdgpu-y += \
- # add amdkfd interfaces
- amdgpu-y += \
- amdgpu_amdkfd.o \
-- amdgpu_amdkfd_gfx_v7.o \
- amdgpu_amdkfd_gfx_v8.o
-
- # add cgs
-diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.c
-index 4c7c09c..496ed21 100644
---- a/drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.c
-+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.c
-@@ -50,9 +50,11 @@ bool amdgpu_amdkfd_load_interface(struct amdgpu_device *rdev)
- #endif
-
- switch (rdev->asic_type) {
-+#ifdef CONFIG_DRM_AMDGPU_CIK
- case CHIP_KAVERI:
- kfd2kgd = amdgpu_amdkfd_gfx_7_get_functions();
- break;
-+#endif
- case CHIP_CARRIZO:
- kfd2kgd = amdgpu_amdkfd_gfx_8_0_get_functions();
- break;
---
-1.9.1
-