aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/files/0010-amd-Setup-Excavator-specific-compile-options.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/linux/files/0010-amd-Setup-Excavator-specific-compile-options.patch')
-rw-r--r--common/recipes-kernel/linux/files/0010-amd-Setup-Excavator-specific-compile-options.patch98
1 files changed, 0 insertions, 98 deletions
diff --git a/common/recipes-kernel/linux/files/0010-amd-Setup-Excavator-specific-compile-options.patch b/common/recipes-kernel/linux/files/0010-amd-Setup-Excavator-specific-compile-options.patch
deleted file mode 100644
index 4195e820..00000000
--- a/common/recipes-kernel/linux/files/0010-amd-Setup-Excavator-specific-compile-options.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From bbfb4ffa4002ce62a1feec27fe51a6a6a0c8a205 Mon Sep 17 00:00:00 2001
-From: Drew Moseley <drew_moseley@mentor.com>
-Date: Fri, 15 Jan 2016 08:45:27 -0500
-Subject: [PATCH 10/10] amd: Setup Excavator specific compile options
-
-Signed-off-by: Drew Moseley <drew_moseley@mentor.com>
----
- arch/x86/Kconfig.cpu | 13 ++++++++++---
- arch/x86/Makefile | 1 +
- arch/x86/Makefile_32.cpu | 1 +
- arch/x86/include/asm/module.h | 2 ++
- 4 files changed, 14 insertions(+), 3 deletions(-)
-
-diff --git a/arch/x86/Kconfig.cpu b/arch/x86/Kconfig.cpu
-index 2a3bc950..9141885 100644
---- a/arch/x86/Kconfig.cpu
-+++ b/arch/x86/Kconfig.cpu
-@@ -175,6 +175,13 @@ config MSTEAMROLLER
-
- Enables -march=bdver3
-
-+config MEXCAVATOR
-+ bool "Excavator"
-+ ---help---
-+ Select this for AMD Excavator processors.
-+
-+ Enables -march=bdver4
-+
- config MCRUSOE
- bool "Crusoe"
- depends on X86_32
-@@ -314,7 +321,7 @@ config X86_INTERNODE_CACHE_SHIFT
- config X86_L1_CACHE_SHIFT
- int
- default "7" if MPENTIUM4 || MPSC
-- default "6" if MK7 || MK8 || MJAGUAR || MSTEAMROLLER || MPENTIUMM || MCORE2 || MATOM || MVIAC7 || X86_GENERIC || GENERIC_CPU
-+ default "6" if MK7 || MK8 || MJAGUAR || MSTEAMROLLER || MEXCAVATOR || MPENTIUMM || MCORE2 || MATOM || MVIAC7 || X86_GENERIC || GENERIC_CPU
- default "4" if MELAN || M486 || MGEODEGX1
- default "5" if MWINCHIP3D || MWINCHIPC6 || MCRUSOE || MEFFICEON || MCYRIXIII || MK6 || MPENTIUMIII || MPENTIUMII || M686 || M586MMX || M586TSC || M586 || MVIAC3_2 || MGEODE_LX
-
-@@ -373,7 +380,7 @@ config X86_P6_NOP
-
- config X86_TSC
- def_bool y
-- depends on (MWINCHIP3D || MCRUSOE || MEFFICEON || MCYRIXIII || MK7 || MK6 || MPENTIUM4 || MPENTIUMM || MPENTIUMIII || MPENTIUMII || M686 || M586MMX || M586TSC || MK8 || MJAGUAR || MSTEAMROLLER || MVIAC3_2 || MVIAC7 || MGEODEGX1 || MGEODE_LX || MCORE2 || MATOM) || X86_64
-+ depends on (MWINCHIP3D || MCRUSOE || MEFFICEON || MCYRIXIII || MK7 || MK6 || MPENTIUM4 || MPENTIUMM || MPENTIUMIII || MPENTIUMII || M686 || M586MMX || M586TSC || MK8 || MJAGUAR || MSTEAMROLLER || MEXCAVATOR || MVIAC3_2 || MVIAC7 || MGEODEGX1 || MGEODE_LX || MCORE2 || MATOM) || X86_64
-
- config X86_CMPXCHG64
- def_bool y
-@@ -383,7 +390,7 @@ config X86_CMPXCHG64
- # generates cmov.
- config X86_CMOV
- def_bool y
-- depends on (MK8 || MJAGUAR || MSTEAMROLLER || MK7 || MCORE2 || MPENTIUM4 || MPENTIUMM || MPENTIUMIII || MPENTIUMII || M686 || MVIAC3_2 || MVIAC7 || MCRUSOE || MEFFICEON || X86_64 || MATOM || MGEODE_LX)
-+ depends on (MK8 || MJAGUAR || MSTEAMROLLER || MEXCAVATOR || MK7 || MCORE2 || MPENTIUM4 || MPENTIUMM || MPENTIUMIII || MPENTIUMII || M686 || MVIAC3_2 || MVIAC7 || MCRUSOE || MEFFICEON || X86_64 || MATOM || MGEODE_LX)
-
- config X86_MINIMUM_CPU_FAMILY
- int
-diff --git a/arch/x86/Makefile b/arch/x86/Makefile
-index 0e6afa4..3b8ab9c 100644
---- a/arch/x86/Makefile
-+++ b/arch/x86/Makefile
-@@ -88,6 +88,7 @@ else
- cflags-$(CONFIG_MK8) += $(call cc-option,-march=k8)
- cflags-$(CONFIG_MJAGUAR) += $(call cc-option,-march=btver2)
- cflags-$(CONFIG_MSTEAMROLLER) += $(call cc-option,-march=bdver3)
-+ cflags-$(CONFIG_MEXCAVATOR) += $(call cc-option,-march=bdver4)
- cflags-$(CONFIG_MPSC) += $(call cc-option,-march=nocona)
-
- cflags-$(CONFIG_MCORE2) += \
-diff --git a/arch/x86/Makefile_32.cpu b/arch/x86/Makefile_32.cpu
-index 4d3a04d..dd6c514 100644
---- a/arch/x86/Makefile_32.cpu
-+++ b/arch/x86/Makefile_32.cpu
-@@ -26,6 +26,7 @@ cflags-$(CONFIG_MK7) += -march=athlon
- cflags-$(CONFIG_MK8) += $(call cc-option,-march=k8,-march=athlon)
- cflags-$(CONFIG_MJAGUAR) += $(call cc-option,-march=btver2,-march=athlon)
- cflags-$(CONFIG_MSTEAMROLLER) += $(call cc-option,-march=bdver3,-march=athlon)
-+cflags-$(CONFIG_MEXCAVATOR) += $(call cc-option,-march=bdver4,-march=athlon)
- cflags-$(CONFIG_MCRUSOE) += -march=i686 $(align)-functions=0 $(align)-jumps=0 $(align)-loops=0
- cflags-$(CONFIG_MEFFICEON) += -march=i686 $(call tune,pentium3) $(align)-functions=0 $(align)-jumps=0 $(align)-loops=0
- cflags-$(CONFIG_MWINCHIPC6) += $(call cc-option,-march=winchip-c6,-march=i586)
-diff --git a/arch/x86/include/asm/module.h b/arch/x86/include/asm/module.h
-index 3f2f520..3eca5a9 100644
---- a/arch/x86/include/asm/module.h
-+++ b/arch/x86/include/asm/module.h
-@@ -37,6 +37,8 @@
- #define MODULE_PROC_FAMILY "JAGUAR "
- #elif defined CONFIG_MSTEAMROLLER
- #define MODULE_PROC_FAMILY "STEAMROLLER "
-+#elif defined CONFIG_MEXCAVATOR
-+#define MODULE_PROC_FAMILY "EXCAVATOR "
- #elif defined CONFIG_MELAN
- #define MODULE_PROC_FAMILY "ELAN "
- #elif defined CONFIG_MCRUSOE
---
-2.7.0
-