aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch')
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch37
1 files changed, 0 insertions, 37 deletions
diff --git a/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch b/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
deleted file mode 100644
index a6599648..00000000
--- a/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 223ffdb659ceb8628e38003495b5c6550833b673 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Thu, 26 Jul 2018 17:13:32 +0500
-Subject: [PATCH] configure.ac: adjust usage of LLVM flags
-
-The llvm-config is provided through a native build
-so using flags from there creates conflicts between
-mesa and llvm on the target.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- configure.ac | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index d1c8bb82da..290cc5f9f8 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1064,6 +1064,7 @@ strip_unwanted_llvm_flags() {
- -e 's/[[[:space:]]]+-pedantic[[[:space:]]]/ /g' \
- -e 's/[[[:space:]]]+-W[[^[:space:]]]*//g' \
- -e 's/[[[:space:]]]+-O[[^[:space:]]]*//g' \
-+ -e 's/[[[:space:]]]+-D_GLIBCXX_USE_CXX11_ABI[[^[:space:]]]*//g' \
- -e 's/[[[:space:]]]+-g[[^[:space:]]]*//g' \
- -e 's/-fno-rtti[[[:space:]]]/-Fno-rtti /g' \
- -e 's/[[[:space:]]]+-f[[^[:space:]]]*//g' \
-@@ -2808,7 +2809,7 @@ dnl
- if test "x$enable_llvm" = xyes; then
- DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DMESA_LLVM_VERSION_PATCH=$LLVM_VERSION_PATCH"
-
-- LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
-+ LLVM_LDFLAGS=
- LLVM_CFLAGS=$LLVM_CPPFLAGS # CPPFLAGS seem to be sufficient
- LLVM_CXXFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cxxflags"`
-
---
-2.11.1