aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-graphics/libva/libva-gl
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-graphics/libva/libva-gl')
-rw-r--r--common/recipes-graphics/libva/libva-gl/0001-disable-tests.patch29
-rw-r--r--common/recipes-graphics/libva/libva-gl/0002-allow-building-gl-backends-only.patch126
-rw-r--r--common/recipes-graphics/libva/libva-gl/0003-allow-building-glx-backend-without-x11-enabled.patch29
3 files changed, 0 insertions, 184 deletions
diff --git a/common/recipes-graphics/libva/libva-gl/0001-disable-tests.patch b/common/recipes-graphics/libva/libva-gl/0001-disable-tests.patch
deleted file mode 100644
index e6115f87..00000000
--- a/common/recipes-graphics/libva/libva-gl/0001-disable-tests.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 1c0c029576e6eed69be2f96b5bbcf13636ea3a84 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Tue, 29 Mar 2016 14:17:27 +0500
-Subject: [PATCH 1/2] disable tests
-
-The tests subdirectory requires libva base package to
-build which is disabled here.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index beac7e9..be1ce9e 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -24,7 +24,7 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-
- AUTOMAKE_OPTIONS = foreign
-
--SUBDIRS = va dummy_drv_video pkgconfig test debian.upstream doc
-+SUBDIRS = va dummy_drv_video pkgconfig debian.upstream doc
-
- # Extra clean files so that maintainer-clean removes *everything*
- MAINTAINERCLEANFILES = \
---
-1.9.1
-
diff --git a/common/recipes-graphics/libva/libva-gl/0002-allow-building-gl-backends-only.patch b/common/recipes-graphics/libva/libva-gl/0002-allow-building-gl-backends-only.patch
deleted file mode 100644
index 055ef79c..00000000
--- a/common/recipes-graphics/libva/libva-gl/0002-allow-building-gl-backends-only.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-From 6f93d2a8e5a1d8339a41d4d8db2299379a59cc26 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Thu, 18 Jan 2018 15:58:08 +0500
-Subject: [PATCH] allow building gl backends only
-
-For this specific package we'd like to only
-build/deploy the gl (EGL, GLX) backends as
-this package will mainly take care of the circular
-dependencies between mesa and libva.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- configure.ac | 4 ++--
- pkgconfig/Makefile.am | 3 +--
- va/Makefile.am | 42 ++++++------------------------------------
- 3 files changed, 9 insertions(+), 40 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 64eddf2..450cf10 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -289,8 +289,8 @@ pkgconfigdir=${libdir}/pkgconfig
- AC_SUBST(pkgconfigdir)
-
- # Check for builds without backend
--if test "$USE_DRM:$USE_X11:$USE_WAYLAND" = "no:no:no"; then
-- AC_MSG_ERROR([Please select at least one backend (DRM, X11, Wayland)])
-+if test "$USE_DRM:$USE_X11:$USE_WAYLAND:$USE_EGL:$USE_GLX" = "no:no:no:no:no"; then
-+ AC_MSG_ERROR([Please select at least one backend (DRM, X11, Wayland, EGL, GLX)])
- fi
-
- # Define __vaDriverInit*() function name for dummy backend
-diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
-index a3435a4..4ce8aa1 100644
---- a/pkgconfig/Makefile.am
-+++ b/pkgconfig/Makefile.am
-@@ -20,8 +20,7 @@
- # TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
- # SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-
--pcfiles = libva.pc
--pcfiles += libva-tpi.pc
-+pcfiles =
- if USE_DRM
- pcfiles += libva-drm.pc
- endif
-diff --git a/va/Makefile.am b/va/Makefile.am
-index 1be4214..1a35c22 100644
---- a/va/Makefile.am
-+++ b/va/Makefile.am
-@@ -36,27 +36,7 @@ libva_source_c = \
- va_trace.c \
- $(NULL)
-
--libva_source_h = \
-- va.h \
-- va_backend.h \
-- va_backend_tpi.h \
-- va_backend_vpp.h \
-- va_compat.h \
-- va_dec_hevc.h \
-- va_dec_jpeg.h \
-- va_dec_vp8.h \
-- va_dec_vp9.h \
-- va_drmcommon.h \
-- va_enc_hevc.h \
-- va_enc_h264.h \
-- va_enc_jpeg.h \
-- va_enc_vp8.h \
-- va_enc_mpeg2.h \
-- va_enc_vp9.h \
-- va_tpi.h \
-- va_version.h \
-- va_vpp.h \
-- $(NULL)
-+libva_source_h =
-
- libva_source_h_priv = \
- sysdeps.h \
-@@ -69,20 +49,10 @@ libva_ldflags = \
- -Wl,-version-script,${srcdir}/libva.syms \
- $(NULL)
-
--lib_LTLIBRARIES = libva.la
-+lib_LTLIBRARIES =
- libvaincludedir = ${includedir}/va
- libvainclude_HEADERS = $(libva_source_h)
- noinst_HEADERS = $(libva_source_h_priv)
--libva_la_SOURCES = $(libva_source_c)
--libva_la_LDFLAGS = $(libva_ldflags)
--libva_la_DEPENDENCIES = libva.syms
--libva_la_LIBADD = $(LIBVA_LIBS) -ldl
--
--lib_LTLIBRARIES += libva-tpi.la
--libva_tpi_la_SOURCES = va_tpi.c
--libva_tpi_la_LDFLAGS = $(LDADD) -no-undefined
--libva_tpi_la_DEPENDENCIES = libva.la
--libva_tpi_la_LIBADD = libva.la -ldl
-
- if USE_DRM
- SUBDIRS += drm
-@@ -110,8 +80,8 @@ SUBDIRS += glx
- lib_LTLIBRARIES += libva-glx.la
- libva_glx_la_SOURCES =
- libva_glx_la_LDFLAGS = $(LDADD)
--libva_glx_la_DEPENDENCIES = libva.la glx/libva_glx.la libva-x11.la
--libva_glx_la_LIBADD = libva.la glx/libva_glx.la libva-x11.la \
-+libva_glx_la_DEPENDENCIES = glx/libva_glx.la
-+libva_glx_la_LIBADD = glx/libva_glx.la \
- $(GLX_LIBS) -ldl
- endif
-
-@@ -120,8 +90,8 @@ SUBDIRS += egl
- lib_LTLIBRARIES += libva-egl.la
- libva_egl_la_SOURCES =
- libva_egl_la_LDFLAGS = $(LDADD)
--libva_egl_la_DEPENDENCIES = libva.la egl/libva_egl.la
--libva_egl_la_LIBADD = libva.la egl/libva_egl.la \
-+libva_egl_la_DEPENDENCIES = egl/libva_egl.la
-+libva_egl_la_LIBADD = egl/libva_egl.la \
- $(EGL_LIBS) -ldl
- endif
-
---
-2.11.1
-
diff --git a/common/recipes-graphics/libva/libva-gl/0003-allow-building-glx-backend-without-x11-enabled.patch b/common/recipes-graphics/libva/libva-gl/0003-allow-building-glx-backend-without-x11-enabled.patch
deleted file mode 100644
index 4f2c5e0c..00000000
--- a/common/recipes-graphics/libva/libva-gl/0003-allow-building-glx-backend-without-x11-enabled.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 602d90e7b04d39576d458094caf031b9638d4c9c Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Tue, 29 Mar 2016 15:10:02 +0500
-Subject: [PATCH] allow building glx backend without x11 enabled
-
-The X11 requirements are dealt through the base package
-so we allow this package to build glx without x11 enabled.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 8dde9ca..65aad67 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -230,7 +230,7 @@ AM_CONDITIONAL(USE_X11, test "$USE_X11" = "yes")
-
- # Check for GLX
- USE_GLX="no"
--if test "$USE_X11:$enable_glx" = "yes:yes"; then
-+if test "$enable_glx" = "yes"; then
- PKG_CHECK_MODULES([GLX], [gl x11], [USE_GLX="yes"], [:])
- saved_CPPFLAGS="$CPPFLAGS"
- saved_LIBS="$LIBS"
---
-1.9.1
-