aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-core')
-rw-r--r--common/recipes-core/busybox/busybox/gpt_disklabel.cfg1
-rw-r--r--common/recipes-core/busybox/busybox_%.bbappend4
-rw-r--r--common/recipes-core/coreutils/coreutils_8.29.bbappend2
-rw-r--r--common/recipes-core/coreutils/files/0001-Fix-build-with-glibc-2.28.patch186
-rw-r--r--common/recipes-core/initrdscripts/files/0001-init-install.sh-Don-t-set-quiet-kernel-option-in-ins.patch38
-rw-r--r--common/recipes-core/initrdscripts/files/0002-init-install.sh-Add-a-second-prompt-to-install.patch37
-rw-r--r--common/recipes-core/initrdscripts/files/0003-init-install-efi.sh-Don-t-set-quiet-kernel-option-in.patch38
-rw-r--r--common/recipes-core/initrdscripts/files/0004-init-install-efi.sh-Add-a-second-prompt-to-install.patch37
-rw-r--r--common/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bbappend5
-rw-r--r--common/recipes-core/initrdscripts/initramfs-live-install_1.0.bbappend5
-rw-r--r--common/recipes-core/llvm/files/0001-llvm-config-allow-overriding-libdir-through-cmdline.patch101
-rw-r--r--common/recipes-core/llvm/llvm_git.bbappend2
-rw-r--r--common/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend7
-rw-r--r--common/recipes-core/packagegroups/packagegroup-core-tools-testapps.bbappend10
-rw-r--r--common/recipes-core/packagegroups/packagegroup-multimedia-risky.bb14
-rw-r--r--common/recipes-core/systemd/systemd_%.bbappend5
-rw-r--r--common/recipes-core/udev/udev-extraconf/60-drm-hotplug-mode.rules1
-rw-r--r--common/recipes-core/udev/udev-extraconf/hotplug-display-auto.sh12
-rw-r--r--common/recipes-core/udev/udev-extraconf/hotplug-display-extended-h.sh16
-rw-r--r--common/recipes-core/udev/udev-extraconf/hotplug-display-extended-v.sh16
-rw-r--r--common/recipes-core/udev/udev-extraconf/hotplug-display-mirrored.sh16
-rw-r--r--common/recipes-core/udev/udev-extraconf_%.bbappend26
22 files changed, 0 insertions, 579 deletions
diff --git a/common/recipes-core/busybox/busybox/gpt_disklabel.cfg b/common/recipes-core/busybox/busybox/gpt_disklabel.cfg
deleted file mode 100644
index 686eb99d..00000000
--- a/common/recipes-core/busybox/busybox/gpt_disklabel.cfg
+++ /dev/null
@@ -1 +0,0 @@
-CONFIG_FEATURE_GPT_LABEL=y
diff --git a/common/recipes-core/busybox/busybox_%.bbappend b/common/recipes-core/busybox/busybox_%.bbappend
deleted file mode 100644
index e77c720e..00000000
--- a/common/recipes-core/busybox/busybox_%.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI_append_amd = " \
- file://gpt_disklabel.cfg \
- "
diff --git a/common/recipes-core/coreutils/coreutils_8.29.bbappend b/common/recipes-core/coreutils/coreutils_8.29.bbappend
deleted file mode 100644
index b49aa484..00000000
--- a/common/recipes-core/coreutils/coreutils_8.29.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI_append_mel-lite = " file://0001-Fix-build-with-glibc-2.28.patch"
diff --git a/common/recipes-core/coreutils/files/0001-Fix-build-with-glibc-2.28.patch b/common/recipes-core/coreutils/files/0001-Fix-build-with-glibc-2.28.patch
deleted file mode 100644
index 8799da81..00000000
--- a/common/recipes-core/coreutils/files/0001-Fix-build-with-glibc-2.28.patch
+++ /dev/null
@@ -1,186 +0,0 @@
-From c428f43e3b7397e23dad0004ad5696842761f8ac Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Tue, 16 Oct 2018 12:02:12 +0500
-Subject: [PATCH] Fix build with glibc 2.28+
-
-These adjustments are required in order to get a clean build with
-glibc 2.28+
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- lib/fflush.c | 6 +++---
- lib/fpending.c | 2 +-
- lib/fpurge.c | 2 +-
- lib/freadahead.c | 2 +-
- lib/freading.c | 2 +-
- lib/freadptr.c | 2 +-
- lib/freadseek.c | 2 +-
- lib/fseeko.c | 4 ++--
- lib/fseterr.c | 2 +-
- lib/stdio-impl.h | 6 ++++++
- 10 files changed, 18 insertions(+), 12 deletions(-)
-
-diff --git a/lib/fflush.c b/lib/fflush.c
-index 4e65692..c16da5f 100644
---- a/lib/fflush.c
-+++ b/lib/fflush.c
-@@ -33,7 +33,7 @@
- #undef fflush
-
-
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-
- /* Clear the stream's ungetc buffer, preserving the value of ftello (fp). */
- static void
-@@ -72,7 +72,7 @@ clear_ungetc_buffer (FILE *fp)
-
- #endif
-
--#if ! (defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
-+#if ! (defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */)
-
- # if (defined __sferror || defined __DragonFly__ || defined __ANDROID__) && defined __SNPT
- /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
-@@ -148,7 +148,7 @@ rpl_fflush (FILE *stream)
- if (stream == NULL || ! freading (stream))
- return fflush (stream);
-
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-
- clear_ungetc_buffer_preserving_position (stream);
-
-diff --git a/lib/fpending.c b/lib/fpending.c
-index 5811a4a..9e21a16 100644
---- a/lib/fpending.c
-+++ b/lib/fpending.c
-@@ -32,7 +32,7 @@ __fpending (FILE *fp)
- /* Most systems provide FILE as a struct and the necessary bitmask in
- <stdio.h>, because they need it for implementing getc() and putc() as
- fast macros. */
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- return fp->_IO_write_ptr - fp->_IO_write_base;
- #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
- /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
-diff --git a/lib/fpurge.c b/lib/fpurge.c
-index 408b8fc..3a16000 100644
---- a/lib/fpurge.c
-+++ b/lib/fpurge.c
-@@ -62,7 +62,7 @@ fpurge (FILE *fp)
- /* Most systems provide FILE as a struct and the necessary bitmask in
- <stdio.h>, because they need it for implementing getc() and putc() as
- fast macros. */
--# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+# if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- fp->_IO_read_end = fp->_IO_read_ptr;
- fp->_IO_write_ptr = fp->_IO_write_base;
- /* Avoid memory leak when there is an active ungetc buffer. */
-diff --git a/lib/freadahead.c b/lib/freadahead.c
-index f335f04..e7cb77b 100644
---- a/lib/freadahead.c
-+++ b/lib/freadahead.c
-@@ -30,7 +30,7 @@ extern size_t __sreadahead (FILE *);
- size_t
- freadahead (FILE *fp)
- {
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- if (fp->_IO_write_ptr > fp->_IO_write_base)
- return 0;
- return (fp->_IO_read_end - fp->_IO_read_ptr)
-diff --git a/lib/freading.c b/lib/freading.c
-index 78140d2..c9d3344 100644
---- a/lib/freading.c
-+++ b/lib/freading.c
-@@ -31,7 +31,7 @@ freading (FILE *fp)
- /* Most systems provide FILE as a struct and the necessary bitmask in
- <stdio.h>, because they need it for implementing getc() and putc() as
- fast macros. */
--# if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+# if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- return ((fp->_flags & _IO_NO_WRITES) != 0
- || ((fp->_flags & (_IO_NO_READS | _IO_CURRENTLY_PUTTING)) == 0
- && fp->_IO_read_base != NULL));
-diff --git a/lib/freadptr.c b/lib/freadptr.c
-index e4cc0b0..aba8dd5 100644
---- a/lib/freadptr.c
-+++ b/lib/freadptr.c
-@@ -29,7 +29,7 @@ freadptr (FILE *fp, size_t *sizep)
- size_t size;
-
- /* Keep this code in sync with freadahead! */
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- if (fp->_IO_write_ptr > fp->_IO_write_base)
- return NULL;
- size = fp->_IO_read_end - fp->_IO_read_ptr;
-diff --git a/lib/freadseek.c b/lib/freadseek.c
-index fcecba6..98726f8 100644
---- a/lib/freadseek.c
-+++ b/lib/freadseek.c
-@@ -36,7 +36,7 @@ freadptrinc (FILE *fp, size_t increment)
- /* Keep this code in sync with freadptr! */
- #if HAVE___FREADPTRINC /* musl libc */
- __freadptrinc (fp, increment);
--#elif defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#elif defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- fp->_IO_read_ptr += increment;
- #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
- /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
-diff --git a/lib/fseeko.c b/lib/fseeko.c
-index d0f24d8..0ae2b15 100644
---- a/lib/fseeko.c
-+++ b/lib/fseeko.c
-@@ -47,7 +47,7 @@ fseeko (FILE *fp, off_t offset, int whence)
- #endif
-
- /* These tests are based on fpurge.c. */
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- if (fp->_IO_read_end == fp->_IO_read_ptr
- && fp->_IO_write_ptr == fp->_IO_write_base
- && fp->_IO_save_base == NULL)
-@@ -123,7 +123,7 @@ fseeko (FILE *fp, off_t offset, int whence)
- return -1;
- }
-
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- fp->_flags &= ~_IO_EOF_SEEN;
- fp->_offset = pos;
- #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
-diff --git a/lib/fseterr.c b/lib/fseterr.c
-index 739e545..d998619 100644
---- a/lib/fseterr.c
-+++ b/lib/fseterr.c
-@@ -29,7 +29,7 @@ fseterr (FILE *fp)
- /* Most systems provide FILE as a struct and the necessary bitmask in
- <stdio.h>, because they need it for implementing getc() and putc() as
- fast macros. */
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
- fp->_flags |= _IO_ERR_SEEN;
- #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
- /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
-diff --git a/lib/stdio-impl.h b/lib/stdio-impl.h
-index 329801a..eeaabab 100644
---- a/lib/stdio-impl.h
-+++ b/lib/stdio-impl.h
-@@ -18,6 +18,12 @@
- the same implementation of stdio extension API, except that some fields
- have different naming conventions, or their access requires some casts. */
-
-+/* Glibc 2.28 made _IO_IN_BACKUP private. For now, work around this
-+ problem by defining it ourselves. FIXME: Do not rely on glibc
-+ internals. */
-+#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN
-+# define _IO_IN_BACKUP 0x100
-+#endif
-
- /* BSD stdio derived implementations. */
-
---
-2.7.4
-
diff --git a/common/recipes-core/initrdscripts/files/0001-init-install.sh-Don-t-set-quiet-kernel-option-in-ins.patch b/common/recipes-core/initrdscripts/files/0001-init-install.sh-Don-t-set-quiet-kernel-option-in-ins.patch
deleted file mode 100644
index c42438d4..00000000
--- a/common/recipes-core/initrdscripts/files/0001-init-install.sh-Don-t-set-quiet-kernel-option-in-ins.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 2fe5dc144c38ca4e8621d81e990453565bb1b01e Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Mon, 19 Mar 2018 16:49:51 +0500
-Subject: [PATCH] init-install.sh: Don't set "quiet" kernel option
-
-Signed-off-by: Drew Moseley <drew_moseley@mentor.com>
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
-
-Upstream-Status: Inappropriate [configuration]
----
- init-install.sh | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/init-install.sh b/init-install.sh
-index 713a830..36fcdba 100644
---- init-install.sh
-+++ init-install.sh
-@@ -293,7 +293,7 @@ if [ -f /etc/grub.d/00_header -a $grub_version -ne 0 ] ; then
- cat >$GRUBCFG <<_EOF
- menuentry "Linux" {
- search --no-floppy --fs-uuid $boot_uuid --set root
-- linux /$kernel root=PARTUUID=$root_part_uuid $rootwait rw $5 $3 $4 quiet
-+ linux /$kernel root=PARTUUID=$root_part_uuid $rootwait rw $5 $3 $4
- }
- _EOF
- chmod 0444 $GRUBCFG
-@@ -307,7 +307,7 @@ if [ $grub_version -eq 0 ] ; then
- echo "timeout 30" >> /boot/grub/menu.lst
- echo "title Live Boot/Install-Image" >> /boot/grub/menu.lst
- echo "root (hd0,0)" >> /boot/grub/menu.lst
-- echo "kernel /$kernel root=$rootfs rw $3 $4 quiet" >> /boot/grub/menu.lst
-+ echo "kernel /$kernel root=$rootfs rw $3 $4" >> /boot/grub/menu.lst
- fi
-
- # Copy kernel artifacts. To add more artifacts just add to types
---
-2.11.1
-
diff --git a/common/recipes-core/initrdscripts/files/0002-init-install.sh-Add-a-second-prompt-to-install.patch b/common/recipes-core/initrdscripts/files/0002-init-install.sh-Add-a-second-prompt-to-install.patch
deleted file mode 100644
index 49482b52..00000000
--- a/common/recipes-core/initrdscripts/files/0002-init-install.sh-Add-a-second-prompt-to-install.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From b93b1271d5f548c048b0813e1f9662c0befdac97 Mon Sep 17 00:00:00 2001
-From: Drew Moseley <drew_moseley@mentor.com>
-Date: Sat, 5 Jul 2014 18:58:25 -0400
-Subject: [PATCH 2/4] init-install.sh: Add a second prompt to install
-
-This also makes it clear that the user will be overwriting
-the entire disk.
-
-Signed-off-by: Drew Moseley <drew_moseley@mentor.com>
----
- meta/recipes-core/initrdscripts/files/init-install.sh | 14 ++++++++++++--
- 1 file changed, 12 insertions(+), 2 deletions(-)
-
-Upstream-Status: Inappropriate [configuration]
-
-diff --git a/meta/recipes-core/initrdscripts/files/init-install.sh b/meta/recipes-core/initrdscripts/files/init-install.sh
---- init-install.sh.orig 2016-08-01 13:29:03.823681411 -0700
-+++ init-install.sh 2016-08-01 13:30:32.323680567 -0700
-@@ -94,6 +94,18 @@
- done
-
- if [ -n "$TARGET_DEVICE_NAME" ]; then
-+ while true; do
-+ echo "This will overwrite all data on $TARGET_DEVICE_NAME"
-+ echo -n "Are you sure? [y/n] "
-+ read answer
-+ if [ "$answer" = "y" ]; then
-+ break
-+ elif [ "$answer" = "n" ]; then
-+ echo "Installation aborted."
-+ exit 1
-+ fi
-+ echo "Please answer y or n"
-+ done
- echo "Installing image on /dev/$TARGET_DEVICE_NAME ..."
- else
- echo "No hard drive selected. Installation aborted."
diff --git a/common/recipes-core/initrdscripts/files/0003-init-install-efi.sh-Don-t-set-quiet-kernel-option-in.patch b/common/recipes-core/initrdscripts/files/0003-init-install-efi.sh-Don-t-set-quiet-kernel-option-in.patch
deleted file mode 100644
index 76771c09..00000000
--- a/common/recipes-core/initrdscripts/files/0003-init-install-efi.sh-Don-t-set-quiet-kernel-option-in.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 30186b183e0022abb97485f5804be0e1e02ccb1f Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Mon, 19 Mar 2018 16:56:53 +0500
-Subject: [PATCH] init-install-efi.sh: Don't set "quiet" kernel option
-
-Signed-off-by: Drew Moseley <drew_moseley@mentor.com>
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
-
-Upstream-Status: Inappropriate [configuration]
----
- init-install-efi.sh | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/init-install-efi.sh b/init-install-efi.sh
-index f946d97..c8af835 100644
---- init-install-efi.sh
-+++ init-install-efi.sh
-@@ -246,7 +246,7 @@ if [ -f /run/media/$1/EFI/BOOT/grub.cfg ]; then
- sed -i "s/ LABEL=[^ ]*/ /" $GRUBCFG
- # Replace root= and add additional standard boot options
- # We use root as a sentinel value, as vmlinuz is no longer guaranteed
-- sed -i "s/ root=[^ ]*/ root=PARTUUID=$root_part_uuid rw $rootwait quiet /g" $GRUBCFG
-+ sed -i "s/ root=[^ ]*/ root=PARTUUID=$root_part_uuid rw $rootwait /g" $GRUBCFG
- fi
-
- if [ -d /run/media/$1/loader ]; then
-@@ -263,7 +263,7 @@ if [ -d /run/media/$1/loader ]; then
- # delete any root= strings
- sed -i "s/ root=[^ ]*/ /" $SYSTEMDBOOT_CFGS
- # add the root= and other standard boot options
-- sed -i "s@options *@options root=PARTUUID=$rootuuid rw $rootwait quiet @" $SYSTEMDBOOT_CFGS
-+ sed -i "s@options *@options root=PARTUUID=$rootuuid rw $rootwait @" $SYSTEMDBOOT_CFGS
- fi
-
- umount /tgt_root
---
-2.11.1
-
diff --git a/common/recipes-core/initrdscripts/files/0004-init-install-efi.sh-Add-a-second-prompt-to-install.patch b/common/recipes-core/initrdscripts/files/0004-init-install-efi.sh-Add-a-second-prompt-to-install.patch
deleted file mode 100644
index 86b8baee..00000000
--- a/common/recipes-core/initrdscripts/files/0004-init-install-efi.sh-Add-a-second-prompt-to-install.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From a2c99e6a9b5a47f72a9a73ad5d1978786c809583 Mon Sep 17 00:00:00 2001
-From: Drew Moseley <drew_moseley@mentor.com>
-Date: Sat, 5 Jul 2014 18:58:39 -0400
-Subject: [PATCH 4/4] init-install-efi.sh: Add a second prompt to install
-
-This also makes it clear that the user will be overwriting
-the entire disk.
-
-Signed-off-by: Drew Moseley <drew_moseley@mentor.com>
----
- meta/recipes-core/initrdscripts/files/init-install-efi.sh | 14 ++++++++++++--
- 1 file changed, 12 insertions(+), 2 deletions(-)
-
-Upstream-Status: Inappropriate [configuration]
-
-diff --git a/meta/recipes-core/initrdscripts/files/init-install-efi.sh b/meta/recipes-core/initrdscripts/files/init-install-efi.sh
---- init-install-efi.sh.orig 2016-08-02 12:13:24.718900725 -0700
-+++ init-install-efi.sh 2016-08-02 12:16:05.926899187 -0700
-@@ -100,6 +100,18 @@
- done
-
- if [ -n "$TARGET_DEVICE_NAME" ]; then
-+ while true; do
-+ echo "This will overwrite all data on $TARGET_DEVICE_NAME"
-+ echo -n "Are you sure? [y/n] "
-+ read answer
-+ if [ "$answer" = "y" ]; then
-+ break
-+ elif [ "$answer" = "n" ]; then
-+ echo "Installation aborted."
-+ exit 1
-+ fi
-+ echo "Please answer y or n"
-+ done
- echo "Installing image on /dev/$TARGET_DEVICE_NAME ..."
- else
- echo "No hard drive selected. Installation aborted."
diff --git a/common/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bbappend b/common/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bbappend
deleted file mode 100644
index 752982b5..00000000
--- a/common/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI_append_amd = " \
- file://0003-init-install-efi.sh-Don-t-set-quiet-kernel-option-in.patch;striplevel=0;patchdir=${WORKDIR} \
- file://0004-init-install-efi.sh-Add-a-second-prompt-to-install.patch;striplevel=0;patchdir=${WORKDIR} \
-"
diff --git a/common/recipes-core/initrdscripts/initramfs-live-install_1.0.bbappend b/common/recipes-core/initrdscripts/initramfs-live-install_1.0.bbappend
deleted file mode 100644
index 45ccedbd..00000000
--- a/common/recipes-core/initrdscripts/initramfs-live-install_1.0.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI_append_amd = " \
- file://0001-init-install.sh-Don-t-set-quiet-kernel-option-in-ins.patch;striplevel=0;patchdir=${WORKDIR} \
- file://0002-init-install.sh-Add-a-second-prompt-to-install.patch;striplevel=0;patchdir=${WORKDIR} \
-"
diff --git a/common/recipes-core/llvm/files/0001-llvm-config-allow-overriding-libdir-through-cmdline.patch b/common/recipes-core/llvm/files/0001-llvm-config-allow-overriding-libdir-through-cmdline.patch
deleted file mode 100644
index 26bf42e5..00000000
--- a/common/recipes-core/llvm/files/0001-llvm-config-allow-overriding-libdir-through-cmdline.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-From 87b01c9e5cecd30f9cde1f717e1ae7094e1f62c1 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Wed, 13 Dec 2017 14:15:24 +0500
-Subject: [PATCH] llvm-config: allow overriding libdir through cmdline
-
-This is handy in cases such as the OE environment
-where llvm-config is used through the llvm-native
-package so the libdir it reports can be different
-what is required for the target sysroot and so if
-the baselib is different for target and host the
-llvm-config --libs command will fail complaining
-about not finding required libraries. This scenario
-can be reproduced through an LLVM enabled mesa build
-where host and target have different baselib. So
-after the patch the mesa build should pass the whole
-target libdir to the llvm-config command to use.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- tools/llvm-config/llvm-config.cpp | 32 ++++++++++++++++++++++++++++----
- 1 file changed, 28 insertions(+), 4 deletions(-)
-
-diff --git a/tools/llvm-config/llvm-config.cpp b/tools/llvm-config/llvm-config.cpp
-index 08b096afb05..8233d16dda0 100644
---- a/tools/llvm-config/llvm-config.cpp
-+++ b/tools/llvm-config/llvm-config.cpp
-@@ -301,6 +301,18 @@ int main(int argc, char **argv) {
- DevelopmentTreeLayout = CMakeStyle; // Initialized to avoid warnings.
- }
-
-+ // Check if we were given a special libdir to use
-+ // if so disregard all other libdir settings
-+ std::string TargetLibDir;
-+ for (int i = 1; i != argc; ++i) {
-+ if (strcmp(argv[i],"--tgtlibdir") == 0) {
-+ if (argc > i+1) {
-+ TargetLibDir.assign(argv[i+1]);
-+ break;
-+ }
-+ }
-+ }
-+
- // Compute various directory locations based on the derived location
- // information.
- std::string ActivePrefix, ActiveBinDir, ActiveIncludeDir, ActiveLibDir,
-@@ -315,13 +327,19 @@ int main(int argc, char **argv) {
- switch (DevelopmentTreeLayout) {
- case CMakeStyle:
- ActiveBinDir = ActiveObjRoot + "/bin";
-- ActiveLibDir = ActiveObjRoot + "/lib" + LLVM_LIBDIR_SUFFIX;
-+ if (!TargetLibDir.empty())
-+ ActiveLibDir = TargetLibDir;
-+ else
-+ ActiveLibDir = ActiveObjRoot + "/lib" + LLVM_LIBDIR_SUFFIX;
- ActiveCMakeDir = ActiveLibDir + "/cmake/llvm";
- break;
- case CMakeBuildModeStyle:
- ActivePrefix = ActiveObjRoot;
- ActiveBinDir = ActiveObjRoot + "/bin/" + build_mode;
-- ActiveLibDir =
-+ if (!TargetLibDir.empty())
-+ ActiveLibDir = TargetLibDir;
-+ else
-+ ActiveLibDir =
- ActiveObjRoot + "/lib" + LLVM_LIBDIR_SUFFIX + "/" + build_mode;
- ActiveCMakeDir = ActiveLibDir + "/cmake/llvm";
- break;
-@@ -336,7 +354,10 @@ int main(int argc, char **argv) {
- SmallString<256> path(StringRef(LLVM_TOOLS_INSTALL_DIR));
- sys::fs::make_absolute(ActivePrefix, path);
- ActiveBinDir = path.str();
-- ActiveLibDir = ActivePrefix + "/lib" + LLVM_LIBDIR_SUFFIX;
-+ if (!TargetLibDir.empty())
-+ ActiveLibDir = TargetLibDir;
-+ else
-+ ActiveLibDir = ActivePrefix + "/lib" + LLVM_LIBDIR_SUFFIX;
- ActiveCMakeDir = ActiveLibDir + "/cmake/llvm";
- ActiveIncludeOption = "-I" + ActiveIncludeDir;
- }
-@@ -468,7 +489,7 @@ int main(int argc, char **argv) {
- };
-
- raw_ostream &OS = outs();
-- for (int i = 1; i != argc; ++i) {
-+ for (int i = 1; i < argc; ++i) {
- StringRef Arg = argv[i];
-
- if (Arg.startswith("-")) {
-@@ -567,6 +588,9 @@ int main(int argc, char **argv) {
- LinkMode = LinkModeShared;
- } else if (Arg == "--link-static") {
- LinkMode = LinkModeStatic;
-+ } else if (Arg == "--tgtlibdir") {
-+ ++i;
-+ continue;
- } else {
- usage();
- }
---
-2.11.1
-
diff --git a/common/recipes-core/llvm/llvm_git.bbappend b/common/recipes-core/llvm/llvm_git.bbappend
deleted file mode 100644
index 373df6cb..00000000
--- a/common/recipes-core/llvm/llvm_git.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "file://0001-llvm-config-allow-overriding-libdir-through-cmdline.patch"
diff --git a/common/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend b/common/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
deleted file mode 100644
index 4f47e708..00000000
--- a/common/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
+++ /dev/null
@@ -1,7 +0,0 @@
-RRECOMMENDS_${PN}_remove_amd := " \
- ${@bb.utils.contains("DISTRO", "mel", "", "perf kernel-module-oprofile", d)} \
-"
-
-PROFILETOOLS_remove_amd := " \
- ${@bb.utils.contains("DISTRO", "mel", "", "oprofile oprofileui-server", d)} \
-"
diff --git a/common/recipes-core/packagegroups/packagegroup-core-tools-testapps.bbappend b/common/recipes-core/packagegroups/packagegroup-core-tools-testapps.bbappend
deleted file mode 100644
index c2d1cc56..00000000
--- a/common/recipes-core/packagegroups/packagegroup-core-tools-testapps.bbappend
+++ /dev/null
@@ -1,10 +0,0 @@
-RDEPENDS_${PN}_remove_amd = " \
- gst-meta-video \
- gst-meta-audio \
- ${@bb.utils.contains("DISTRO", "mel", "", "owl-video", d)} \
-"
-
-RDEPENDS_${PN}_append_amd = "${@bb.utils.contains("DISTRO", "mel", " \
- gstreamer1.0-meta-video \
- gstreamer1.0-meta-audio \
-", "", d)}"
diff --git a/common/recipes-core/packagegroups/packagegroup-multimedia-risky.bb b/common/recipes-core/packagegroups/packagegroup-multimedia-risky.bb
deleted file mode 100644
index 36bc2075..00000000
--- a/common/recipes-core/packagegroups/packagegroup-multimedia-risky.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "AMD risky multimedia packages"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-PR = "r0"
-
-inherit packagegroup
-
-RDEPENDS_${PN} += "\
- libfaad \
- libid3tag \
- gstreamer1.0-plugins-bad-meta \
- gstreamer1.0-plugins-ugly-meta \
- gstreamer1.0-libav \
-"
diff --git a/common/recipes-core/systemd/systemd_%.bbappend b/common/recipes-core/systemd/systemd_%.bbappend
deleted file mode 100644
index 2198b747..00000000
--- a/common/recipes-core/systemd/systemd_%.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-pkg_postinst_udev-hwdb_amd () {
-}
-pkg_postinst_ontarget_udev-hwdb_amd () {
- udevadm hwdb --update
-}
diff --git a/common/recipes-core/udev/udev-extraconf/60-drm-hotplug-mode.rules b/common/recipes-core/udev/udev-extraconf/60-drm-hotplug-mode.rules
deleted file mode 100644
index 9eaa12ba..00000000
--- a/common/recipes-core/udev/udev-extraconf/60-drm-hotplug-mode.rules
+++ /dev/null
@@ -1 +0,0 @@
-ACTION=="change", SUBSYSTEM=="drm", ENV{HOTPLUG}=="1", ENV{DISPLAY}=":0", RUN+="/etc/udev/scripts/hotplug-display-@MULTIDISPLAYMODE.sh"
diff --git a/common/recipes-core/udev/udev-extraconf/hotplug-display-auto.sh b/common/recipes-core/udev/udev-extraconf/hotplug-display-auto.sh
deleted file mode 100644
index 9e1864da..00000000
--- a/common/recipes-core/udev/udev-extraconf/hotplug-display-auto.sh
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh
-
-connectedPorts=$(xrandr | grep " connected" | sed 's/ connected.*//')
-for port in $connectedPorts ; do
- xrandr --output $port --auto
-done
-
-disconnectedPorts=$(xrandr | grep " disconnected" | sed 's/ disconnected.*//')
-for port in $disconnectedPorts ; do
- xrandr --output $port --off
-done
-
diff --git a/common/recipes-core/udev/udev-extraconf/hotplug-display-extended-h.sh b/common/recipes-core/udev/udev-extraconf/hotplug-display-extended-h.sh
deleted file mode 100644
index 6adab773..00000000
--- a/common/recipes-core/udev/udev-extraconf/hotplug-display-extended-h.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-declare -a connectedPorts=($(xrandr | grep " connected" | sed 's/ connected.*//'))
-for i in "${!connectedPorts[@]}"; do
- if [ $i -eq 0 ]; then
- xrandr --output ${connectedPorts[i]} --auto
- fi
- if [ -n "${connectedPorts[i+1]}" ]; then
- xrandr --output ${connectedPorts[i+1]} --auto --right-of ${connectedPorts[i]}
- fi
-done
-
-disconnectedPorts=$(xrandr | grep " disconnected" | sed 's/ disconnected.*//')
-for port in $disconnectedPorts ; do
- xrandr --output $port --off
-done
diff --git a/common/recipes-core/udev/udev-extraconf/hotplug-display-extended-v.sh b/common/recipes-core/udev/udev-extraconf/hotplug-display-extended-v.sh
deleted file mode 100644
index 5b16969c..00000000
--- a/common/recipes-core/udev/udev-extraconf/hotplug-display-extended-v.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-declare -a connectedPorts=($(xrandr | grep " connected" | sed 's/ connected.*//'))
-for i in "${!connectedPorts[@]}"; do
- if [ $i -eq 0 ]; then
- xrandr --output ${connectedPorts[i]} --auto
- fi
- if [ -n "${connectedPorts[i+1]}" ]; then
- xrandr --output ${connectedPorts[i+1]} --auto --below ${connectedPorts[i]}
- fi
-done
-
-disconnectedPorts=$(xrandr | grep " disconnected" | sed 's/ disconnected.*//')
-for port in $disconnectedPorts ; do
- xrandr --output $port --off
-done
diff --git a/common/recipes-core/udev/udev-extraconf/hotplug-display-mirrored.sh b/common/recipes-core/udev/udev-extraconf/hotplug-display-mirrored.sh
deleted file mode 100644
index 1c0ae61a..00000000
--- a/common/recipes-core/udev/udev-extraconf/hotplug-display-mirrored.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-declare -a connectedPorts=($(xrandr | grep " connected" | sed 's/ connected.*//'))
-for i in "${!connectedPorts[@]}"; do
- if [ $i -eq 0 ]; then
- xrandr --output ${connectedPorts[i]} --auto
- fi
- if [ -n "${connectedPorts[i+1]}" ]; then
- xrandr --output ${connectedPorts[i+1]} --auto --same-as ${connectedPorts[0]}
- fi
-done
-
-disconnectedPorts=$(xrandr | grep " disconnected" | sed 's/ disconnected.*//')
-for port in $disconnectedPorts ; do
- xrandr --output $port --off
-done
diff --git a/common/recipes-core/udev/udev-extraconf_%.bbappend b/common/recipes-core/udev/udev-extraconf_%.bbappend
deleted file mode 100644
index 28e5e30f..00000000
--- a/common/recipes-core/udev/udev-extraconf_%.bbappend
+++ /dev/null
@@ -1,26 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += " \
- file://60-drm-hotplug-mode.rules \
- file://hotplug-display-auto.sh \
- file://hotplug-display-mirrored.sh \
- file://hotplug-display-extended-h.sh \
- file://hotplug-display-extended-v.sh \
-"
-# Allowed options for MULTI_DISPLAY_MODE: auto | mirrored | extended-h | extended-v
-MULTI_DISPLAY_MODE ?= "auto"
-
-do_install_append() {
- sed -i 's/@MULTIDISPLAYMODE/${MULTI_DISPLAY_MODE}/' ${WORKDIR}/60-drm-hotplug-mode.rules
-
- install -d ${D}${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/60-drm-hotplug-mode.rules ${D}${sysconfdir}/udev/rules.d/60-drm-hotplug-mode.rules
-
- install -d ${D}${sysconfdir}/udev/scripts/
- install -m 0755 ${WORKDIR}/hotplug-display-auto.sh ${D}${sysconfdir}/udev/scripts/hotplug-display-auto.sh
- install -m 0755 ${WORKDIR}/hotplug-display-mirrored.sh ${D}${sysconfdir}/udev/scripts/hotplug-display-mirrored.sh
- install -m 0755 ${WORKDIR}/hotplug-display-extended-h.sh ${D}${sysconfdir}/udev/scripts/hotplug-display-extended-h.sh
- install -m 0755 ${WORKDIR}/hotplug-display-extended-v.sh ${D}${sysconfdir}/udev/scripts/hotplug-display-extended-v.sh
-}
-
-RDEPENDS_${PN} += "${@bb.utils.contains('IMAGE_FEATURES', 'x11-base', 'xrandr', '', d)}"