aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/recipes-multimedia/mplayer/mplayer2_git.bbappend8
1 files changed, 7 insertions, 1 deletions
diff --git a/common/recipes-multimedia/mplayer/mplayer2_git.bbappend b/common/recipes-multimedia/mplayer/mplayer2_git.bbappend
index e0e89cfa..0276c176 100644
--- a/common/recipes-multimedia/mplayer/mplayer2_git.bbappend
+++ b/common/recipes-multimedia/mplayer/mplayer2_git.bbappend
@@ -9,7 +9,13 @@ do_install_append_amd() {
[ -e ${D}/usr/lib ] && rmdir ${D}/usr/lib
}
-PNBLACKLIST_amd[mplayer2] = ""
+# Clear PNBLACKLIST conditionally for AMD.
+# Suffix overrides and flags don't work well together.
+# Anonymous python would be less convoluted but that appears
+# to be too late in the parsing process to do what we need.
+OVERRIDES_LIST := "${@MACHINEOVERRIDES.replace(':', ' ')}"
+UPSTREAM_BLACKLIST_VALUE := "${@d.getVarFlag('PNBLACKLIST', 'mplayer2', False)}"
+PNBLACKLIST[mplayer2] = "${@bb.utils.contains('OVERRIDES_LIST', 'amd', '', '${UPSTREAM_BLACKLIST_VALUE}', d)}"
#
# mplayer has broken auto-tools scripts for