aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-amd-bsp/recipes-support/boost/boost/0001-boost-libs-python-converter-fix-build-with-gcc8.patch29
-rw-r--r--meta-amd-bsp/recipes-support/boost/boost_1.59.0.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-support/boost/boost/0001-boost-libs-python-converter-fix-build-with-gcc8.patch b/meta-amd-bsp/recipes-support/boost/boost/0001-boost-libs-python-converter-fix-build-with-gcc8.patch
new file mode 100644
index 00000000..c2530ec4
--- /dev/null
+++ b/meta-amd-bsp/recipes-support/boost/boost/0001-boost-libs-python-converter-fix-build-with-gcc8.patch
@@ -0,0 +1,29 @@
+From 3ff8d2aedcd072392692a3b21bf51ed5806b8f44 Mon Sep 17 00:00:00 2001
+From: "Arsalan H. Awan" <Arsalan_Awan@mentor.com>
+Date: Fri, 30 Aug 2019 15:11:04 +0500
+Subject: [PATCH] boost/libs/python/converter: fix build with gcc8
+
+Fixes the following in converter/builtin_converters.cpp:51:35:
+error: invalid conversion from 'const void*' to 'void*' [-fpermissive]
+
+Signed-off-by: Arsalan H. Awan <Arsalan_Awan@mentor.com>
+---
+ libs/python/src/converter/builtin_converters.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libs/python/src/converter/builtin_converters.cpp b/libs/python/src/converter/builtin_converters.cpp
+index 9900602..d67d721 100644
+--- a/libs/python/src/converter/builtin_converters.cpp
++++ b/libs/python/src/converter/builtin_converters.cpp
+@@ -48,7 +48,7 @@ namespace
+ #else
+ void* convert_to_cstring(PyObject* obj)
+ {
+- return PyUnicode_Check(obj) ? _PyUnicode_AsString(obj) : 0;
++ return (void*)(PyUnicode_Check(obj) ? _PyUnicode_AsString(obj) : 0);
+ }
+ #endif
+
+--
+2.11.1
+
diff --git a/meta-amd-bsp/recipes-support/boost/boost_1.59.0.bb b/meta-amd-bsp/recipes-support/boost/boost_1.59.0.bb
index de509c29..5f26c344 100644
--- a/meta-amd-bsp/recipes-support/boost/boost_1.59.0.bb
+++ b/meta-amd-bsp/recipes-support/boost/boost_1.59.0.bb
@@ -16,6 +16,7 @@ SRC_URI += "\
file://0003-smart_ptr-mips-assembly-doesn-t-compile-in-mips16e-m.patch \
file://0004-Use-atomic-by-default-when-BOOST_NO_CXX11_HDR_ATOMIC.patch \
file://boost-math-disable-pch-for-gcc.patch \
+ file://0001-boost-libs-python-converter-fix-build-with-gcc8.patch \
"
TARGET_CPPFLAGS += " -D_GLIBCXX_USE_CXX11_ABI=0"