aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/mel-support/recipes-core/meta/archive-release.bbappend3
-rw-r--r--common/recipes-bsp/grub/grub-efi_2.00.bbappend3
-rw-r--r--common/recipes-core/busybox/busybox_%.bbappend5
-rw-r--r--common/recipes-kernel/linux/linux-yocto_%.bbappend9
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer1.0-omx_git.bbappend10
-rw-r--r--common/recipes-multimedia/libomxil/libomxil_0.9.3.bbappend3
-rw-r--r--meta-baldeagle/conf/machine/baldeagle.conf2
-rw-r--r--meta-steppeeagle/conf/machine/steppeeagle.conf2
8 files changed, 12 insertions, 25 deletions
diff --git a/common/mel-support/recipes-core/meta/archive-release.bbappend b/common/mel-support/recipes-core/meta/archive-release.bbappend
index c9e4c624..6a21c02f 100644
--- a/common/mel-support/recipes-core/meta/archive-release.bbappend
+++ b/common/mel-support/recipes-core/meta/archive-release.bbappend
@@ -1,2 +1 @@
-IMAGE_EXTENSION_live_baldeagle := "${@oe_filter_out('iso', '${IMAGE_EXTENSION_live}', d)}"
-IMAGE_EXTENSION_live_steppeeagle := "${@oe_filter_out('iso', '${IMAGE_EXTENSION_live}', d)}"
+IMAGE_EXTENSION_live_amd := "${@oe_filter_out('iso', '${IMAGE_EXTENSION_live}', d)}"
diff --git a/common/recipes-bsp/grub/grub-efi_2.00.bbappend b/common/recipes-bsp/grub/grub-efi_2.00.bbappend
index 2e855281..706e3f8b 100644
--- a/common/recipes-bsp/grub/grub-efi_2.00.bbappend
+++ b/common/recipes-bsp/grub/grub-efi_2.00.bbappend
@@ -5,5 +5,4 @@
# Still need to determine why this is necessary but
# in the meantime this will get us a bootable system.
#
-TUNE_CCARGS_append_steppeeagle += "-march=core2"
-TUNE_CCARGS_append_baldeagle += "-march=core2"
+TUNE_CCARGS_append_amd += "-march=core2"
diff --git a/common/recipes-core/busybox/busybox_%.bbappend b/common/recipes-core/busybox/busybox_%.bbappend
index 82288ef3..e77c720e 100644
--- a/common/recipes-core/busybox/busybox_%.bbappend
+++ b/common/recipes-core/busybox/busybox_%.bbappend
@@ -1,7 +1,4 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI_append_baldeagle = " \
- file://gpt_disklabel.cfg \
- "
-SRC_URI_append_steppeeagle = " \
+SRC_URI_append_amd = " \
file://gpt_disklabel.cfg \
"
diff --git a/common/recipes-kernel/linux/linux-yocto_%.bbappend b/common/recipes-kernel/linux/linux-yocto_%.bbappend
index 3b234c5b..c6be6346 100644
--- a/common/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -1,12 +1,5 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI_append_baldeagle = " \
- file://logo.cfg \
- file://console.cfg \
- file://logitech.cfg \
- file://efi-partition.cfg \
- ${@base_contains("DISTRO_FEATURES", "bluetooth", "file://bluetooth.cfg", "", d)} \
-"
-SRC_URI_append_steppeeagle += " \
+SRC_URI_append_amd = " \
file://logo.cfg \
file://console.cfg \
file://logitech.cfg \
diff --git a/common/recipes-multimedia/gstreamer/gstreamer1.0-omx_git.bbappend b/common/recipes-multimedia/gstreamer/gstreamer1.0-omx_git.bbappend
index a958e493..3a73c18d 100644
--- a/common/recipes-multimedia/gstreamer/gstreamer1.0-omx_git.bbappend
+++ b/common/recipes-multimedia/gstreamer/gstreamer1.0-omx_git.bbappend
@@ -3,10 +3,9 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
#
# Remove the patch as it is not needed with the new SRCREV we are using
#
-SRC_URI_remove_baldeagle = "file://0001-omx-fixed-type-error-in-printf-call.patch"
-SRC_URI_remove_steppeeagle = "file://0001-omx-fixed-type-error-in-printf-call.patch"
+SRC_URI_remove_amd = "file://0001-omx-fixed-type-error-in-printf-call.patch"
-SRC_URI_AMD_ADDITIONS = " \
+SRC_URI_append_amd = " \
file://0001-gstomxvideodec-fix-multithreads-negotiation-problem-.patch \
file://0002-gstomxvideodec-remove-dead-code.patch \
file://0003-gstomxvideodec-simplify-_find_nearest_frame.patch \
@@ -19,11 +18,8 @@ SRC_URI_AMD_ADDITIONS = " \
file://0010-omxvideoenc-fix-startup-race-condition.patch \
file://0011-omx-fix-two-serious-message-handling-bugs.patch \
"
-SRC_URI_append_baldeagle = " ${SRC_URI_AMD_ADDITIONS}"
-SRC_URI_append_steppeeagle = " ${SRC_URI_AMD_ADDITIONS}"
-SRCREV_baldeagle = "c44cd849400b90f5f4b1f4f429278d9685b1daca"
-SRCREV_steppeeagle = "c44cd849400b90f5f4b1f4f429278d9685b1daca"
+SRCREV_amd = "c44cd849400b90f5f4b1f4f429278d9685b1daca"
PV .= "+git${SRCPV}"
diff --git a/common/recipes-multimedia/libomxil/libomxil_0.9.3.bbappend b/common/recipes-multimedia/libomxil/libomxil_0.9.3.bbappend
index f851d092..a0b6ad37 100644
--- a/common/recipes-multimedia/libomxil/libomxil_0.9.3.bbappend
+++ b/common/recipes-multimedia/libomxil/libomxil_0.9.3.bbappend
@@ -1,5 +1,4 @@
-RDEPENDS_${PN}_append_baldeagle = "libomx-mesa"
-RDEPENDS_${PN}_append_steppeeagle = "libomx-mesa"
+RDEPENDS_${PN}_append_amd = "libomx-mesa"
#
# This package should not have commercial license flags.
diff --git a/meta-baldeagle/conf/machine/baldeagle.conf b/meta-baldeagle/conf/machine/baldeagle.conf
index b3896530..f2aa4d7d 100644
--- a/meta-baldeagle/conf/machine/baldeagle.conf
+++ b/meta-baldeagle/conf/machine/baldeagle.conf
@@ -43,3 +43,5 @@ APPEND += "console=ttyS0,115200 console=tty0"
RELEASE_IMAGE ?= "core-image-sato"
APPEND += "radeon.dpm=1"
+
+MACHINEOVERRIDES .= ":amd"
diff --git a/meta-steppeeagle/conf/machine/steppeeagle.conf b/meta-steppeeagle/conf/machine/steppeeagle.conf
index dbc7a737..16e46071 100644
--- a/meta-steppeeagle/conf/machine/steppeeagle.conf
+++ b/meta-steppeeagle/conf/machine/steppeeagle.conf
@@ -44,3 +44,5 @@ APPEND += "console=ttyUSB0,115200 console=tty0"
RELEASE_IMAGE ?= "core-image-sato"
APPEND += "radeon.dpm=1"
+
+MACHINEOVERRIDES .= ":amd"