aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/conf/machine/include/amd-common-configurations.inc4
-rw-r--r--common/recipes-graphics/mesa/mesa_git.bb2
2 files changed, 4 insertions, 2 deletions
diff --git a/common/conf/machine/include/amd-common-configurations.inc b/common/conf/machine/include/amd-common-configurations.inc
index bbe63bc3..df15137b 100644
--- a/common/conf/machine/include/amd-common-configurations.inc
+++ b/common/conf/machine/include/amd-common-configurations.inc
@@ -8,6 +8,10 @@ PREFERRED_VERSION_linux-yocto ?= "4.4%"
PREFERRED_VERSION_libav ?= "9.18"
PREFERRED_PROVIDER_llvm ?= "llvm7"
+# Components that depend on LLVM should set versions here
+# so we know what needs to be changed/validated as LLVM moves
+MESA_LLVM_RELEASE_amd = "7"
+
MULTILIBS ?= ""
require conf/multilib.conf
diff --git a/common/recipes-graphics/mesa/mesa_git.bb b/common/recipes-graphics/mesa/mesa_git.bb
index 596b8105..048ce06d 100644
--- a/common/recipes-graphics/mesa/mesa_git.bb
+++ b/common/recipes-graphics/mesa/mesa_git.bb
@@ -24,8 +24,6 @@ LIBVA_PLATFORMS .= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' libva-x11',
LIBVA_PLATFORMS .= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', ' libva-wayland', '', d)}"
RDEPENDS_mesa-megadriver += "${@bb.utils.contains('PACKAGECONFIG', 'va', '${LIBVA_PLATFORMS}', '', d)}"
-MESA_LLVM_RELEASE_amd = "7"
-
SRC_URI_amd = "git://anongit.freedesktop.org/mesa/mesa;branch=master \
file://0001-configure.ac-obey-llvm_prefix-if-available.patch \
file://0001-configure.ac-adjust-usage-of-LLVM-flags.patch \