aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/README8
-rw-r--r--common/recipes-core/images/core-image-base.bbappend3
-rw-r--r--common/recipes-sato/images/core-image-sato.bbappend3
-rw-r--r--meta-amdfalconx86/README20
-rw-r--r--meta-amdfalconx86/conf/machine/amdfalconx86.conf2
-rw-r--r--meta-baldeagle/README20
-rw-r--r--meta-baldeagle/conf/machine/baldeagle.conf2
-rw-r--r--meta-steppeeagle/README20
-rw-r--r--meta-steppeeagle/conf/machine/steppeeagle.conf2
9 files changed, 75 insertions, 5 deletions
diff --git a/common/README b/common/README
new file mode 100644
index 00000000..f153f5d6
--- /dev/null
+++ b/common/README
@@ -0,0 +1,8 @@
+meta-amd/common
+===============
+
+This layer contains metadata that is appropriate for all
+AMD-based platforms.
+
+Settings in this layer should use appropriate variable suffixes
+to ensure they only apply to expected boards.
diff --git a/common/recipes-core/images/core-image-base.bbappend b/common/recipes-core/images/core-image-base.bbappend
index 5f693fe3..36ae05dc 100644
--- a/common/recipes-core/images/core-image-base.bbappend
+++ b/common/recipes-core/images/core-image-base.bbappend
@@ -1,3 +1,4 @@
require conf/machine/include/amd-multimedia.inc
-IMAGE_INSTALL_append_amd = " mesa-demos"
+IMAGE_INSTALL_append_amdgpu = " mesa-demos"
+IMAGE_INSTALL_append_radeon = " mesa-demos"
diff --git a/common/recipes-sato/images/core-image-sato.bbappend b/common/recipes-sato/images/core-image-sato.bbappend
index 5f693fe3..36ae05dc 100644
--- a/common/recipes-sato/images/core-image-sato.bbappend
+++ b/common/recipes-sato/images/core-image-sato.bbappend
@@ -1,3 +1,4 @@
require conf/machine/include/amd-multimedia.inc
-IMAGE_INSTALL_append_amd = " mesa-demos"
+IMAGE_INSTALL_append_amdgpu = " mesa-demos"
+IMAGE_INSTALL_append_radeon = " mesa-demos"
diff --git a/meta-amdfalconx86/README b/meta-amdfalconx86/README
new file mode 100644
index 00000000..45106d0b
--- /dev/null
+++ b/meta-amdfalconx86/README
@@ -0,0 +1,20 @@
+meta-amd/meta-amdfalconx86
+==========================
+
+This is the location for AMD Falcon Family BSP.
+
+Please see the README file contained in the root meta-amd directory
+for general information and usage details.
+
+Dependencies
+============
+
+This layer depends on:
+
+URI: git://git.openembedded.org/bitbake
+
+URI: git://git.openembedded.org/openembedded-core
+layers: meta
+
+URI: git://git.openembedded.org/meta-openembedded
+layers: meta-oe
diff --git a/meta-amdfalconx86/conf/machine/amdfalconx86.conf b/meta-amdfalconx86/conf/machine/amdfalconx86.conf
index 40fcfc2a..2fdfadbf 100644
--- a/meta-amdfalconx86/conf/machine/amdfalconx86.conf
+++ b/meta-amdfalconx86/conf/machine/amdfalconx86.conf
@@ -67,4 +67,4 @@ APPEND += "amdgpu.dpm=1 amdgpu.dal=0"
# The AMD GPU driver will take over once it is up
APPEND += "vga=802"
-MACHINEOVERRIDES =. "amd:"
+MACHINEOVERRIDES =. "amd:amdgpu:"
diff --git a/meta-baldeagle/README b/meta-baldeagle/README
new file mode 100644
index 00000000..cce5fa07
--- /dev/null
+++ b/meta-baldeagle/README
@@ -0,0 +1,20 @@
+meta-amd/meta-baldeagle
+=======================
+
+This is the location for AMD Bald Eagle BSP.
+
+Please see the README file contained in the root meta-amd directory
+for general information and usage details.
+
+Dependencies
+============
+
+This layer depends on:
+
+URI: git://git.openembedded.org/bitbake
+
+URI: git://git.openembedded.org/openembedded-core
+layers: meta
+
+URI: git://git.openembedded.org/meta-openembedded
+layers: meta-oe
diff --git a/meta-baldeagle/conf/machine/baldeagle.conf b/meta-baldeagle/conf/machine/baldeagle.conf
index f0de2852..82d342c4 100644
--- a/meta-baldeagle/conf/machine/baldeagle.conf
+++ b/meta-baldeagle/conf/machine/baldeagle.conf
@@ -51,4 +51,4 @@ RELEASE_IMAGE ?= "core-image-sato"
APPEND += "radeon.dpm=1"
-MACHINEOVERRIDES =. "amd:"
+MACHINEOVERRIDES =. "amd:radeon:"
diff --git a/meta-steppeeagle/README b/meta-steppeeagle/README
new file mode 100644
index 00000000..c731ebeb
--- /dev/null
+++ b/meta-steppeeagle/README
@@ -0,0 +1,20 @@
+meta-amd/meta-steppeeagle
+=========================
+
+This is the location for AMD Steppe Eagle BSP.
+
+Please see the README file contained in the root meta-amd directory
+for general information and usage details.
+
+Dependencies
+============
+
+This layer depends on:
+
+URI: git://git.openembedded.org/bitbake
+
+URI: git://git.openembedded.org/openembedded-core
+layers: meta
+
+URI: git://git.openembedded.org/meta-openembedded
+layers: meta-oe
diff --git a/meta-steppeeagle/conf/machine/steppeeagle.conf b/meta-steppeeagle/conf/machine/steppeeagle.conf
index f66d4fd0..23d3a69e 100644
--- a/meta-steppeeagle/conf/machine/steppeeagle.conf
+++ b/meta-steppeeagle/conf/machine/steppeeagle.conf
@@ -51,4 +51,4 @@ RELEASE_IMAGE ?= "core-image-sato"
APPEND += "radeon.dpm=1"
-MACHINEOVERRIDES =. "amd:"
+MACHINEOVERRIDES =. "amd:radeon:"