aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/recipes-multimedia/mpv/mpv_%.bbappend7
-rw-r--r--meta-amdfalconx86/conf/local.conf.append.amdfalconx862
-rw-r--r--meta-steppeeagle/conf/local.conf.append.steppeeagle2
-rw-r--r--meta-v1000/conf/local.conf.append.v10002
-rw-r--r--meta-v1000/recipes-multimedia/mpv/mpv_0.24.0.bb60
5 files changed, 4 insertions, 69 deletions
diff --git a/common/recipes-multimedia/mpv/mpv_%.bbappend b/common/recipes-multimedia/mpv/mpv_%.bbappend
index f23b1cbc..45addc3c 100644
--- a/common/recipes-multimedia/mpv/mpv_%.bbappend
+++ b/common/recipes-multimedia/mpv/mpv_%.bbappend
@@ -1,9 +1,4 @@
-PACKAGECONFIG[drm] = "--enable-drm, --disable-drm, libdrm"
-PACKAGECONFIG[gbm] = "--enable-gbm, --disable-gbm, virtual/libgl"
-PACKAGECONFIG[vdpau] = "--enable-vdpau, --disable-vdpau, libvdpau"
-PACKAGECONFIG[va] = "--enable-vaapi, --disable-vaapi, libva"
-
-PACKAGECONFIG_append_amdx86 = " drm gbm vdpau va"
+PACKAGECONFIG_append_amdx86 = " drm gbm vdpau vaapi"
PACKAGECONFIG_remove_amdx86 = "lua"
EXTRA_OECONF_remove = "--disable-gl"
diff --git a/meta-amdfalconx86/conf/local.conf.append.amdfalconx86 b/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
index 742f5e5e..68cf3405 100644
--- a/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
+++ b/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
@@ -27,7 +27,7 @@ RT_KERNEL_AMD = "no"
# or software.
INCLUDE_MPV ??= "no"
-COMMERCIAL_LIC_FLAGS_MPV = "commercial_ffmpeg commercial_x264"
+COMMERCIAL_LIC_FLAGS_MPV = "commercial_mpv commercial_ffmpeg commercial_x264"
LICENSE_FLAGS_WHITELIST_append = "${@' ${COMMERCIAL_LIC_FLAGS_MPV}' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
CORE_IMAGE_EXTRA_INSTALL_append = "${@' mpv' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
diff --git a/meta-steppeeagle/conf/local.conf.append.steppeeagle b/meta-steppeeagle/conf/local.conf.append.steppeeagle
index c3f1b0b6..9ed86ffe 100644
--- a/meta-steppeeagle/conf/local.conf.append.steppeeagle
+++ b/meta-steppeeagle/conf/local.conf.append.steppeeagle
@@ -23,7 +23,7 @@
# or software.
INCLUDE_MPV ??= "no"
-COMMERCIAL_LIC_FLAGS_MPV = "commercial_ffmpeg commercial_x264"
+COMMERCIAL_LIC_FLAGS_MPV = "commercial_mpv commercial_ffmpeg commercial_x264"
LICENSE_FLAGS_WHITELIST .= "${@' ${COMMERCIAL_LIC_FLAGS_MPV}' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
CORE_IMAGE_EXTRA_INSTALL .= "${@' mpv' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
diff --git a/meta-v1000/conf/local.conf.append.v1000 b/meta-v1000/conf/local.conf.append.v1000
index bac98044..4c5658ec 100644
--- a/meta-v1000/conf/local.conf.append.v1000
+++ b/meta-v1000/conf/local.conf.append.v1000
@@ -23,7 +23,7 @@
# or software.
INCLUDE_MPV ??= "no"
-COMMERCIAL_LIC_FLAGS_MPV = "commercial_ffmpeg commercial_x264"
+COMMERCIAL_LIC_FLAGS_MPV = "commercial_mpv commercial_ffmpeg commercial_x264"
LICENSE_FLAGS_WHITELIST_append = "${@' ${COMMERCIAL_LIC_FLAGS_MPV}' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
CORE_IMAGE_EXTRA_INSTALL_append = "${@' mpv' if bb.utils.to_boolean('${INCLUDE_MPV}') else ''}"
diff --git a/meta-v1000/recipes-multimedia/mpv/mpv_0.24.0.bb b/meta-v1000/recipes-multimedia/mpv/mpv_0.24.0.bb
deleted file mode 100644
index bb10eec7..00000000
--- a/meta-v1000/recipes-multimedia/mpv/mpv_0.24.0.bb
+++ /dev/null
@@ -1,60 +0,0 @@
-SUMMARY = "Open Source multimedia player"
-DESCRIPTION = "mpv is a fork of mplayer2 and MPlayer. It shares some features with the former projects while introducing many more."
-SECTION = "multimedia"
-HOMEPAGE = "http://www.mpv.io/"
-DEPENDS = "zlib ffmpeg jpeg virtual/libx11 xsp libxv \
- libxscrnsaver libv4l libxinerama libvdpau \
-"
-
-REQUIRED_DISTRO_FEATURES = "x11"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=91f1cb870c1cc2d31351a4d2595441cb"
-
-SRC_URI = " \
- https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz;name=mpv \
- http://www.freehackers.org/~tnagy/release/waf-1.8.12;name=waf;subdir=${BPN}-${PV} \
-"
-SRC_URI[mpv.md5sum] = "5c85d1163911e49315a5bf1ca1fae13d"
-SRC_URI[mpv.sha256sum] = "a41854fa0ac35b9c309ad692aaee67c8d4495c3546f11cb4cdd0a124195d3f15"
-SRC_URI[waf.md5sum] = "cef4ee82206b1843db082d0b0506bf71"
-SRC_URI[waf.sha256sum] = "01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f22fca60c98b"
-
-inherit waf pkgconfig pythonnative distro_features_check
-
-# Note: both lua and libass are required to get on-screen-display (controls)
-PACKAGECONFIG ??= "lua libass"
-PACKAGECONFIG[lua] = "--enable-lua,--disable-lua,lua luajit"
-PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass"
-PACKAGECONFIG[libarchive] = "--enable-libarchive,--disable-libarchive,libarchive"
-PACKAGECONFIG[jack] = "--enable-jack, --disable-jack, jack"
-
-SIMPLE_TARGET_SYS = "${@'${TARGET_SYS}'.replace('${TARGET_VENDOR}', '')}"
-EXTRA_OECONF = " \
- --prefix=${prefix} \
- --target=${SIMPLE_TARGET_SYS} \
- --confdir=${sysconfdir} \
- --datadir=${datadir} \
- --disable-manpage-build \
- --disable-gl \
- --disable-libsmbclient \
- --disable-encoding \
- --disable-libbluray \
- --disable-dvdread \
- --disable-dvdnav \
- --disable-cdda \
- --disable-uchardet \
- --disable-rubberband \
- --disable-lcms2 \
- --disable-vapoursynth \
- --disable-vapoursynth-lazy \
- ${PACKAGECONFIG_CONFARGS} \
-"
-
-do_configure_prepend () {
- ln -sf waf-1.8.12 ${S}/waf
- chmod +x ${S}/waf
-}
-
-FILES_${PN} += "${datadir}/icons"
-