aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/classes/kernel-openssl.bbclass11
-rw-r--r--meta-snowyowl/recipes-kernel/amd-spi/amd-spi_1.0.bb2
-rw-r--r--meta-snowyowl/recipes-kernel/amd-wdt/amd-wdt_1.0.bb2
-rw-r--r--meta-snowyowl/recipes-kernel/lttng/lttng-modules_git.bbappend1
4 files changed, 14 insertions, 2 deletions
diff --git a/common/classes/kernel-openssl.bbclass b/common/classes/kernel-openssl.bbclass
new file mode 100644
index 00000000..1837b50e
--- /dev/null
+++ b/common/classes/kernel-openssl.bbclass
@@ -0,0 +1,11 @@
+# Hackish because this should be handled in the actual module
+# classes (module module-base), a kernel with configurations
+# such as CONFIG_MODULE_SIG requires openssl native bits
+# to build properly.
+DEPENDS += "openssl-native"
+do_make_scripts() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ make HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}" \
+ CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
+ -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} scripts
+}
diff --git a/meta-snowyowl/recipes-kernel/amd-spi/amd-spi_1.0.bb b/meta-snowyowl/recipes-kernel/amd-spi/amd-spi_1.0.bb
index b23e5ce6..aacb1039 100644
--- a/meta-snowyowl/recipes-kernel/amd-spi/amd-spi_1.0.bb
+++ b/meta-snowyowl/recipes-kernel/amd-spi/amd-spi_1.0.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "This kernel module provides support for AMD SPI controller driver
LICENSE = "BSD | GPLv2"
LIC_FILES_CHKSUM = "file://spi_amd.c;endline=29;md5=e9fdf6da58412e619d89ec9e135a1be3"
-inherit module
+inherit module kernel-openssl
SRC_URI = "file://Makefile \
file://spi_amd.c \
diff --git a/meta-snowyowl/recipes-kernel/amd-wdt/amd-wdt_1.0.bb b/meta-snowyowl/recipes-kernel/amd-wdt/amd-wdt_1.0.bb
index edaecf5a..e6e3815d 100644
--- a/meta-snowyowl/recipes-kernel/amd-wdt/amd-wdt_1.0.bb
+++ b/meta-snowyowl/recipes-kernel/amd-wdt/amd-wdt_1.0.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "This kernel module provides support for AMD Watchdog driver"
LICENSE = "BSD | GPLv2"
LIC_FILES_CHKSUM = "file://amd_wdt.c;endline=29;md5=8e7a9706367d146e5073510a6e176dc2"
-inherit module
+inherit module kernel-openssl
SRC_URI = "file://Makefile \
file://amd_wdt.c \
diff --git a/meta-snowyowl/recipes-kernel/lttng/lttng-modules_git.bbappend b/meta-snowyowl/recipes-kernel/lttng/lttng-modules_git.bbappend
new file mode 100644
index 00000000..5a800608
--- /dev/null
+++ b/meta-snowyowl/recipes-kernel/lttng/lttng-modules_git.bbappend
@@ -0,0 +1 @@
+inherit kernel-openssl