aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/conf/machine/include/amd-common-configurations.inc1
-rw-r--r--common/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch (renamed from meta-r1000/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch)0
-rw-r--r--common/recipes-core/llvm/llvm_git.bbappend14
-rw-r--r--common/recipes-graphics/drm/libdrm/0001-headers-sync-up-amdgpu_drm.h-with-drm-next.patch35
-rw-r--r--common/recipes-graphics/drm/libdrm_git.bb5
-rw-r--r--common/recipes-graphics/libva/libva_2.1.0.bbappend1
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch (renamed from meta-r1000/recipes-graphics/mesa/files/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch)0
-rw-r--r--common/recipes-graphics/mesa/mesa_git.bb18
-rw-r--r--common/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend (renamed from meta-v1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend)2
-rw-r--r--common/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend2
-rw-r--r--meta-r1000/conf/machine/r1000.conf1
-rw-r--r--meta-r1000/recipes-core/llvm/llvm_git.bbappend15
-rw-r--r--meta-r1000/recipes-graphics/drm/libdrm_git.bbappend3
-rw-r--r--meta-r1000/recipes-graphics/mesa/mesa_git.bbappend18
-rw-r--r--meta-r1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend6
-rw-r--r--meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-amdgpu-patches.scc0
-rw-r--r--meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend3
-rw-r--r--meta-r1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend1
-rw-r--r--meta-v1000/conf/machine/v1000.conf1
-rw-r--r--meta-v1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend1
20 files changed, 32 insertions, 95 deletions
diff --git a/common/conf/machine/include/amd-common-configurations.inc b/common/conf/machine/include/amd-common-configurations.inc
index b6d52110..3755b02e 100644
--- a/common/conf/machine/include/amd-common-configurations.inc
+++ b/common/conf/machine/include/amd-common-configurations.inc
@@ -6,6 +6,7 @@ PREFERRED_PROVIDER_jpeg ?= "jpeg"
PREFERRED_PROVIDER_jpeg-native ?= "jpeg-native"
PREFERRED_VERSION_linux-yocto ?= "4.4%"
PREFERRED_VERSION_libav ?= "9.18"
+PREFERRED_PROVIDER_llvm ?= "llvm7"
MULTILIBS ?= ""
require conf/multilib.conf
diff --git a/meta-r1000/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch b/common/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch
index 7b490a81..7b490a81 100644
--- a/meta-r1000/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch
+++ b/common/recipes-core/llvm/files/0002-llvm-allow-env-override-of-exe-path.patch
diff --git a/common/recipes-core/llvm/llvm_git.bbappend b/common/recipes-core/llvm/llvm_git.bbappend
index 373df6cb..bd77ed77 100644
--- a/common/recipes-core/llvm/llvm_git.bbappend
+++ b/common/recipes-core/llvm/llvm_git.bbappend
@@ -1,2 +1,16 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=c520ed40e11887bb1d24d86f7f5b1f05"
+
+SRCREV = "4a059213dd6f034147e9083c21133dc1b57b3a8a"
+PV = "7"
+BRANCH = "release_70"
+PATCH_VERSION = "0"
+
SRC_URI += "file://0001-llvm-config-allow-overriding-libdir-through-cmdline.patch"
+SRC_URI_remove = "file://0001-Disable-generating-a-native-llvm-config.patch"
+
+INSANE_SKIP_${MLPREFIX}libllvm${LLVM_RELEASE}-llvm-${LLVM_RELEASE}.${PATCH_VERSION}.0 += "dev-so"
+
+PACKAGES =+ "${PN}-testplugin"
+FILES_${PN}-testplugin = "${libdir}/${LLVM_DIR}/TestPlugin.so"
+FILES_${PN}-dbg += "${libdir}/${LLVM_DIR}/.debug/TestPlugin.so"
diff --git a/common/recipes-graphics/drm/libdrm/0001-headers-sync-up-amdgpu_drm.h-with-drm-next.patch b/common/recipes-graphics/drm/libdrm/0001-headers-sync-up-amdgpu_drm.h-with-drm-next.patch
deleted file mode 100644
index 2e6ba6ac..00000000
--- a/common/recipes-graphics/drm/libdrm/0001-headers-sync-up-amdgpu_drm.h-with-drm-next.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 48ec0e7b1203e9fbe4aa8b59642ed0abeb739ab5 Mon Sep 17 00:00:00 2001
-From: Rex Zhu <Rex.Zhu@amd.com>
-Date: Wed, 31 Jan 2018 12:56:44 +0800
-Subject: [PATCH] headers: sync up amdgpu_drm.h with drm-next
-
-Add sensor_info type
-AMDGPU_INFO_SENSOR_STABLE_PSTATE_GFX_MCLK
-AMDGPU_INFO_SENSOR_STABLE_PSTATE_GFX_SCLK
-
-Change-Id: I83c763aee5cd0be21f2ab5734f0d19ffb59a2628
-Acked-by: Junwei Zhang <Jerry.Zhang@amd.com>
-Reviewed-by: Evan Quan <evan.quan@amd.com>
-Signed-off-by: Rex Zhu <Rex.Zhu@amd.com>
----
- include/drm/amdgpu_drm.h | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/include/drm/amdgpu_drm.h b/include/drm/amdgpu_drm.h
-index a023b47..f784f24 100644
---- a/include/drm/amdgpu_drm.h
-+++ b/include/drm/amdgpu_drm.h
-@@ -656,6 +656,10 @@ struct drm_amdgpu_cs_chunk_data {
- #define AMDGPU_INFO_SENSOR_VDDNB 0x6
- /* Subquery id: Query graphics voltage */
- #define AMDGPU_INFO_SENSOR_VDDGFX 0x7
-+ /* Subquery id: Query GPU stable pstate shader clock */
-+ #define AMDGPU_INFO_SENSOR_STABLE_PSTATE_GFX_SCLK 0x8
-+ /* Subquery id: Query GPU stable pstate memory clock */
-+ #define AMDGPU_INFO_SENSOR_STABLE_PSTATE_GFX_MCLK 0x9
- /* Number of VRAM page faults on CPU access. */
- #define AMDGPU_INFO_NUM_VRAM_CPU_PAGE_FAULTS 0x1E
- #define AMDGPU_INFO_VRAM_LOST_COUNTER 0x1F
---
-2.7.4
-
diff --git a/common/recipes-graphics/drm/libdrm_git.bb b/common/recipes-graphics/drm/libdrm_git.bb
index cbca6b72..d516c526 100644
--- a/common/recipes-graphics/drm/libdrm_git.bb
+++ b/common/recipes-graphics/drm/libdrm_git.bb
@@ -9,16 +9,15 @@ SECTION = "x11/base"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://xf86drm.c;beginline=9;endline=32;md5=c8a3b961af7667c530816761e949dc71"
PROVIDES = "drm"
-DRM_VERSION = "2.4.91"
+DRM_VERSION = "2.4.96"
PV = "${DRM_VERSION}+git${SRCPV}"
inherit autotools pkgconfig
-SRCREV = "85ae22af0f209e73c954d8867d9189ab2cfeb3e1"
+SRCREV = "5a3bdc7add2f30f7673052376514c91dbcd1b64a"
DEPENDS = "libpthread-stubs udev libpciaccess freetype libxext cairo fontconfig libxrender libpng pixman"
SRC_URI = "git://anongit.freedesktop.org/mesa/drm;branch=master \
- file://0001-headers-sync-up-amdgpu_drm.h-with-drm-next.patch \
file://amdgpu.ids \
"
diff --git a/common/recipes-graphics/libva/libva_2.1.0.bbappend b/common/recipes-graphics/libva/libva_2.1.0.bbappend
index b28610f4..f8ffae4a 100644
--- a/common/recipes-graphics/libva/libva_2.1.0.bbappend
+++ b/common/recipes-graphics/libva/libva_2.1.0.bbappend
@@ -5,3 +5,4 @@ EXTRA_OECONF_append_amd = " --disable-glx"
PACKAGES_remove_amd = "libva-x11 libva-glx"
# This package (without x11) is no more dependent on mesa
DEPENDS_remove_amd = "virtual/mesa"
+RRECOMMENDS_${PN}_append_amd = " libva-utils"
diff --git a/meta-r1000/recipes-graphics/mesa/files/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch b/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
index d40aaa98..d40aaa98 100644
--- a/meta-r1000/recipes-graphics/mesa/files/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
+++ b/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
diff --git a/common/recipes-graphics/mesa/mesa_git.bb b/common/recipes-graphics/mesa/mesa_git.bb
index 4e38fd06..596b8105 100644
--- a/common/recipes-graphics/mesa/mesa_git.bb
+++ b/common/recipes-graphics/mesa/mesa_git.bb
@@ -5,9 +5,9 @@ S = "${WORKDIR}/git"
DEPENDS_append = " python-mako-native"
inherit pythonnative
-SRCREV_amd = "1f3536b80baf248761ccffcfc59d9fad23933945"
+SRCREV_amd = "0144bbdb98f515cce31688fce57d769e7fd82d52"
LIC_FILES_CHKSUM_amd = "file://docs/license.html;md5=725f991a1cc322aa7a0cd3a2016621c4"
-PV_amd = "18.1.1+git${SRCPV}"
+PV_amd = "19.0.0+git${SRCPV}"
DEPENDS_append_amd = " libvdpau libomxil"
@@ -24,19 +24,20 @@ LIBVA_PLATFORMS .= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' libva-x11',
LIBVA_PLATFORMS .= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', ' libva-wayland', '', d)}"
RDEPENDS_mesa-megadriver += "${@bb.utils.contains('PACKAGECONFIG', 'va', '${LIBVA_PLATFORMS}', '', d)}"
-MESA_LLVM_RELEASE_amd = "6.0"
+MESA_LLVM_RELEASE_amd = "7"
-SRC_URI_amd = "git://anongit.freedesktop.org/mesa/mesa;branch=18.1 \
+SRC_URI_amd = "git://anongit.freedesktop.org/mesa/mesa;branch=master \
file://0001-configure.ac-obey-llvm_prefix-if-available.patch \
- file://0001-configure.ac-adjust-usage-of-LLVM-flags.patch"
+ file://0001-configure.ac-adjust-usage-of-LLVM-flags.patch \
+ file://0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch"
EXTRA_OECONF_append_amd = " \
--enable-vdpau \
--enable-osmesa \
--enable-glx \
--enable-omx-bellagio \
- --with-omx-bellagio-libdir=${libdir}/bellagio \
- --enable-texture-float"
+ --with-omx-bellagio-libdir=${libdir}/bellagio"
+EXTRA_OECONF_remove_amd = "--enable-texture-float"
# Package all the libXvMC gallium extensions together
# they provide the shared lib libXvMCGallium and splitting
@@ -56,9 +57,10 @@ FILES_${PN}-dbg += "${libdir}/vdpau/.debug"
# libomx files are non-versioned so we put *.so directly in the
# main package as opposed to the -dev package.
#
-PACKAGES =+ "libomx-${PN} libomx-${PN}-dev"
+PACKAGES =+ "libomx-${PN} libomx-${PN}-dev ${PN}-driconfigs"
FILES_libomx-${PN} = "${libdir}/bellagio/libomx_*.so"
FILES_libomx-${PN}-dev = "${libdir}/bellagio/libomx_*.la"
+FILES_${PN}-driconfigs = "${datadir}/drirc.d/*"
FILES_${PN}-dbg += "${libdir}/bellagio/.debug"
# Set DRIDRIVERS with anonymous python so we can effectively
diff --git a/meta-v1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend b/common/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend
index 7c661e41..3bb9fae6 100644
--- a/meta-v1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend
+++ b/common/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend
@@ -1,5 +1,5 @@
# Force X to be run on vt7
-do_install_append_v1000() {
+do_install_append_amdgpu() {
if [ -f ${D}${sysconfdir}/default/xserver-nodm ]; then
echo "INPUT_EXTRA_ARGS=vt7" >> ${D}${sysconfdir}/default/xserver-nodm
fi
diff --git a/common/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend b/common/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
index 17f101db..be3d0a0c 100644
--- a/common/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
+++ b/common/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
@@ -1,3 +1,3 @@
PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau"
-PACKAGECONFIG_append_amdgpu = " vdpau"
+PACKAGECONFIG_append_amdgpu = " vdpau vaapi"
PACKAGECONFIG_append_radeon = " vdpau"
diff --git a/meta-r1000/conf/machine/r1000.conf b/meta-r1000/conf/machine/r1000.conf
index c656d290..70f9c113 100644
--- a/meta-r1000/conf/machine/r1000.conf
+++ b/meta-r1000/conf/machine/r1000.conf
@@ -9,7 +9,6 @@ PATCH_VERSION = "0"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
PREFERRED_VERSION_linux-yocto ?= "4.14%"
-PREFERRED_PROVIDER_llvm ?= "llvm7"
require conf/machine/include/tune-r1000.inc
diff --git a/meta-r1000/recipes-core/llvm/llvm_git.bbappend b/meta-r1000/recipes-core/llvm/llvm_git.bbappend
deleted file mode 100644
index 1f2c4ffe..00000000
--- a/meta-r1000/recipes-core/llvm/llvm_git.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=c520ed40e11887bb1d24d86f7f5b1f05"
-
-SRCREV = "4a059213dd6f034147e9083c21133dc1b57b3a8a"
-PV = "7"
-BRANCH = "release_70"
-PATCH_VERSION = "0"
-
-SRC_URI_remove = "file://0001-Disable-generating-a-native-llvm-config.patch"
-
-INSANE_SKIP_${MLPREFIX}libllvm${LLVM_RELEASE}-llvm-${LLVM_RELEASE}.${PATCH_VERSION}.0 += "dev-so"
-
-PACKAGES =+ "${PN}-testplugin"
-FILES_${PN}-testplugin = "${libdir}/${LLVM_DIR}/TestPlugin.so"
-FILES_${PN}-dbg += "${libdir}/${LLVM_DIR}/.debug/TestPlugin.so"
diff --git a/meta-r1000/recipes-graphics/drm/libdrm_git.bbappend b/meta-r1000/recipes-graphics/drm/libdrm_git.bbappend
deleted file mode 100644
index d14d9e46..00000000
--- a/meta-r1000/recipes-graphics/drm/libdrm_git.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-SRCREV_r1000 = "5a3bdc7add2f30f7673052376514c91dbcd1b64a"
-DRM_VERSION_r1000 = "2.4.96"
-SRC_URI_remove_r1000 = "file://0001-headers-sync-up-amdgpu_drm.h-with-drm-next.patch"
diff --git a/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend b/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend
index e21af4fa..5211be22 100644
--- a/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend
+++ b/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend
@@ -1,17 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRCREV_r1000 = "0144bbdb98f515cce31688fce57d769e7fd82d52"
-LIC_FILES_CHKSUM_r1000 = "file://docs/license.html;md5=725f991a1cc322aa7a0cd3a2016621c4"
-PV_r1000 = "19.0.0+git${SRCPV}"
-
-MESA_LLVM_RELEASE_r1000 = "7"
-
-SRC_URI_remove_r1000 = "git://anongit.freedesktop.org/mesa/mesa;branch=18.1"
-SRC_URI_append_r1000 = " git://anongit.freedesktop.org/mesa/mesa;branch=master \
- file://0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch"
-
-PACKAGECONFIG_append_r1000 = " dri3"
-
-EXTRA_OECONF_remove_r1000 = "--enable-texture-float"
-
-PACKAGES += "${PN}-driconfigs"
-FILES_${PN}-driconfigs += "${datadir}/drirc.d/*"
+PACKAGECONFIG_append_r1000 = " dri3" \ No newline at end of file
diff --git a/meta-r1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend b/meta-r1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend
deleted file mode 100644
index db11aade..00000000
--- a/meta-r1000/recipes-graphics/x11-common/xserver-nodm-init_%.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Force X to be run on vt7
-do_install_append_r1000() {
- if [ -f ${D}${sysconfdir}/default/xserver-nodm ]; then
- echo "INPUT_EXTRA_ARGS=vt7" >> ${D}${sysconfdir}/default/xserver-nodm
- fi
-}
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-amdgpu-patches.scc b/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-amdgpu-patches.scc
deleted file mode 100644
index e69de29b..00000000
--- a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-amdgpu-patches.scc
+++ /dev/null
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend b/meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend
index 8cebf430..d71129e0 100644
--- a/meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend
+++ b/meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend
@@ -1,4 +1,3 @@
require linux-yocto-r1000_4.14.inc
-SRC_URI_append_r1000 += "file://r1000-standard-only.cfg \
- file://r1000-amdgpu-patches.scc"
+SRC_URI_append_r1000 += "file://r1000-standard-only.cfg"
diff --git a/meta-r1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend b/meta-r1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
deleted file mode 100644
index 6e603ee9..00000000
--- a/meta-r1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-PACKAGECONFIG_append_r1000 = " vaapi"
diff --git a/meta-v1000/conf/machine/v1000.conf b/meta-v1000/conf/machine/v1000.conf
index 88460aef..27215d63 100644
--- a/meta-v1000/conf/machine/v1000.conf
+++ b/meta-v1000/conf/machine/v1000.conf
@@ -9,7 +9,6 @@ PATCH_VERSION = "0"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
PREFERRED_VERSION_linux-yocto ?= "4.14%"
-PREFERRED_PROVIDER_llvm ?= "llvm6.0"
require conf/machine/include/tune-v1000.inc
diff --git a/meta-v1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend b/meta-v1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
deleted file mode 100644
index 53f3483c..00000000
--- a/meta-v1000/recipes-multimedia/ffmpeg/ffmpeg_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-PACKAGECONFIG_append_v1000 = " vaapi"