aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch13
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch33
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch (renamed from meta-r1000/recipes-graphics/mesa/files/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch)0
-rw-r--r--common/recipes-graphics/mesa/mesa_git.bb4
-rw-r--r--common/recipes-kernel/linux/linux-yocto-4.14.71/5759-mmc-sdhci-add-tuning-error-codes.patch (renamed from meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5759-mmc-sdhci-add-tuning-error-codes.patch)0
-rw-r--r--common/recipes-kernel/linux/linux-yocto-4.14.71/5760-Revert-drm-amdgpu-interim-disable-RV2-GFX-CG-flag-fo.patch (renamed from meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5760-Revert-drm-amdgpu-interim-disable-RV2-GFX-CG-flag-fo.patch)0
-rw-r--r--common/recipes-kernel/linux/linux-yocto-4.14.71/5761-net-phy-marvell10g-remove-XGMII-as-an-option-for-88x.patch (renamed from meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5761-net-phy-marvell10g-remove-XGMII-as-an-option-for-88x.patch)0
-rw-r--r--common/recipes-kernel/linux/linux-yocto-4.14.71/5762-net-phy-marvell10g-update-header-comments.patch (renamed from meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5762-net-phy-marvell10g-update-header-comments.patch)0
-rw-r--r--common/recipes-kernel/linux/linux-yocto-4.14.71/5763-amd-xgbe-Sometimes-driver-report-incorrect-link-stat.patch (renamed from meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5763-amd-xgbe-Sometimes-driver-report-incorrect-link-stat.patch)0
-rw-r--r--common/recipes-kernel/linux/linux-yocto-4.14.71/5764-Revert-drm-amdgpu-enable-gfxoff-in-non-sriov-and-stu.patch (renamed from meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5764-Revert-drm-amdgpu-enable-gfxoff-in-non-sriov-and-stu.patch)0
-rw-r--r--common/recipes-kernel/linux/linux-yocto-4.14.71/5765-drm-amd-powerplay-enable-UMDPSTATE-support-on-raven2.patch (renamed from meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5765-drm-amd-powerplay-enable-UMDPSTATE-support-on-raven2.patch)0
-rw-r--r--common/recipes-kernel/linux/linux-yocto-4.14.71/amd-emmc-patches.scc1
-rw-r--r--common/recipes-kernel/linux/linux-yocto-4.14.71/amd-xgbe-patches.scc3
-rwxr-xr-xcommon/recipes-kernel/linux/linux-yocto-4.14.71/amdgpu-patches.scc4
-rw-r--r--meta-r1000/recipes-graphics/mesa/files/0001-configure.ac-adjust-usage-of-LLVM-flags.patch36
-rw-r--r--meta-r1000/recipes-graphics/mesa/mesa_git.bbappend7
-rw-r--r--meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-amdgpu-patches.scc3
-rw-r--r--meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-emmc-patches.scc1
-rw-r--r--meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-xgbe-patches.scc3
-rw-r--r--meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend5
20 files changed, 16 insertions, 97 deletions
diff --git a/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch b/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
index a6599648..7338cf50 100644
--- a/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
+++ b/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
@@ -1,4 +1,4 @@
-From 223ffdb659ceb8628e38003495b5c6550833b673 Mon Sep 17 00:00:00 2001
+From 5f05454b30da807a02233e99373a37b7c863d5c3 Mon Sep 17 00:00:00 2001
From: Awais Belal <awais_belal@mentor.com>
Date: Thu, 26 Jul 2018 17:13:32 +0500
Subject: [PATCH] configure.ac: adjust usage of LLVM flags
@@ -8,15 +8,16 @@ so using flags from there creates conflicts between
mesa and llvm on the target.
Signed-off-by: Awais Belal <awais_belal@mentor.com>
+
---
configure.ac | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
-index d1c8bb82da..290cc5f9f8 100644
+index f59b29f2d68..893d41f7094 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1064,6 +1064,7 @@ strip_unwanted_llvm_flags() {
+@@ -1101,6 +1101,7 @@ strip_unwanted_llvm_flags() {
-e 's/[[[:space:]]]+-pedantic[[[:space:]]]/ /g' \
-e 's/[[[:space:]]]+-W[[^[:space:]]]*//g' \
-e 's/[[[:space:]]]+-O[[^[:space:]]]*//g' \
@@ -24,7 +25,7 @@ index d1c8bb82da..290cc5f9f8 100644
-e 's/[[[:space:]]]+-g[[^[:space:]]]*//g' \
-e 's/-fno-rtti[[[:space:]]]/-Fno-rtti /g' \
-e 's/[[[:space:]]]+-f[[^[:space:]]]*//g' \
-@@ -2808,7 +2809,7 @@ dnl
+@@ -2900,7 +2901,7 @@ dnl
if test "x$enable_llvm" = xyes; then
DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DMESA_LLVM_VERSION_PATCH=$LLVM_VERSION_PATCH"
@@ -32,6 +33,4 @@ index d1c8bb82da..290cc5f9f8 100644
+ LLVM_LDFLAGS=
LLVM_CFLAGS=$LLVM_CPPFLAGS # CPPFLAGS seem to be sufficient
LLVM_CXXFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cxxflags"`
-
---
-2.11.1
+ LLVM_CXXFLAGS="$CXX11_CXXFLAGS $LLVM_CXXFLAGS"
diff --git a/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch b/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
deleted file mode 100644
index d40aaa98..00000000
--- a/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From ad0ef93a61be1ccd00e3b48bf6913bc2bffb3143 Mon Sep 17 00:00:00 2001
-From: Samuel Pitoiset <samuel.pitoiset@gmail.com>
-Date: Fri, 7 Dec 2018 10:08:38 +0100
-Subject: [PATCH] gallium: add missing PIPE_CAP_SURFACE_SAMPLE_COUNT default
- value
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes: 2710c40e3c8 ("gallium: Add new PIPE_CAP_SURFACE_SAMPLE_COUNT")
-Signed-off-by: Samuel Pitoiset <samuel.pitoiset@gmail.com>
-Tested-by: Michel Dänzer <michel.daenzer@amd.com>
----
- src/gallium/auxiliary/util/u_screen.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/gallium/auxiliary/util/u_screen.c b/src/gallium/auxiliary/util/u_screen.c
-index 95d2a7d5701..6ca3992ecd1 100644
---- a/src/gallium/auxiliary/util/u_screen.c
-+++ b/src/gallium/auxiliary/util/u_screen.c
-@@ -328,6 +328,9 @@ u_pipe_screen_get_param_defaults(struct pipe_screen *pscreen,
- case PIPE_CAP_MAX_VERTEX_ELEMENT_SRC_OFFSET:
- return 2047;
-
-+ case PIPE_CAP_SURFACE_SAMPLE_COUNT:
-+ return 0;
-+
- default:
- unreachable("bad PIPE_CAP_*");
- }
---
-2.11.1
-
diff --git a/meta-r1000/recipes-graphics/mesa/files/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch b/common/recipes-graphics/mesa/mesa/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch
index e487d420..e487d420 100644
--- a/meta-r1000/recipes-graphics/mesa/files/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch
+++ b/common/recipes-graphics/mesa/mesa/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch
diff --git a/common/recipes-graphics/mesa/mesa_git.bb b/common/recipes-graphics/mesa/mesa_git.bb
index 048ce06d..de2e8481 100644
--- a/common/recipes-graphics/mesa/mesa_git.bb
+++ b/common/recipes-graphics/mesa/mesa_git.bb
@@ -5,7 +5,7 @@ S = "${WORKDIR}/git"
DEPENDS_append = " python-mako-native"
inherit pythonnative
-SRCREV_amd = "0144bbdb98f515cce31688fce57d769e7fd82d52"
+SRCREV_amd = "d2c170eb355a912586cb982858faac2fc85c4783"
LIC_FILES_CHKSUM_amd = "file://docs/license.html;md5=725f991a1cc322aa7a0cd3a2016621c4"
PV_amd = "19.0.0+git${SRCPV}"
@@ -27,7 +27,7 @@ RDEPENDS_mesa-megadriver += "${@bb.utils.contains('PACKAGECONFIG', 'va', '${LIBV
SRC_URI_amd = "git://anongit.freedesktop.org/mesa/mesa;branch=master \
file://0001-configure.ac-obey-llvm_prefix-if-available.patch \
file://0001-configure.ac-adjust-usage-of-LLVM-flags.patch \
- file://0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch"
+ file://0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch"
EXTRA_OECONF_append_amd = " \
--enable-vdpau \
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5759-mmc-sdhci-add-tuning-error-codes.patch b/common/recipes-kernel/linux/linux-yocto-4.14.71/5759-mmc-sdhci-add-tuning-error-codes.patch
index 898d0c2d..898d0c2d 100644
--- a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5759-mmc-sdhci-add-tuning-error-codes.patch
+++ b/common/recipes-kernel/linux/linux-yocto-4.14.71/5759-mmc-sdhci-add-tuning-error-codes.patch
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5760-Revert-drm-amdgpu-interim-disable-RV2-GFX-CG-flag-fo.patch b/common/recipes-kernel/linux/linux-yocto-4.14.71/5760-Revert-drm-amdgpu-interim-disable-RV2-GFX-CG-flag-fo.patch
index abd22a27..abd22a27 100644
--- a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5760-Revert-drm-amdgpu-interim-disable-RV2-GFX-CG-flag-fo.patch
+++ b/common/recipes-kernel/linux/linux-yocto-4.14.71/5760-Revert-drm-amdgpu-interim-disable-RV2-GFX-CG-flag-fo.patch
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5761-net-phy-marvell10g-remove-XGMII-as-an-option-for-88x.patch b/common/recipes-kernel/linux/linux-yocto-4.14.71/5761-net-phy-marvell10g-remove-XGMII-as-an-option-for-88x.patch
index e5317536..e5317536 100644
--- a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5761-net-phy-marvell10g-remove-XGMII-as-an-option-for-88x.patch
+++ b/common/recipes-kernel/linux/linux-yocto-4.14.71/5761-net-phy-marvell10g-remove-XGMII-as-an-option-for-88x.patch
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5762-net-phy-marvell10g-update-header-comments.patch b/common/recipes-kernel/linux/linux-yocto-4.14.71/5762-net-phy-marvell10g-update-header-comments.patch
index 692e419f..692e419f 100644
--- a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5762-net-phy-marvell10g-update-header-comments.patch
+++ b/common/recipes-kernel/linux/linux-yocto-4.14.71/5762-net-phy-marvell10g-update-header-comments.patch
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5763-amd-xgbe-Sometimes-driver-report-incorrect-link-stat.patch b/common/recipes-kernel/linux/linux-yocto-4.14.71/5763-amd-xgbe-Sometimes-driver-report-incorrect-link-stat.patch
index 6c869f19..6c869f19 100644
--- a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5763-amd-xgbe-Sometimes-driver-report-incorrect-link-stat.patch
+++ b/common/recipes-kernel/linux/linux-yocto-4.14.71/5763-amd-xgbe-Sometimes-driver-report-incorrect-link-stat.patch
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5764-Revert-drm-amdgpu-enable-gfxoff-in-non-sriov-and-stu.patch b/common/recipes-kernel/linux/linux-yocto-4.14.71/5764-Revert-drm-amdgpu-enable-gfxoff-in-non-sriov-and-stu.patch
index 6f13687e..6f13687e 100644
--- a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5764-Revert-drm-amdgpu-enable-gfxoff-in-non-sriov-and-stu.patch
+++ b/common/recipes-kernel/linux/linux-yocto-4.14.71/5764-Revert-drm-amdgpu-enable-gfxoff-in-non-sriov-and-stu.patch
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5765-drm-amd-powerplay-enable-UMDPSTATE-support-on-raven2.patch b/common/recipes-kernel/linux/linux-yocto-4.14.71/5765-drm-amd-powerplay-enable-UMDPSTATE-support-on-raven2.patch
index f1dd23e9..f1dd23e9 100644
--- a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/5765-drm-amd-powerplay-enable-UMDPSTATE-support-on-raven2.patch
+++ b/common/recipes-kernel/linux/linux-yocto-4.14.71/5765-drm-amd-powerplay-enable-UMDPSTATE-support-on-raven2.patch
diff --git a/common/recipes-kernel/linux/linux-yocto-4.14.71/amd-emmc-patches.scc b/common/recipes-kernel/linux/linux-yocto-4.14.71/amd-emmc-patches.scc
index b7c8d685..45ac77d3 100644
--- a/common/recipes-kernel/linux/linux-yocto-4.14.71/amd-emmc-patches.scc
+++ b/common/recipes-kernel/linux/linux-yocto-4.14.71/amd-emmc-patches.scc
@@ -15,3 +15,4 @@ patch 5737-mmc-sdhci-Add-32-bit-block-count-support-for-v4-mode.patch
patch 5738-mmc-sdhci-Add-Auto-CMD-Auto-Select-support.patch
patch 5746-amd-eMMC-sdhci-HS400-workaround-for-ZP.patch
patch 5758-RTQA4-Fix-build-error-for-hs400-and-hs200.patch
+patch 5759-mmc-sdhci-add-tuning-error-codes.patch
diff --git a/common/recipes-kernel/linux/linux-yocto-4.14.71/amd-xgbe-patches.scc b/common/recipes-kernel/linux/linux-yocto-4.14.71/amd-xgbe-patches.scc
index 32d73c30..9de599b9 100644
--- a/common/recipes-kernel/linux/linux-yocto-4.14.71/amd-xgbe-patches.scc
+++ b/common/recipes-kernel/linux/linux-yocto-4.14.71/amd-xgbe-patches.scc
@@ -20,3 +20,6 @@ patch 5744-net-phy-Add-helper-for-advertise-to-lcl-value.patch
patch 5745-drivers-net-remove-net-busy_poll.h-inclusion-when-no.patch
patch 5749-net-phy-Also-request-modules-for-C45-IDs.patch
patch 5750-amd-xgbe-Fix-mdio-access-for-non-zero-ports-and-clau.patch
+patch 5761-net-phy-marvell10g-remove-XGMII-as-an-option-for-88x.patch
+patch 5762-net-phy-marvell10g-update-header-comments.patch
+patch 5763-amd-xgbe-Sometimes-driver-report-incorrect-link-stat.patch
diff --git a/common/recipes-kernel/linux/linux-yocto-4.14.71/amdgpu-patches.scc b/common/recipes-kernel/linux/linux-yocto-4.14.71/amdgpu-patches.scc
index 0618a367..6788d267 100755
--- a/common/recipes-kernel/linux/linux-yocto-4.14.71/amdgpu-patches.scc
+++ b/common/recipes-kernel/linux/linux-yocto-4.14.71/amdgpu-patches.scc
@@ -5714,4 +5714,6 @@ patch 5754-drm-amdgpu-make-gfx9-enter-into-rlc-safe-mode-when-s.patch
patch 5755-Revert-drm-amdgpu-revert-the-commit-interim-disable-.patch
patch 5756-Revert-drm-amdgpu-revert-psp-firmware-load-status-ch.patch
patch 5757-drm-amdgpu-psp-ignore-psp-response-status.patch
-
+patch 5760-Revert-drm-amdgpu-interim-disable-RV2-GFX-CG-flag-fo.patch
+patch 5764-Revert-drm-amdgpu-enable-gfxoff-in-non-sriov-and-stu.patch
+patch 5765-drm-amd-powerplay-enable-UMDPSTATE-support-on-raven2.patch
diff --git a/meta-r1000/recipes-graphics/mesa/files/0001-configure.ac-adjust-usage-of-LLVM-flags.patch b/meta-r1000/recipes-graphics/mesa/files/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
deleted file mode 100644
index 7338cf50..00000000
--- a/meta-r1000/recipes-graphics/mesa/files/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 5f05454b30da807a02233e99373a37b7c863d5c3 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Thu, 26 Jul 2018 17:13:32 +0500
-Subject: [PATCH] configure.ac: adjust usage of LLVM flags
-
-The llvm-config is provided through a native build
-so using flags from there creates conflicts between
-mesa and llvm on the target.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
-
----
- configure.ac | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index f59b29f2d68..893d41f7094 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1101,6 +1101,7 @@ strip_unwanted_llvm_flags() {
- -e 's/[[[:space:]]]+-pedantic[[[:space:]]]/ /g' \
- -e 's/[[[:space:]]]+-W[[^[:space:]]]*//g' \
- -e 's/[[[:space:]]]+-O[[^[:space:]]]*//g' \
-+ -e 's/[[[:space:]]]+-D_GLIBCXX_USE_CXX11_ABI[[^[:space:]]]*//g' \
- -e 's/[[[:space:]]]+-g[[^[:space:]]]*//g' \
- -e 's/-fno-rtti[[[:space:]]]/-Fno-rtti /g' \
- -e 's/[[[:space:]]]+-f[[^[:space:]]]*//g' \
-@@ -2900,7 +2901,7 @@ dnl
- if test "x$enable_llvm" = xyes; then
- DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DMESA_LLVM_VERSION_PATCH=$LLVM_VERSION_PATCH"
-
-- LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
-+ LLVM_LDFLAGS=
- LLVM_CFLAGS=$LLVM_CPPFLAGS # CPPFLAGS seem to be sufficient
- LLVM_CXXFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cxxflags"`
- LLVM_CXXFLAGS="$CXX11_CXXFLAGS $LLVM_CXXFLAGS"
diff --git a/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend b/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend
index 81e55bc7..03425920 100644
--- a/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend
+++ b/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend
@@ -1,8 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-SRCREV_r1000 = "d2c170eb355a912586cb982858faac2fc85c4783"
-
-SRC_URI_remove_r1000 = "file://0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch"
-SRC_URI_append_r1000 = " file://0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch"
-
PACKAGECONFIG_append_r1000 = " dri3"
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-amdgpu-patches.scc b/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-amdgpu-patches.scc
deleted file mode 100644
index 985d0c9c..00000000
--- a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-amdgpu-patches.scc
+++ /dev/null
@@ -1,3 +0,0 @@
-patch 5760-Revert-drm-amdgpu-interim-disable-RV2-GFX-CG-flag-fo.patch
-patch 5764-Revert-drm-amdgpu-enable-gfxoff-in-non-sriov-and-stu.patch
-patch 5765-drm-amd-powerplay-enable-UMDPSTATE-support-on-raven2.patch
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-emmc-patches.scc b/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-emmc-patches.scc
deleted file mode 100644
index 544ec114..00000000
--- a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-emmc-patches.scc
+++ /dev/null
@@ -1 +0,0 @@
-patch 5759-mmc-sdhci-add-tuning-error-codes.patch
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-xgbe-patches.scc b/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-xgbe-patches.scc
deleted file mode 100644
index 8333e09e..00000000
--- a/meta-r1000/recipes-kernel/linux/linux-yocto-4.14.71/r1000-xgbe-patches.scc
+++ /dev/null
@@ -1,3 +0,0 @@
-patch 5761-net-phy-marvell10g-remove-XGMII-as-an-option-for-88x.patch
-patch 5762-net-phy-marvell10g-update-header-comments.patch
-patch 5763-amd-xgbe-Sometimes-driver-report-incorrect-link-stat.patch
diff --git a/meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend b/meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend
index 93e2f4b8..9f13e492 100644
--- a/meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend
+++ b/meta-r1000/recipes-kernel/linux/linux-yocto_4.14.bbappend
@@ -1,6 +1,3 @@
require linux-yocto-r1000_4.14.inc
-SRC_URI_append_r1000 = " file://r1000-standard-only.cfg \
- file://r1000-amdgpu-patches.scc \
- file://r1000-emmc-patches.scc \
- file://r1000-xgbe-patches.scc"
+SRC_URI_append_r1000 = " file://r1000-standard-only.cfg"