aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch13
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch33
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch (renamed from meta-r1000/recipes-graphics/mesa/files/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch)0
-rw-r--r--common/recipes-graphics/mesa/mesa_git.bb4
-rw-r--r--meta-r1000/recipes-graphics/mesa/files/0001-configure.ac-adjust-usage-of-LLVM-flags.patch36
-rw-r--r--meta-r1000/recipes-graphics/mesa/mesa_git.bbappend7
6 files changed, 8 insertions, 85 deletions
diff --git a/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch b/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
index a6599648..7338cf50 100644
--- a/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
+++ b/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
@@ -1,4 +1,4 @@
-From 223ffdb659ceb8628e38003495b5c6550833b673 Mon Sep 17 00:00:00 2001
+From 5f05454b30da807a02233e99373a37b7c863d5c3 Mon Sep 17 00:00:00 2001
From: Awais Belal <awais_belal@mentor.com>
Date: Thu, 26 Jul 2018 17:13:32 +0500
Subject: [PATCH] configure.ac: adjust usage of LLVM flags
@@ -8,15 +8,16 @@ so using flags from there creates conflicts between
mesa and llvm on the target.
Signed-off-by: Awais Belal <awais_belal@mentor.com>
+
---
configure.ac | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
-index d1c8bb82da..290cc5f9f8 100644
+index f59b29f2d68..893d41f7094 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1064,6 +1064,7 @@ strip_unwanted_llvm_flags() {
+@@ -1101,6 +1101,7 @@ strip_unwanted_llvm_flags() {
-e 's/[[[:space:]]]+-pedantic[[[:space:]]]/ /g' \
-e 's/[[[:space:]]]+-W[[^[:space:]]]*//g' \
-e 's/[[[:space:]]]+-O[[^[:space:]]]*//g' \
@@ -24,7 +25,7 @@ index d1c8bb82da..290cc5f9f8 100644
-e 's/[[[:space:]]]+-g[[^[:space:]]]*//g' \
-e 's/-fno-rtti[[[:space:]]]/-Fno-rtti /g' \
-e 's/[[[:space:]]]+-f[[^[:space:]]]*//g' \
-@@ -2808,7 +2809,7 @@ dnl
+@@ -2900,7 +2901,7 @@ dnl
if test "x$enable_llvm" = xyes; then
DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DMESA_LLVM_VERSION_PATCH=$LLVM_VERSION_PATCH"
@@ -32,6 +33,4 @@ index d1c8bb82da..290cc5f9f8 100644
+ LLVM_LDFLAGS=
LLVM_CFLAGS=$LLVM_CPPFLAGS # CPPFLAGS seem to be sufficient
LLVM_CXXFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cxxflags"`
-
---
-2.11.1
+ LLVM_CXXFLAGS="$CXX11_CXXFLAGS $LLVM_CXXFLAGS"
diff --git a/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch b/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
deleted file mode 100644
index d40aaa98..00000000
--- a/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From ad0ef93a61be1ccd00e3b48bf6913bc2bffb3143 Mon Sep 17 00:00:00 2001
-From: Samuel Pitoiset <samuel.pitoiset@gmail.com>
-Date: Fri, 7 Dec 2018 10:08:38 +0100
-Subject: [PATCH] gallium: add missing PIPE_CAP_SURFACE_SAMPLE_COUNT default
- value
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes: 2710c40e3c8 ("gallium: Add new PIPE_CAP_SURFACE_SAMPLE_COUNT")
-Signed-off-by: Samuel Pitoiset <samuel.pitoiset@gmail.com>
-Tested-by: Michel Dänzer <michel.daenzer@amd.com>
----
- src/gallium/auxiliary/util/u_screen.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/gallium/auxiliary/util/u_screen.c b/src/gallium/auxiliary/util/u_screen.c
-index 95d2a7d5701..6ca3992ecd1 100644
---- a/src/gallium/auxiliary/util/u_screen.c
-+++ b/src/gallium/auxiliary/util/u_screen.c
-@@ -328,6 +328,9 @@ u_pipe_screen_get_param_defaults(struct pipe_screen *pscreen,
- case PIPE_CAP_MAX_VERTEX_ELEMENT_SRC_OFFSET:
- return 2047;
-
-+ case PIPE_CAP_SURFACE_SAMPLE_COUNT:
-+ return 0;
-+
- default:
- unreachable("bad PIPE_CAP_*");
- }
---
-2.11.1
-
diff --git a/meta-r1000/recipes-graphics/mesa/files/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch b/common/recipes-graphics/mesa/mesa/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch
index e487d420..e487d420 100644
--- a/meta-r1000/recipes-graphics/mesa/files/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch
+++ b/common/recipes-graphics/mesa/mesa/0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch
diff --git a/common/recipes-graphics/mesa/mesa_git.bb b/common/recipes-graphics/mesa/mesa_git.bb
index 048ce06d..de2e8481 100644
--- a/common/recipes-graphics/mesa/mesa_git.bb
+++ b/common/recipes-graphics/mesa/mesa_git.bb
@@ -5,7 +5,7 @@ S = "${WORKDIR}/git"
DEPENDS_append = " python-mako-native"
inherit pythonnative
-SRCREV_amd = "0144bbdb98f515cce31688fce57d769e7fd82d52"
+SRCREV_amd = "d2c170eb355a912586cb982858faac2fc85c4783"
LIC_FILES_CHKSUM_amd = "file://docs/license.html;md5=725f991a1cc322aa7a0cd3a2016621c4"
PV_amd = "19.0.0+git${SRCPV}"
@@ -27,7 +27,7 @@ RDEPENDS_mesa-megadriver += "${@bb.utils.contains('PACKAGECONFIG', 'va', '${LIBV
SRC_URI_amd = "git://anongit.freedesktop.org/mesa/mesa;branch=master \
file://0001-configure.ac-obey-llvm_prefix-if-available.patch \
file://0001-configure.ac-adjust-usage-of-LLVM-flags.patch \
- file://0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch"
+ file://0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch"
EXTRA_OECONF_append_amd = " \
--enable-vdpau \
diff --git a/meta-r1000/recipes-graphics/mesa/files/0001-configure.ac-adjust-usage-of-LLVM-flags.patch b/meta-r1000/recipes-graphics/mesa/files/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
deleted file mode 100644
index 7338cf50..00000000
--- a/meta-r1000/recipes-graphics/mesa/files/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 5f05454b30da807a02233e99373a37b7c863d5c3 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Thu, 26 Jul 2018 17:13:32 +0500
-Subject: [PATCH] configure.ac: adjust usage of LLVM flags
-
-The llvm-config is provided through a native build
-so using flags from there creates conflicts between
-mesa and llvm on the target.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
-
----
- configure.ac | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index f59b29f2d68..893d41f7094 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1101,6 +1101,7 @@ strip_unwanted_llvm_flags() {
- -e 's/[[[:space:]]]+-pedantic[[[:space:]]]/ /g' \
- -e 's/[[[:space:]]]+-W[[^[:space:]]]*//g' \
- -e 's/[[[:space:]]]+-O[[^[:space:]]]*//g' \
-+ -e 's/[[[:space:]]]+-D_GLIBCXX_USE_CXX11_ABI[[^[:space:]]]*//g' \
- -e 's/[[[:space:]]]+-g[[^[:space:]]]*//g' \
- -e 's/-fno-rtti[[[:space:]]]/-Fno-rtti /g' \
- -e 's/[[[:space:]]]+-f[[^[:space:]]]*//g' \
-@@ -2900,7 +2901,7 @@ dnl
- if test "x$enable_llvm" = xyes; then
- DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DMESA_LLVM_VERSION_PATCH=$LLVM_VERSION_PATCH"
-
-- LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
-+ LLVM_LDFLAGS=
- LLVM_CFLAGS=$LLVM_CPPFLAGS # CPPFLAGS seem to be sufficient
- LLVM_CXXFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cxxflags"`
- LLVM_CXXFLAGS="$CXX11_CXXFLAGS $LLVM_CXXFLAGS"
diff --git a/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend b/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend
index 81e55bc7..03425920 100644
--- a/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend
+++ b/meta-r1000/recipes-graphics/mesa/mesa_git.bbappend
@@ -1,8 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-SRCREV_r1000 = "d2c170eb355a912586cb982858faac2fc85c4783"
-
-SRC_URI_remove_r1000 = "file://0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch"
-SRC_URI_append_r1000 = " file://0001-vl-dri3-remove-the-wait-before-getting-back-buffer.patch"
-
PACKAGECONFIG_append_r1000 = " dri3"