aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amdfalconx86
diff options
context:
space:
mode:
authorAwais Belal <awais_belal@mentor.com>2018-02-14 14:38:33 +0500
committerAwais Belal <awais_belal@mentor.com>2018-02-14 14:38:38 +0500
commitf88c52d4fce13b30dd5cf84985133a6471c8d013 (patch)
tree82abcd496f1e2a8a79b7d3a5adac4d70ea5c2805 /meta-amdfalconx86
parentec42c33e5d036d1e616e78f44352be8f362f4e0d (diff)
downloadmeta-amd-f88c52d4fce13b30dd5cf84985133a6471c8d013.tar.gz
meta-amd-f88c52d4fce13b30dd5cf84985133a6471c8d013.tar.bz2
meta-amd-f88c52d4fce13b30dd5cf84985133a6471c8d013.zip
vulkan-tools: fix build error with Qt5
The vulkan-tools configuration process checks for Qt5 _and_ Qt5Svg availability before enabling the traceviewer but our enablement of the feature only checks for Qt5 layer which creates a discrepancy. This ends up in an installation failure when we try to manually install traceviewer binary which is skipped during the build process due to the above reason. We fix this by depending upon the qtsvg package as well which is checked for during the configuration process otherwise a race condition would cause undesireable/unknown condition. Signed-off-by: Awais Belal <awais_belal@mentor.com>
Diffstat (limited to 'meta-amdfalconx86')
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb
index ad324dce..5a6761c6 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.26.bb
@@ -57,7 +57,7 @@ do_install_append() {
# Conditional building of vktraceviewer
QTBITS ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'cmake_qt5', '',d)}"
inherit ${QTBITS}
-DEPENDS += "${@base_conditional('QTBITS', '', '', 'libxcb', d)}"
+DEPENDS += "${@base_conditional('QTBITS', '', '', 'libxcb qtsvg', d)}"
RDEPENDS_${PN}_append = " ${@base_conditional('QTBITS', '', '', 'qtsvg', d)}"
do_install_append() {
if [ "${QTBITS}" != "" ]