aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amdfalconx86
diff options
context:
space:
mode:
authorAwais Belal <awais_belal@mentor.com>2016-10-26 14:19:18 +0500
committerAwais Belal <awais_belal@mentor.com>2016-10-27 11:43:53 +0500
commit5aa85fc5ce18ed700972de35b02d64608801ceba (patch)
tree425b9221f83a66207e7b76c3c2e8616c776c1dbb /meta-amdfalconx86
parent2cf5d7bc9728753b4c1bb52c491637c03652d98a (diff)
downloadmeta-amd-5aa85fc5ce18ed700972de35b02d64608801ceba.tar.gz
meta-amd-5aa85fc5ce18ed700972de35b02d64608801ceba.tar.bz2
meta-amd-5aa85fc5ce18ed700972de35b02d64608801ceba.zip
glslang: add to nativesdk
The glslangValidator is required for application development on the host through CodeBench. Signed-off-by: Awais Belal <awais_belal@mentor.com>
Diffstat (limited to 'meta-amdfalconx86')
-rw-r--r--meta-amdfalconx86/conf/machine/amdfalconx86.conf2
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang_git.bb2
2 files changed, 3 insertions, 1 deletions
diff --git a/meta-amdfalconx86/conf/machine/amdfalconx86.conf b/meta-amdfalconx86/conf/machine/amdfalconx86.conf
index 9788ed8e..a6aff156 100644
--- a/meta-amdfalconx86/conf/machine/amdfalconx86.conf
+++ b/meta-amdfalconx86/conf/machine/amdfalconx86.conf
@@ -43,4 +43,6 @@ KERNEL_SERIAL_CONSOLE = "console=ttyS0,115200n8"
# Enable powerplay
APPEND += "amdgpu.powerplay=1 amdgpu.pg_mask=0"
+TOOLCHAIN_HOST_TASK_append = " ${@bb.utils.contains('INCLUDE_GAMING_COMPONENTS', 'yes', "nativesdk-glslang", "", d)}"
+
MACHINEOVERRIDES =. "amd:amdx86:amdgpu:"
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang_git.bb b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang_git.bb
index 0ddd1efa..15852cac 100644
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang_git.bb
+++ b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/glslang_git.bb
@@ -20,7 +20,7 @@ SRC_URI = "git://github.com/KhronosGroup/glslang \
FILES_${PN} += "${libdir}/*"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
do_install_append() {
# Some of the vulkan samples/test require these headers