aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..92f9f65
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,15 @@
+PREFIXDIR = $(prefix)
+PKGDATADIR = $(pkgdatadir)
+DATADIR = $(datadir)
+
+INCLUDES = -DDATADIR=\"$(DATADIR)\" -DPKGDATADIR=\"$(PKGDATADIR)\" -DPREFIX=\"$(PREFIXDIR)\" $(LIBMB_CFLAGS)
+
+bin_PROGRAMS = matchbox-panel
+
+matchbox_panel_LDADD = $(LIBMB_LIBS)
+
+matchbox_panel_SOURCES = \
+ panel.c panel_app.c panel_menu.c panel_util.c session.c msg.c \
+ panel.h panel_app.h panel_menu.h panel_util.h session.h msg.h
+
+