aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..b772f12
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,35 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.53)
+AC_INIT([mbpanelmgr], 0.1, [mallum@handhelds.org])
+AC_CONFIG_SRCDIR([mbpanelmgr.c])
+
+AM_INIT_AUTOMAKE()
+AM_MAINTAINER_MODE
+AM_CONFIG_HEADER(config.h)
+
+# Checks for programs.
+AC_PROG_CC
+
+PKG_CHECK_MODULES(MBPANELMGR, gtk+-2.0)
+
+if test "x$GCC" = "xyes"; then
+ GCC_WARNINGS="-Wall -fno-strict-aliasing"
+ XLIBS_CFLAGS="$GCC_WARNINGS"
+fi
+
+AC_SUBST(MBPANELMGR_CFLAGS)
+AC_SUBST(MBPANELMGR_LIBS)
+
+# Checks for header files.
+
+AC_HEADER_STDC
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_PID_T
+
+# Checks for library functions.
+
+AC_OUTPUT([Makefile])