aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ab0c899..45c9485 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,11 +10,13 @@ AC_PROG_CC
AC_STDC_HEADERS
AC_PROG_LIBTOOL
+# base deps
PKG_CHECK_MODULES(MATCHBOX_PANEL,
glib-2.0
gtk+-2.0 >= 2.6
gmodule-2.0)
+# startup-notification
AC_ARG_ENABLE(startup_notification,
[ --enable-startup-notification enable startup notification support],
enable_startup_notification=$enableval, enable_startup_notification=yes )
@@ -26,6 +28,7 @@ if test x$enable_startup_notification != xno; then
AC_DEFINE(USE_LIBSN, [1], [Has Startup Notification Support])
fi
+# libnotify
AC_ARG_ENABLE(libnotify,
[ --enable-libnotify enable libnotify support],
enable_libnotify=$enableval, enable_libnotify=yes )
@@ -37,9 +40,15 @@ if test x$enable_libnotify != xno; then
AC_DEFINE(USE_LIBNOTIFY, [1], [Has libnotify Support])
fi
+# apm
+AC_CHECK_HEADERS(apm.h, enable_linux_apm=yes, enable_linux_apm=no)
+AM_CONDITIONAL(HAVE_LIBAPM, test x$enable_linux_apm = xyes)
+
+# glib-genmarshal
GLIB_GENMARSHAL=`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`
AC_SUBST(GLIB_GENMARSHAL)
+# gettext
GETTEXT_PACKAGE=matchbox-panel
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, ["$GETTEXT_PACKAGE"],
@@ -48,6 +57,7 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, ["$GETTEXT_PACKAGE"],
ALL_LINGUAS=""
AM_GLIB_GNU_GETTEXT
+# output stuff
AC_OUTPUT([
Makefile
matchbox-panel.pc
@@ -56,6 +66,7 @@ applets/Makefile
applets/clock/Makefile
applets/launcher/Makefile
applets/systray/Makefile
+applets/battery/Makefile
po/Makefile.in
po/Makefile
])