aboutsummaryrefslogtreecommitdiffstats
path: root/applets/systray/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'applets/systray/Makefile.am')
-rw-r--r--applets/systray/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/applets/systray/Makefile.am b/applets/systray/Makefile.am
index f49068d..b42dfef 100644
--- a/applets/systray/Makefile.am
+++ b/applets/systray/Makefile.am
@@ -8,7 +8,8 @@ appletdir = $(pkglibdir)
applet_LTLIBRARIES = libsystray.la
%.c: %.list
- $(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_na_marshal $^ --body > $@
+ $(AM_V_GEN) (echo "#include \"na-marshal.h\""; \
+ $(GLIB_GENMARSHAL) --internal --prefix=_na_marshal $^ --body) > $@
%.h: %.list
$(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_na_marshal $^ --header > $@