aboutsummaryrefslogtreecommitdiffstats
path: root/applets/notify/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'applets/notify/Makefile.am')
-rw-r--r--applets/notify/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/applets/notify/Makefile.am b/applets/notify/Makefile.am
index 53e7946..3ae8b94 100644
--- a/applets/notify/Makefile.am
+++ b/applets/notify/Makefile.am
@@ -22,9 +22,10 @@ DBUS_GLUE=notification-manager-glue.h
MARSHALS = marshal.c marshal.h
%.c: %.list
- $(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=mb_marshal $^ --body > $@
+ $(AM_V_GEN) (echo "#include \"marshal.h\""; \
+ $(GLIB_GENMARSHAL) --internal --prefix=mb_marshal $^ --body) > $@
%.h: %.list
- $(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=mb_marshal $^ --header > $@
+ $(AM_V_GEN) $(GLIB_GENMARSHAL) --internal --prefix=mb_marshal $^ --header > $@
BUILT_SOURCES = $(DBUS_GLUE) $(MARSHALS)
CLEANFILES = $(BUILT_SOURCES)