aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/stackdelta
diff options
context:
space:
mode:
authorKamil Rytarowski <n54@gmx.com>2017-05-07 23:25:26 +0200
committerMasahiro Yamada <yamada.masahiro@socionext.com>2017-05-14 11:20:44 +0900
commitcb77f0d623ff33a7899cb945f4f5a4825fbb2ea1 (patch)
tree4de662eee07903e11e20750f15e134a34928d5b6 /scripts/stackdelta
parent2ea659a9ef488125eb46da6eb571de5eae5c43f6 (diff)
downloadlinux-yocto-cb77f0d623ff33a7899cb945f4f5a4825fbb2ea1.tar.gz
linux-yocto-cb77f0d623ff33a7899cb945f4f5a4825fbb2ea1.tar.bz2
linux-yocto-cb77f0d623ff33a7899cb945f4f5a4825fbb2ea1.zip
scripts: Switch to more portable Perl shebang
The default NetBSD package manager is pkgsrc and it installs Perl along other third party programs under custom and configurable prefix. The default prefix for binary prebuilt packages is /usr/pkg, and the Perl executable lands in /usr/pkg/bin/perl. This change switches "/usr/bin/perl" to "/usr/bin/env perl" as it's the most portable solution that should work for almost everybody. Perl's executable is detected automatically. This change switches -w option passed to the executable with more modern "use warnings;" approach. There is no functional change to the default behavior. While there, drop "require 5" from scripts/namespace.pl (Perl from 1994?). Signed-off-by: Kamil Rytarowski <n54@gmx.com> Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
Diffstat (limited to 'scripts/stackdelta')
-rwxr-xr-xscripts/stackdelta2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/stackdelta b/scripts/stackdelta
index 48eabf2f48f8..20a79f19a111 100755
--- a/scripts/stackdelta
+++ b/scripts/stackdelta
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!/usr/bin/env perl
# Read two files produced by the stackusage script, and show the
# delta between them.