aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..7e7e61d
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,18 @@
+AC_PREREQ(2.52)
+AC_INIT(libowl, 0.0, http://o-hand.com)
+AC_CONFIG_SRCDIR(libowl/owlpaned.c)
+AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
+AM_CONFIG_HEADER(libowl/config.h)
+AM_MAINTAINER_MODE
+
+AM_PROG_LIBTOOL
+
+PKG_CHECK_MODULES(GTK, gtk+-2.0)
+AC_SUBST(GTK_CFLAGS)
+AC_SUBST(GTK_LIBS)
+
+AC_OUTPUT([
+Makefile
+libowl/Makefile
+tests/Makefile
+])