aboutsummaryrefslogtreecommitdiffstats
path: root/matchbox2/theme-engines/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'matchbox2/theme-engines/Makefile.am')
-rw-r--r--matchbox2/theme-engines/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/matchbox2/theme-engines/Makefile.am b/matchbox2/theme-engines/Makefile.am
new file mode 100644
index 0000000..ee7f594
--- /dev/null
+++ b/matchbox2/theme-engines/Makefile.am
@@ -0,0 +1,19 @@
+
+if THEME_PNG
+PNG_SRC = mb-wm-theme-png.c mb-wm-theme-png.h
+endif
+
+COMMON_SRC = mb-wm-theme.h mb-wm-theme.c mb-wm-theme-xml.h mb-wm-theme-xml.c
+
+pkgincludedir = $(includedir)/$(MBWM2_INCDIR)/theme-engines
+
+if ENABLE_LIBMATCHBOX
+pkginclude_HEADERS = mb-wm-theme.h mb-wm-theme-png.h mb-wm-theme-xml.h
+endif
+noinst_LTLIBRARIES = libmb-theme.la
+libmb_theme_la_SOURCES = $(COMMON_SRC) $(PNG_SRC)
+libmb_theme_la_CFLAGS =
+
+INCLUDES = $(MBWM_INCS) $(MBWM_CFLAGS) -DDATADIR=\"$(datadir)\"
+
+MAINTAINERCLEANFILES = config.h.in Makefile.in