aboutsummaryrefslogtreecommitdiffstats
path: root/matchbox2/client-types/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'matchbox2/client-types/Makefile.am')
-rw-r--r--matchbox2/client-types/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/matchbox2/client-types/Makefile.am b/matchbox2/client-types/Makefile.am
new file mode 100644
index 0000000..8bb7990
--- /dev/null
+++ b/matchbox2/client-types/Makefile.am
@@ -0,0 +1,52 @@
+if ENABLE_COMPOSITE
+compmgr_libs = libmb-wm-client-override.la
+compmgr_ltlibs = libmb-wm-client-override.la
+endif
+
+THEME_LIBS = $(MBWM_THEME_LIBS)/libmb-theme.la
+
+INCLUDES = $(MBWM_INCS) $(MBWM_CFLAGS)
+LDADD =$(THEME_LIBS)
+DEPENDENCIES = $(THEME_LIBS)
+
+pkgincludedir = $(includedir)/$(MBWM2_INCDIR)/client-types
+
+if ENABLE_LIBMATCHBOX
+pkginclude_HEADERS = mb-wm-client-app.h \
+ mb-wm-client-dialog.h \
+ mb-wm-client-menu.h \
+ mb-wm-client-override.h \
+ mb-wm-client-desktop.h \
+ mb-wm-client-input.h \
+ mb-wm-client-note.h \
+ mb-wm-client-panel.h
+endif
+
+noinst_LTLIBRARIES = libmb-wm-client-app.la \
+ libmb-wm-client-panel.la \
+ libmb-wm-client-dialog.la \
+ libmb-wm-client-note.la \
+ libmb-wm-client-input.la \
+ libmb-wm-client-desktop.la \
+ libmb-wm-client-menu.la \
+ $(compmgr_ltlibs)
+
+libmb_wm_client_app_la_SOURCES = mb-wm-client-app.c mb-wm-client-app.h
+libmb_wm_client_panel_la_SOURCES = mb-wm-client-panel.c mb-wm-client-panel.h
+libmb_wm_client_dialog_la_SOURCES = mb-wm-client-dialog.c mb-wm-client-dialog.h
+libmb_wm_client_note_la_SOURCES = mb-wm-client-note.c mb-wm-client-note.h
+libmb_wm_client_input_la_SOURCES = mb-wm-client-input.c mb-wm-client-input.h
+libmb_wm_client_desktop_la_SOURCES = mb-wm-client-desktop.c mb-wm-client-desktop.h
+libmb_wm_client_menu_la_SOURCES = mb-wm-client-menu.c mb-wm-client-menu.h
+libmb_wm_client_override_la_SOURCES= mb-wm-client-override.c \
+ mb-wm-client-override.h
+libmb_wm_client_app_la_CFLAGS =
+libmb_wm_client_panel_la_CFLAGS =
+libmb_wm_client_dialog_la_CFLAGS =
+libmb_wm_client_note_la_CFLAGS =
+libmb_wm_client_input_la_CFLAGS =
+libmb_wm_client_desktop_la_CFLAGS =
+libmb_wm_client_menu_la_CFLAGS =
+libmb_wm_client_override_la_CFLAGS =
+
+MAINTAINERCLEANFILES = config.h.in Makefile.in