aboutsummaryrefslogtreecommitdiffstats
path: root/matchbox2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'matchbox2/Makefile.am')
-rw-r--r--matchbox2/Makefile.am114
1 files changed, 91 insertions, 23 deletions
diff --git a/matchbox2/Makefile.am b/matchbox2/Makefile.am
index 3f90f3c..47dfdc8 100644
--- a/matchbox2/Makefile.am
+++ b/matchbox2/Makefile.am
@@ -1,31 +1,99 @@
-if ENABLE_COMPOSITE
-comp=comp-mgr
-complib= \
- client-types/libmb-wm-client-override.la \
- $(comp)/libmatchbox-window-manager-2-compmgr.la
-endif
-MAINTAINERCLEANFILES = Makefile.in
+lib_LTLIBRARIES = libmatchbox2-@MBWM2_API_VERSION@.la
-pkgincludedir = $(includedir)/$(MBWM2_INCDIR)
+source_public_h = \
+ mb-wm.h
-SUBDIRS = core client-types theme-engines $(comp)
+# Core...
+source = \
+ mb-wm-types.h \
+ mb-wm-macros.h \
+ mb-wm-object.h \
+ mb-wm-object-props.h \
+ mb-wm-object.c \
+ mb-wm-debug.h \
+ mb-wm-debug.c \
+ mb-wm-client.h \
+ mb-wm-client.c \
+ mb-wm-client-base.h \
+ mb-wm-client-base.c \
+ mb-wm-client-window.h \
+ mb-wm-client-window.c \
+ mb-wm-root-window.h \
+ mb-wm-root-window.c \
+ mb-wm-stack.h \
+ mb-wm-stack.c \
+ mb-wm-props.h \
+ mb-wm-props.c \
+ mb-wm-util.h \
+ mb-wm-util.c \
+ mb-wm-atoms.h \
+ mb-wm-atoms.c \
+ mb-wm-layout.h \
+ mb-wm-layout.c \
+ mb-wm-keys.h \
+ mb-wm-keys.c \
+ mb-wm-decor.h \
+ mb-wm-decor.c \
+ mb-window-manager.h \
+ mb-window-manager.c \
+ mb-wm-main-context.h \
+ mb-wm-main-context.c \
+ xas.h \
+ xas.c
-lib_LTLIBRARIES = libmatchbox2-@MBWM2_API_VERSION@.la
+# Client window types...
+source += \
+ mb-wm-client-app.h \
+ mb-wm-client-app.c \
+ mb-wm-client-panel.h \
+ mb-wm-client-panel.c \
+ mb-wm-client-dialog.h \
+ mb-wm-client-dialog.c \
+ mb-wm-client-note.h \
+ mb-wm-client-note.c \
+ mb-wm-client-input.h \
+ mb-wm-client-input.c \
+ mb-wm-client-desktop.h \
+ mb-wm-client-desktop.c \
+ mb-wm-client-menu.h \
+ mb-wm-client-menu.c \
+ mb-wm-client-override.h \
+ mb-wm-client-override.c
+
+
+# Compositing...
+if ENABLE_COMPOSITE
+source += mb-wm-comp-mgr.h
+source += mb-wm-comp-mgr.c
+if COMP_MGR_BACKEND
+if ENABLE_CLUTTER_COMPOSITE_MANAGER
+source += mb-wm-comp-mgr-clutter.h
+source += mb-wm-comp-mgr-clutter.c
+else
+source += mb-wm-comp-mgr-xrender.h
+source += mb-wm-comp-mgr-xrender.c
+endif
+endif
+
+endif #ENABLE_COMPOSITE
+
+# Theming...
+source += \
+ mb-wm-theme.h \
+ mb-wm-theme.c \
+ mb-wm-theme-xml.h \
+ mb-wm-theme-xml.c
+
+if THEME_PNG
+source += mb-wm-theme-png.c mb-wm-theme-png.h
+endif
-libmatchbox2_@MBWM2_API_VERSION@_la_LIBADD = \
- core/libmatchbox-window-manager-2-core.la \
- client-types/libmb-wm-client-app.la \
- client-types/libmb-wm-client-desktop.la \
- client-types/libmb-wm-client-dialog.la \
- client-types/libmb-wm-client-input.la \
- client-types/libmb-wm-client-menu.la \
- client-types/libmb-wm-client-note.la \
- client-types/libmb-wm-client-panel.la \
- theme-engines/libmb-theme.la \
- $(complib)
+pkgincludedir = $(includedir)/$(MBWM2_INCDIR)/matchbox2
+pkginclude_HEADERS = $(source_public_h)
-libmatchbox2_@MBWM2_API_VERSION@_la_SOURCES =
+libmatchbox2_@MBWM2_API_VERSION@_la_SOURCES = $(source_public_h) $(source)
+libmatchbox2_@MBWM2_API_VERSION@_la_CFLAGS = $(MBWM_INCS) $(MBWM_CFLAGS) -DDATADIR=\"$(datadir)\"
+libmatchbox2_@MBWM2_API_VERSION@_la_LIBADD = $(MBWM_LIBS)
-pkginclude_HEADERS = *.h